Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jul 28 21:09
    sheila-arroyo-fw starred MscrmTools/XrmToolBox
  • Jul 22 06:56
    MscrmTools closed #1056
  • Jul 21 20:51
    samalex1701 labeled #1056
  • Jul 21 20:51
    samalex1701 opened #1056
  • Jul 20 10:24
    georged labeled #1055
  • Jul 20 10:24
    georged opened #1055
  • Jul 20 10:10
    georged labeled #1054
  • Jul 20 10:10
    georged opened #1054
  • Jul 16 09:21
    MscrmTools closed #1053
  • Jul 16 00:51
    SwatiLavi labeled #1053
  • Jul 16 00:51
    SwatiLavi opened #1053
  • Jul 15 07:09
    MscrmTools closed #1052
  • Jul 12 19:53
    simes1 opened #1052
  • Jul 11 08:43
    NJWorld starred MscrmTools/XrmToolBox
  • Jul 09 13:04
    MscrmTools closed #1051
  • Jul 09 13:04
    MscrmTools labeled #1051
  • Jul 09 13:04
    MscrmTools unlabeled #1051
  • Jul 09 12:50
    ilis18 labeled #1051
  • Jul 09 12:50
    ilis18 opened #1051
  • Jul 08 10:11
    rappen labeled #1050
Ziv
@ZivBenOr
image.png
MscrmTools
@MscrmTools
Can you untick tick checkboxes?
Ziv
@ZivBenOr
Yes
MscrmTools
@MscrmTools
And it does not change the display of tools?
Ziv
@ZivBenOr
No
MscrmTools
@MscrmTools
Let me try
Ziv
@ZivBenOr
How?
MscrmTools
@MscrmTools
I just tested with a new installation. If you untick everything then tick again, tools should show up
Ziv
@ZivBenOr
You meen the catagories?
mean
MscrmTools
@MscrmTools
Not categories, the ones under "Display Tools"
Ziv
@ZivBenOr
OK, now i can see
:-)
It's a bug?
MscrmTools
@MscrmTools
I did not test a fresh new install... Will double check what is wrong in the code
yes, has to be a bug when XrmToolBox is run for the first time
Ziv
@ZivBenOr
OK. thank you very much!
MscrmTools
@MscrmTools
I just introduced these "Display Tools" checkboxes but it seems I did not test enough the behavior
you're welcome
Ziv
@ZivBenOr
😉
moharmin
@moharmin
Hi there. I have installed the latest version of XrmToolbox but am not able to find Ribbon Workbench in it. I open the tool library and can see 226 tools in it but there is no sign of ribbon workbench. Please could someone let me know how to get ribbon workbench in the toolbox?
MscrmTools
@MscrmTools
Please untick and tick back « display options » checkboxes
That should bring back the list of tools and you should find Ribbon Workbench
moharmin
@moharmin
That's great MscrmTools. It worked. Thanks a lot :-)
MscrmTools
@MscrmTools
You’re welcome
Pocaho
@Pocaho
Hello,
Is there any option that allow us to open a webpage with a navigator other than IE11?
My customer implemented a web page for the MFA that is not compatible with IE11 and he refuses to change his code.
MscrmTools
@MscrmTools
Can you describe a scenario when you open a webpage from XrmToolBox ?
Pocaho
@Pocaho
My client implemented a SSO/MFA for security issues. So when using the "sdk login control" connection method to create a new connection then hitting the Login button, a SSO page is prompted and it works fine it redirect us to the MFA page and it's not compatible with IE11.
MscrmTools
@MscrmTools
Ok, so the SDK login control is directly provided by Microsoft. This is not something I can change in XrmToolBox. I’m afraid you are stuck
Pocaho
@Pocaho
okay, thank you so much
Zohaib Uddin Khan
@ZohaibUddinKhan
Morning Team,
I've recently updated to 1.2021.6.50 and trying to connect to an 'Oceania' region organisation. But, its throwing following exception:
  1. ERROR REQUESTING Token FROM THE Authentication context - General ADAL Errror.
  2. Federated service at https://auth.organizationname.com.au/idp/sts.wst?TokenProcessorId=ldapUPNTokenProcessor returned error: ID3242: The security token could not be authenticated or authorized.
  3. Exception while trying to connect Discovery Server, (Global Discovery) URI is = https://globaldisco.crm.dynamics.com/api/discovery/v2.0/Instances
MscrmTools
@MscrmTools
What kind of connection is it? Wizard? Oauth? Other?
Zohaib Uddin Khan
@ZohaibUddinKhan
Wizard.
Zohaib Uddin Khan
@ZohaibUddinKhan
I tried to create a new OAuth, used the 'development Azure AD App' and my corp email address. And, when I click on the Next button, a new Pop-up opens but this pop-up is appearing blank and nothing happens after that. As far as I know, that pop-up is from Corp Authentication Server and nothing to do with XrmToolBox. But, maybe XrmToolBox need to send some parameters or something?
MscrmTools
@MscrmTools
If this is a custom Oauth provider, the problem can be that this web page is not compatible with IE11 which is the browser used by .net framework. I already seen that. If this is the root cause, so there is nothing I can do here. You would need to use another authentication method like client id/secret or certificate, to avoid this Corp page
Zohaib Uddin Khan
@ZohaibUddinKhan
I'm not 100% sure whether this is custom OAuth. I tried the client id/secret also, but stumble into another issue - The HTTP request was forbidden with client authentication scheme 'Anonymous'. => The remote server returned an error (403) Forbidden.
Zohaib Uddin Khan
@ZohaibUddinKhan
Kindly ignore the last message. Thanks for the HELP! Appreciated!
In case, if anyone else face the same issue, then kindly use Client Id / Secret for connection. Steps are 1. Create App Registration 2. Create an Application user in D365 3. Assign the Security role to this application User. And Viola!
Zohaib Uddin Khan
@ZohaibUddinKhan
Connection is getting setup correctly. But, when I'm actually trying to connect to org, I'm getting this: MscrmTools/MscrmTools.Xrm.Connection#120
Zohaib Uddin Khan
@ZohaibUddinKhan
Create new connection as Connection String is WORKING properly. Connection String has been written as AuthType=ClientSecret;url=https://contosotest.crm.dynamics.com;ClientId={AppId};ClientSecret={ClientSecret}
MH
@Rekojeht
Hey - so I am trying to create a new XRMToolBox project in Visual Studio 2019 and it's just stuck on "Creating project..." doing nothing.
LOL nevermind. When I went to cancel it, it prompted me to Trust or Not Trust the template.
MscrmTools
@MscrmTools
I’m glad it worked. VS is not always showing that warning correctly
MH
@Rekojeht
Yeah, I've noticed that a lot where popups aren't going to the foreground. Before I get started - you're not aware of any tool that allows you to bulk unshare records from a user or team, are you?
MscrmTools
@MscrmTools
Not that I am aware of
MH
@Rekojeht
Dang, well I guess we're gonna get one then! Had a power user share a bunch of records to another user and I don't think anyone wants to manually unshare a couple thousand records one at a time..
cvicky123
@cvicky123
hey - my connections were fine in June and now after an update i get an error message - no URI found. i have tried to re-connect via wizard and created a new office 365 app password and now getting ERROR REQUESTING Token FROM THE Authentication context - General ADAL Error. i've also tried uninstalling and re-installing xrmtoolbox and sill can't connect. any help would be great. i'm not that techie!
MscrmTools
@MscrmTools
This is a known bug. Go to settings to use pre release version of connection controls and validate. Install the pre release when prompted and you should be good
cvicky123
@cvicky123
thanks, just tried that but still won't connect - same error message
MscrmTools
@MscrmTools
Can you try to create a connection with Oauth type or Microsoft login control?