Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Shawn
    @Aiphox
    Hey Meinrad, I'm not seeing the typo! 😓
    Meinrad Recheis
    @henon
    Changed
    Shawn
    @Aiphox
    Wow, I spent way too much time staring at that not to see it!
    Thanks!!
    Meinrad Recheis
    @henon
    :D your welcome
    remember, this is HTML which allows to pass any parameters
    it makes it hard to notice typos
    Shawn
    @Aiphox
    Yeah, I figured since it wasn't complaining that it was typed correct, just wasn't doing anything.
    Lesson learnt 😅
    Aymen Abdessamad
    @AymenAbdessama1_twitter
    hello guys , why i can't apply "Style" to my MudMessageBox ?
    John Horvath
    @JHorvath-MaxetaTech

    What is the proper way to remove any margins, padding, etc. from MudMainContent:

    <MudDrawer @bind-Open="_drawerOpen" ClipMode="DrawerClipMode.Always" Elevation="2" Variant="@DrawerVariant.Mini">
        <NavMenu />
    </MudDrawer>
    <MudMainContent>
        <MudContainer>
            @Body
        </MudContainer>
    </MudMainContent>

    I need my body to be flush up against my MudDrawer.

    haydeb
    @haydebxd_twitter
    Is there any kind of documentation regarding how to use the FilterDefintions list inside of the MudDataGrid? I want the column filters to be case-insensitive.
    ashvinero
    @ashvinero
    Hi, I am implementing mudselect with multi select feature. eg. https://try.mudblazor.com/snippet/GYcwOVPRnWjjCUjc I am trying to get the selected values i.e values selected in dropdown in code behind i.e in razor .cs pages Can someone please let me know how this can be done
    ɹǝʌᴉlɐʇǝɯ
    @oliverholliday_twitter
    @ashvinero you need to use two way binding on the value, either with @bind-Value="" or by doing both directions seperately by handling ValueChanged=""
    emrebiber
    @emrebiber_twitter
    Hello friends, I have a small question regarding MudAutocomplete. Is there any way to set the initial value to MudAutocomplete? The value that comes from DB will be set to autocomplete (initial value) and if the user wants to change it, will see all other values (options)
    ` <MudItem xs="12" md="6">
                            <MudAutocomplete T="City"
                                             Label="City"
                                             SearchFunc="@SearchCity"
                                             ToStringFunc="@(e => e == null ? null : $"{e.CityName}")"
                                             ValueChanged="@((City city) => OnSelectedCityValue(city))"
                                             Variant="Variant.Outlined"
                                             MaxItems="100"
                                             Placeholder="Select a city"
                                             Clearable="true" />
                </MudItem>`
    this is currently what i have
    Hugo Garcia
    @ivictorhugo_gitlab
    image.png

    Hello friends, Good morning!

    I would like to implement a custom font on MudBlazor on my .NET MAUI application, however, the custom font is not being applied to the MudBlazor controls.
    I registered the fonts on MauiProgram.cs and also overrided the default typography following MudBlazor documentation by creating a MudTheme and then assign it to the MudThemeProvider tag.

    image.png
    Do you know if I'm missing something on the custom font setup?
    limberganzaldo
    @limberganzaldo
    Error al actualizavar a la version 6.0.12 y 6.0.13
    2 replies
    Failed to load resource: the server responded with a status of 404 ()
    blazor.webassembly.js:1 Debugging hotkey: Shift+Alt+D (when application has focus)
    blazor.webassembly.js:1 blazor Loaded 13.17 MB resourcesThis application was built with linking (tree shaking) disabled. Published applications will be significantly smaller.
    :1801/07173787ea9643a59a910298a9a51a21/browserLinkSignalR/negotiate?requestUrl=https%3A%2F%2Flocalhost%3A7239%2F&browserName=&userAgent=Mozilla%2F5.0+(Windows+NT+10.0%3B+Win64%3B+x64)+AppleWebKit%2F537.36+(KHTML%2C+like+Gecko)+Chrome%2F103.0.5060.134+Safari%2F537.36&browserIdKey=window.browserLink.initializationData.browserId&browserId=833f-d24d&clientProtocol=1.3&_=1658882523395:1 Failed to load resource: net::ERR_CONNECTIONREFUSED
    :1801/07173787ea9643a59a910298a9a51a21/browserLinkSignalR/negotiate?requestUrl=https%3A%2F%2Flocalhost%3A7239%2FLogin&browserName=&userAgent=Mozilla%2F5.0+(Windows+NT+10.0%3B+Win64%3B+x64)+AppleWebKit%2F537.36+(KHTML%2C+like+Gecko)+Chrome%2F103.0.5060.134+Safari%2F537.36&browserIdKey=window.browserLink.initializationData.browserId&browserId=cd5a-3ed2&clientProtocol=1.3&
    =1658882527502:1 Failed to load resource: net::ERR_CONNECTION_REFUSED
    blazor.webassembly.js:1 crit: Microsoft.AspNetCore.Components.WebAssembly.Rendering.WebAssemblyRenderer[100]
    Unhandled exception rendering component: Could not find 'mudPopover.initialize' ('initialize' was undefined).
    Error: Could not find 'mudPopover.initialize' ('initialize' was undefined).
    at https://localhost:7239/_framework/blazor.webassembly.js:1:328
    at Array.forEach (<anonymous>)
    at a.findFunction (https://localhost:7239/_framework/blazor.webassembly.js:1:296)
    at _ (https://localhost:7239/_framework/blazor.webassembly.js:1:2437)
    at https://localhost:7239/_framework/blazor.webassembly.js:1:3325
    at new Promise (<anonymous>)
    at Object.beginInvokeJSFromDotNet (https://localhost:7239/_framework/blazor.webassembly.js:1:3306)
    at Object.St [as invokeJSFromDotNet] (https://localhost:7239/_framework/blazor.webassembly.js:1:59938)
    at _mono_wasm_invoke_js_blazor (https://localhost:7239/_framework/dotnet.6.0.7.z6wkk9w7vs.js:1:195300)
    at wasm://wasm/00971e46:wasm-function[219]:0x1a490
    Microsoft.JSInterop.JSException: Could not find 'mudPopover.initialize' ('initialize' was undefined).
    Error: Could not find 'mudPopover.initialize' ('initialize' was undefined).
    at https://localhost:7239/_framework/blazor.webassembly.js:1:328
    at Array.forEach (<anonymous>)
    at a.findFunction (https://localhost:7239/_framework/blazor.webassembly.js:1:296)
    at _ (https://localhost:7239/_framework/blazor.webassembly.js:1:2437)
    at https://localhost:7239/_framework/blazor.webassembly.js:1:3325
    at new Promise (<anonymous>)
    at Object.beginInvokeJSFromDotNet (https://localhost:7239/_framework/blazor.webassembly.js:1:3306)
    at Object.St [as invokeJSFromDotNet] (https://localhost:7239/_framework/blazor.webassembly.js:1:59938)
    at _mono_wasm_invoke_js_blazor (https://localhost:7239/_framework/dotnet.6.0.7.z6wkk9w7vs.js:1:195300)
    at wasm://wasm/00971e46:wasm-function[219]:0x1a490
    at Microsoft.JSInterop.JSRuntime.<InvokeAsync>d__16`1[[Microsoft.JSInterop.Infrastructure.IJSVoidResult, Microsoft.JSInterop, Version=6.0.0.0, Culture=neutral, PublicKeyToken=adb9793829ddae60]].MoveNext()
    at Microsoft.JSInterop.JSRuntimeExtensions.InvokeVoidAsync(IJSRuntime jsRuntime, String identifier, Object[] args)
    at MudBlazor.MudPopoverService.InitializeIfNeeded()
    at MudBlazor.MudPopover.OnAfterRenderAsync(Boolean firstRender)
    at Microsoft.AspNetCore.Components.RenderTree.Renderer.GetErrorHandledTask(Task taskToHandle, ComponentState owningComponentState)
    window.Module.s.printErr @ blazor.webassembly.js:1
    Fe._internal.dotNetCriticalError @ blazor.webassembly.js:1
    St @ blazor.webassembly.js:1
    _mono_wasm_invoke_js_blazor @ dotnet.6.0.7.z6wkk9w7vs.js:1
    $func219 @ 00971e46:0x1a490
    $func167 @ 00971e46:0xce5e
    $func166 @
    Zia Ul Hassan
    @musafabrics_twitter
    Hello...
    Mudtextfield Masking is not working with some valid regular expression
    This is a valid regular expression .^[A-Z][A-Z0-9]{1,5}$
    I am trying to use it as follow
    public IMask NameMask = new RegexMask(@"^[A-Z][A-Z0-9]{1,5}$");
    but its not working .
    I have tried various variations where i try to use two [], it does not work.
    Following code works fine
    public IMask NameMask = new RegexMask(@"^[A-Z0-9]{1,5}$");
    but i want to make sure that first character is a capital alphabet.
    Please Check and advice
    many thanks
    Note ; This one is also not working
    public IMask NameMask = new RegexMask(@"^[A-Z\d\s.-']{2,}$");
    Meinrad Recheis
    @henon
    @musafabrics_twitter RegexMask is difficult to use. The regex must match all partial input!
    so for instance if you have a simple regex (oversimplified for brevity) that matches an email like [a-z]+@[a-z]+\.[a-z]+ it won't work because it only matches a full email like musa@mail.com but not a partial email address like musa while the user is typing. you must factor that into your regex expression. if you look at the regex for our Email mask you will see how complicated it gets
    Zia Ul Hassan
    @musafabrics_twitter
    @henon Thanks alot for answering my question. I was worried because valid regex were not working . I came to the same conclusion. Now you have also stated the same in your answer. RegeMask are difficult to use.
    How I can look at regex for Email mask? are there any other examples to look into.?
    You guys are doing a great job and have developed a very good blazor front end development framework. Thanks
    Meinrad Recheis
    @henon
    @musafabrics_twitter you'll find it in the code. Check out RegexMask.Email()
    Shawn
    @Aiphox
    For MudDataGrid... it appears to auto-populate the grid with the object you assign to Items. If a given item does not have a value for a column, how does the grid react? Is there a way to change the way it handles it?
    Meinrad Recheis
    @henon
    Sorry I don't know anything about MudDataGrid. It was entirely developed by @tjscience
    Shawn
    @Aiphox
    Okay, thanks
    ashvinero
    @ashvinero

    Hi,

    We had setup our Blazor application and hosted it in Azure. Often we encounter the below error description and the user has to reload the page to make it working. We had been referring some articles related to the above. However the issue still persists and we are unable to fix the issue.

    *Could not reconnect to the server. Reload the page to restore functionality**

    Can someone please help on fixing the issue in a Blazor application. Help is very much appreciated.

    Regards,
    Ashvin

    Meinrad Recheis
    @henon
    @ashvinero switch to WASM if you can
    Jean Poulin
    @jeanpoulin
    Is there a way to have the MudCardMedia to be clickable to launch a function . On the code below, my MudIconButton is working OK but the onclick is not really implemented in the component so it does not work. Can I wrap it inside something. I tried to google but found no example. <MudItem xs=12 sm="2">
    <MudCard>
    <MudCardMedia Image="assets/products/Drywall.png" Height="144" onclick="() => FilterByCategoryL1(cat.CategoryID)" />
    <MudCardContent>
    <MudText Typo="Typo.body2">@cat.CategoryName </MudText>
    </MudCardContent>
    <MudCardActions>
    <MudIconButton Icon="@Icons.Material.Filled.Search" Color="MudBlazor.Color.Primary" OnClick="() => FilterByCategoryL1(cat.CategoryID)"></MudIconButton>
    </MudCardActions>
    </MudCard>
    </MudItem>
    Jean Poulin
    @jeanpoulin
    Many thanks, it works perfectly . Final code was: @onclick="@(()=> FilterByCategoryL1(@cat.CategoryID))"
    EXTERNAL Bonner Mark (RTRS, ETAS-DAP/XPC-UK) (etas)
    @external-Mark-Bonner_pace
    I need to add a 0.5rem corporate coloured image above the MudAppBar and MudDrawer with width: 100%. Is this possible? So far, I've noticed .mud-appbar.mud-appbar-fixed-top is fixed at 0, so if I start overriding in css it causes layout issues.
    1 reply
    Sagun Nepal
    @Sagun202
    hello
    How can i use multiple breakpoint like <mudhidden Breakpoint= "breakpoint.Lg, breakpoint.Md ">
    Meinrad Recheis
    @henon
    there should be Breakpoint.MdAndUp or so?
    IKIKN
    @IKIKN

    Hi all, is there a way to pass a custom color to the IconColor property of MudListItem ?

    Something like this : <MudListItem Icon="@Icons.Filled.Bookmark" IconColor="#FF6600" />

    Thanks !

    Meinrad Recheis
    @henon
    if they are not there yet it would be easy to implement. You may PR
    buzzbonner
    @buzzbonner
    I need to create a three state MudSwitch. Off / Transition State / On. Each state will have it's own colour. The Transistion State may fail and return to Off. Is this possible by extending MudSwitch?
    buzzbonner
    @buzzbonner
    I'm using MudD:ataGrid, and want to keep the header visible when scrolling. I'm usin FixedHeader="true" and Style="overflow: auto; height: 70vh", but the header vertically scrolls away?