These are chat archives for MylesIsCool/ViaVersion

13th
Apr 2016
Myles
@MylesIsCool
Apr 13 2016 11:32
#12 highest rated & #6 highest rated free plugin ;)
Mats
@Matsv
Apr 13 2016 15:06
@rj0495 Are you on Gitter? :)
Ryan James
@rj0495
Apr 13 2016 15:07
Hello!
Mats
@Matsv
Apr 13 2016 15:07
Hey
Ryan James
@rj0495
Apr 13 2016 15:07
I'm back!
Mats
@Matsv
Apr 13 2016 15:07
Is your server map created in 1.7 or lower?
Ryan James
@rj0495
Apr 13 2016 15:07
You can confirm right.
No it's a 1.8 map
Like I made a new server for the test
Mats
@Matsv
Apr 13 2016 15:08
Ah ok, then I can't blame 1.7
If I login inside the same chunk from the sign, I can see the text
Ryan James
@rj0495
Apr 13 2016 15:09
Yeah I see that too
Mats
@Matsv
Apr 13 2016 15:09
Well awesome, we have the same problem :P I'm no longer the only one with it
Ryan James
@rj0495
Apr 13 2016 15:10
I've had the issue for like a month. But I thought I'd report again now because I wanna go to 1.9
1.9.2
MylesIsCool/ViaVersion@7c66507
That's the responsible commit
And the 2 before it
MylesIsCool/ViaVersion@8b65efc
Myles
@MylesIsCool
Apr 13 2016 15:12
have you tried the latest one ryan
as in latest build
Ryan James
@rj0495
Apr 13 2016 15:12
Umm I will now.
I see you patched chunks?
This commit too MylesIsCool/ViaVersion@e436988
Ryan James
@rj0495
Apr 13 2016 15:21
@Matsv You able to try the latest version too?
From the build server?
Mats
@Matsv
Apr 13 2016 15:21
Sure one sec
Ryan James
@rj0495
Apr 13 2016 15:22
@Matsv What version of Protocol lib are you using?
I'm using 3.6.5
Mats
@Matsv
Apr 13 2016 15:23
3.6.4
I'll try to update that also to the latest 1.8
Ryan James
@rj0495
Apr 13 2016 15:23
Ok
My client is just loading :P
Mats
@Matsv
Apr 13 2016 15:25
Nope didn't fix it
Ryan James
@rj0495
Apr 13 2016 15:25
Hmm
Mats
@Matsv
Apr 13 2016 15:27
I got to go, back in about 45 minutes
Ryan James
@rj0495
Apr 13 2016 15:28
@MylesIsCool It didn't fix the issue for both of us
Myles
@MylesIsCool
Apr 13 2016 15:31
Alright, I don't plan on working on it at this point in time. Busy with other issues
Ryan James
@rj0495
Apr 13 2016 15:32
Ok
Well I think protocol lib is causing the problems
Mats
@Matsv
Apr 13 2016 15:36
Does it not happen without it?
Ryan James
@rj0495
Apr 13 2016 15:37
It works fine with no Protlib
Mats
@Matsv
Apr 13 2016 15:39
Hm good to know
Ryan James
@rj0495
Apr 13 2016 15:39
Should have the same result for you?
Mats
@Matsv
Apr 13 2016 15:39
Well I have no problems with it on my testserver & protocollib
Ryan James
@rj0495
Apr 13 2016 15:40
I thought you said you couldn't see signs
Mats
@Matsv
Apr 13 2016 15:40
But I have on my server, where some plugins depend on it
Ryan James
@rj0495
Apr 13 2016 15:40
Ahh.
So you do have the same issue as I described
Mats
@Matsv
Apr 13 2016 15:41
Yup
I'll take a look at it when I'm back on my p
c
Ryan James
@rj0495
Apr 13 2016 15:46
Ok
Myles
@MylesIsCool
Apr 13 2016 18:51
We've released 0.7.5 -> https://www.spigotmc.org/resources/viaversion.19254/ big thanks to @Matsv for a lot of the changes :)
Zaino60
@Zaino60
Apr 13 2016 18:55
Hey guys I'm currently using ViaVersion 0.7.4 (I'll update to 0.7.5 in a min) and I still can't interact with command blocks while being in 1.9. Is this supposed to be like this (bug not fixed yet), or I'm doing something wrong?
Myles
@MylesIsCool
Apr 13 2016 18:56
It works fine on my clients i've used?
Mats
@Matsv
Apr 13 2016 18:57
You need op and creative to interact with commandblocks
that's new in 1.9
Zaino60
@Zaino60
Apr 13 2016 19:07
I'm op but still nothing
Mats
@Matsv
Apr 13 2016 19:07
Did you relog?
I haven't fixed that yet
That it updates when you get op
Zaino60
@Zaino60
Apr 13 2016 19:09
Yeah the thing is that I have a WG setting that deops you on join for security reasons so when I re-log it deops me and even if I re-op me myself it doesn't work
Mats
@Matsv
Apr 13 2016 19:10
Well that's the problem ;), I'll try to implement it that it updates directly
Zaino60
@Zaino60
Apr 13 2016 19:11
Thanks!
OMFG yesssssssss
Mats
@Matsv
Apr 13 2016 19:38
Lol hahaha
Uh is there not a player op event on Bukkit? :(
fillefilip8
@fillefilip8
Apr 13 2016 19:39
Matsv
Watch the second video
Mats
@Matsv
Apr 13 2016 19:39
oh god
fillefilip8
@fillefilip8
Apr 13 2016 19:39
It about Linux also
".net doesnt support other platforms "
Mats
@Matsv
Apr 13 2016 19:40
Hahahaha
So true
fillefilip8
@fillefilip8
Apr 13 2016 19:40
Best fucking video of the day
Mats
@Matsv
Apr 13 2016 19:41
Well I will probably use Windows 10 as my default pc when bash is stable on it
I like Linux how it is, but there are just not enough (good) tools out there.
I used teamviewer yesterday, ported to linux with a windows 2003 theme
I cried
fillefilip8
@fillefilip8
Apr 13 2016 19:42
"lenny Linux" hahaha
Myles
@MylesIsCool
Apr 13 2016 19:42
The reason I don't use linux is because no good game support
fillefilip8
@fillefilip8
Apr 13 2016 19:42
U watching the second video?
Mats
@Matsv
Apr 13 2016 19:42
I use Windows for gaming / steam, only that because that keeps it fast, and use linux for development
Well and Minecraft on Linux runs faster for me on Linux then Windows
Atm I only need one thing in my life, sharex, they made it windows only :(