These are chat archives for MylesIsCool/ViaVersion

14th
Apr 2016
Mats
@Matsv
Apr 14 2016 11:54
@MylesIsCool #356
Checkium
@checkium
Apr 14 2016 18:02
Is this plugin compatible with bungeecord?
Mats
@Matsv
Apr 14 2016 18:02
As said at the Spigot page, yes. As long you use the latest bungeecord
Checkium
@checkium
Apr 14 2016 18:02
I'm using AutoIn so I can't use the 1.8-1.9 bungeecord
so that's a problem for me
Mats
@Matsv
Apr 14 2016 18:03
Oh why not?
Checkium
@checkium
Apr 14 2016 18:03
AutoIn still doesn't support 1.9
Mats
@Matsv
Apr 14 2016 18:03
That is no problem, the spigot server is still 1.8.8
It just allows 1.9 users to join
or is autoin a bungeecord plugin?
Checkium
@checkium
Apr 14 2016 18:04
autoin is a plugin for bungeecord and bukkit
Mats
@Matsv
Apr 14 2016 18:04
It probably works if you use the bukkit plugin
Checkium
@checkium
Apr 14 2016 18:04
to fix skins, make premium players have premium uuids, and auto-login premium players
When I try to use AutoIn in the 1.9 bungee it just error
Mats
@Matsv
Apr 14 2016 18:05
And when you try to use it in the spigot 1.8.8?
Checkium
@checkium
Apr 14 2016 18:05
java.lang.IllegalArgumentException: Cannot get ID for packet class net.md_5.bungee.protocol.packet.SetCompression
in spigot 1.8.8 works fine
Mats
@Matsv
Apr 14 2016 18:05
OH it's both
Well yeah, you probably have to wait until the developer updates it in that case
Checkium
@checkium
Apr 14 2016 18:06
That will take a really LONG time
the dev doesn't have sufficient time to update it, and it's not open source
and as I know, there's no alternative to AutoIn
Mats
@Matsv
Apr 14 2016 18:09
It'd be smart if he would make it open-source so people can contribute, that will make the development a lot faster
But yeah
that's his choice
But there is not much we can do to solve this problem sadly
Checkium
@checkium
Apr 14 2016 18:11
"Sources for 3.x will be not released, some sources from 4.x will be released, but I don't have time in this month, it will be released somewhere at the end of this month or at the beginning of next one."
:/
The unique alternative isn't free :/
Mats
@Matsv
Apr 14 2016 18:14
But does autoin require both the bungee plugin and bukkit to function properly?
Checkium
@checkium
Apr 14 2016 18:14
yes
or you will get "login not authorized by AutoIn" when joining
Myles
@MylesIsCool
Apr 14 2016 18:23
Then we can't help.
Checkium
@checkium
Apr 14 2016 18:24
I think I'll need to stay at 1.8 only for now