These are chat archives for MylesIsCool/ViaVersion

26th
Jun 2016
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:00
You may get some complaints about "fuck you your server doesn't support any of the new minecraft features!!!", but at the same time you will get a lot of new players because your server supports 1.9/1.10
Mats
@Matsv
Jun 26 2016 00:00
It's good to update some day though
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:00
If I did fix the ViaVersion /viaver list command, I could see what version most people use in my server
Yive
@Yive
Jun 26 2016 00:00
it's cracked too & I heard a lot of cracked players still use 1.8.x
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:01
but no... I forgot to fix, now every 1.7/1.8 client shows up as "1.8.X"
Mats
@Matsv
Jun 26 2016 00:02
Change the getPlayerVersion method? :)
Instead of if not ported SERVER_PROTOCOL
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:02
Yeah
I know, I was going to do that
Mats
@Matsv
Jun 26 2016 00:03
the craftplauer#getHandle#getVersion
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:03
But then I will need to restart the server, but I want to view the most used version now
Mats
@Matsv
Jun 26 2016 00:03
there was some kind of method for that
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:03
if (version != 47) { }
Mats
@Matsv
Jun 26 2016 00:07
Yes the spigot protocolhack does have this function ' (((CraftPlayer) p).getHandle().playerConnection.networkManager.getVersion() '
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:13
and... done!
Mats
@Matsv
Jun 26 2016 00:13
:)
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:13
Well, I done in a separate plugin so I could load it now to check the stats, and...
Yive
@Yive
Jun 26 2016 00:14
wtf why so many people on 1.7.5?
troyfrew
@troyfrew
Jun 26 2016 00:14
idk
but that sucks
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:14
(1.7.5 = 1.7.2 and 1.7.5)
Yive
@Yive
Jun 26 2016 00:14
ah
troyfrew
@troyfrew
Jun 26 2016 00:14
because all those players have bad json chat experiance
such as hover action new lines
probably using 1.7.5 because the best hacking clients are in those versions
:^)
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:16
29 players on 1.8.X, 40 players on 1.7.X
*47 players on 1.7.X, 40 players on 1.7.2 - 1.7.5
ffs players stop using 1.7.X so I could at least update to 1.8.8
troyfrew
@troyfrew
Jun 26 2016 00:21
past 4 days for me:
MariaDB [kingdoms]> SELECT version,COUNT(*) AS count FROM loginlog GROUP BY version ORDER BY version DESC;
+---------+-------+
| version | count |
+---------+-------+
| 210 | 7906 |
| 110 | 1139 |
| 109 | 256 |
| 108 | 14 |
| 107 | 1403 |
| 47 | 17106 |
| 5 | 3284 |
| 4 | 323 |
+---------+-------+
Myles
@MylesIsCool
Jun 26 2016 00:21
Damn
troyfrew
@troyfrew
Jun 26 2016 00:22
my players primarily are logging in with 1.8
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:22
:O
Yeah, most people are logging in with 1.8 and 1.10
Mats
@Matsv
Jun 26 2016 00:22
90% is using 1.8 on my server..
:(
I'd love to update
troyfrew
@troyfrew
Jun 26 2016 00:25
actually that is longer then 4 days i reset it longer then that
this is the last 24 hours
MariaDB [kingdoms]> SELECT version,COUNT(*) AS count FROM loginlog WHERE timestamp > DATE_SUB(NOW(), INTERVAL 1 DAY) GROUP BY version ORDER BY version DESC;
+---------+-------+
| version | count |
+---------+-------+
| 210 | 1062 |
| 110 | 137 |
| 109 | 35 |
| 108 | 2 |
| 107 | 162 |
| 47 | 2282 |
| 5 | 457 |
| 4 | 50 |
+---------+-------+
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:25
Created a poll on my server's facebook page to see if player's would like to update to a newer version.
troyfrew
@troyfrew
Jun 26 2016 00:25
1.8, 1.10, 1.7.10 are dominating the login counts
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:25
Maybe people are using 1.7.2 just because the server is 1.7.10, so they use 1.7.2
@troyfrew you are using ViaVersion + ProtocolSupport, right?
troyfrew
@troyfrew
Jun 26 2016 00:26
yes
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:26
Oh, ok
First people who done the poll said "Yes, update to 1.10"
So... that's something
Someone said "Yes, update to 1.9.4 (with 1.10 support)"
Well, actually 1.10 didn't bring too much changes
troyfrew
@troyfrew
Jun 26 2016 00:30
you will never be able to drop 1.7 until factions and pvp servers that popular youtubers play on switch to 1.9+ combat
and i have a feeling that will not happen for another year at least
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:31
At least my server isn't really focused on PvP (I don't like PvP servers) and I would really like the new additions to the resource pack system (3D models yay)
troyfrew
@troyfrew
Jun 26 2016 00:31
then move to 1.9
1.10 is fluff
just move to 1.9.4
and people will be happy
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:32
56% players said to update to 1.10
but yeah, if 1.10 wins I will update to 1.9.4
Because... what does 1.10 adds to the Minecraft experience?
Except two new mobs that are just a reskinned zombie/skeleton that throws potion effects
troyfrew
@troyfrew
Jun 26 2016 00:32
polar bears
some new block for builders
uh..
idk
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:33
Yeah, and polar bears
1.9 did bring a lot of new features
Florian
@sinnlosername
Jun 26 2016 00:33
polar bears
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:33
But 1.10? nah
just some new mobs
Florian
@sinnlosername
Jun 26 2016 00:33
But why not
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:34
50% said to update to 1.10
It's winning
Florian
@sinnlosername
Jun 26 2016 00:34
Currently, after Minecraft Dev's wrote a AI called Andersson (insider lel) they can update very fast
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:34
It's in portuguese, but...
Blue = Yes, update to 1.10
Red = Yes, update to 1.9.4 (with 1.10 support)
Yellow: Yes, update to 1.8.8 (with 1.9 and 1.10 support)
Green: No, it is better to keep 1.7.10 (with 1.8, 1.9 and 1.10 support (so... how it is now))
troyfrew
@troyfrew
Jun 26 2016 00:36
anything that isn't in the green column is going to cause players to quit
and you are talking about greater then 25% of your playerbase
Mats
@Matsv
Jun 26 2016 00:37
You could use protocolsupport if you update to 1.10
To keep your playerbase
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:38
If ProtocolSupport wasn't too buggy I was going to use it, idk how it is now, but when I used it on 1.9 it was constantly disconnecting 1.7 players.
troyfrew
@troyfrew
Jun 26 2016 00:38
i think you have your answer
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:39
35,7% 1.7.10 and 35.7% 1.10
But only 14 players already done the poll
People are too lazy to click on a link to just do a poll
Then those people that are too lazy to click will complain later "why did you update the server??????????????"
Well, I'm considering 1.9.4 and 1.10 as the "same" version
So 1.9.4 is "winning"
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:44
fuck, now 1.7.10 is winning
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 00:53
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 14:28
Decided to update to 1.10.2 + ProtocolSupport, sadly ProtocolSupport too buggy and it is disconnecting 1.7.X clients randomly
Mats
@Matsv
Jun 26 2016 21:25
@MrPowerGamerBR ProtocolSupport 1.10 is still in development. You could help the developer out by reporting those bugs? ;)
MrPowerGamerBR
@MrPowerGamerBR
Jun 26 2016 22:20
@Matsv nah, already reverted to 1.7.10, the server was constantly disconnecting clients for no reason at all (including 1.10.2, so I think it isn't a ProtocolSupport issue)
@Matsv and in 1.7.10 I gave skull heads that crashes 1.10 (I don't know WHY it crashes the client, in 1.7.10 this issue didn't happen, at all) https://www.spigotmc.org/posts/1689385/ (I found a fix, but players already had those skulls with custom names)