These are chat archives for MylesIsCool/ViaVersion

12th
Aug 2016
lenis0012
@lenis0012
Aug 12 2016 13:42
One To One conversations
Faizaan
@SirFaizdat
Aug 12 2016 14:24
Nice annotations too
MrPowerGamerBR
@MrPowerGamerBR
Aug 12 2016 20:01
ffs now Timings for 1.7.10 is broken
MrPowerGamerBR
@MrPowerGamerBR
Aug 12 2016 20:04
Yes, I will patch it
Thanks for sharing the patch link
(I was trying to find the Spigot's source code, well, less work for me :) )
It breaks every version before 1.10.2, right? (Yeah, I know, 1.8 and 1.9 has an official build with the fix)
Mats
@Matsv
Aug 12 2016 20:06
Yeah paste.ubuntu.com stopped accepting pastes for now iirc
lenis0012
@lenis0012
Aug 12 2016 20:06
i cant believe mojang is already releasing snmapshots again
2 months tops and we'll have a 1.11
Mats
@Matsv
Aug 12 2016 20:06
Probably yeah
lenis0012
@lenis0012
Aug 12 2016 20:06
with fuck all changes
and a new version path
MrPowerGamerBR
@MrPowerGamerBR
Aug 12 2016 20:06
@lenis0012 and ViaVersion already supports the snapshot version :)
lenis0012
@lenis0012
Aug 12 2016 20:07
yeah except i want to run 1.10
but support 1.8
and 1.11 when it comes out
so im in a bit of trouble
MrPowerGamerBR
@MrPowerGamerBR
Aug 12 2016 20:08
I was going to say to try using ViaVersion with ProtocolSupport on 1.11... then I remembered that there isn't a ViaVersion build for 1.10 yet. (And I think PS doesn't work with ViaVersion in 1.9, right?)
lenis0012
@lenis0012
Aug 12 2016 20:09
what
ViaVersion should work on 1.10
MrPowerGamerBR
@MrPowerGamerBR
Aug 12 2016 20:09
Yeah
it should work
But what protocol it will remap?
lenis0012
@lenis0012
Aug 12 2016 20:09
none
Mats
@Matsv
Aug 12 2016 20:09
It works but it won't do anything
lenis0012
@lenis0012
Aug 12 2016 20:09
but when 1.11 is out
out will do 1.11
Mats
@Matsv
Aug 12 2016 20:09
@lenis0012 is most of your playerbase still 1.8?
MrPowerGamerBR
@MrPowerGamerBR
Aug 12 2016 20:09
Yeah, when I said "doesn't work" I meant "it won't do anything"
lenis0012
@lenis0012
Aug 12 2016 20:10
50%
thats the annoying part
1.10 works shitty on our server
theres lots of bugs
other servers are picking up on the new boss bars
and even our pixelmon server is updating to 1.10
Mats
@Matsv
Aug 12 2016 20:10
You could use the ViaVersion API for the new bossbars? ;)
lenis0012
@lenis0012
Aug 12 2016 20:10
which no longer supports technic launcher
and their own laucnher has no API or mac support
so im making my own launcher now
Mats
@Matsv
Aug 12 2016 20:11
Oh rip
MrPowerGamerBR
@MrPowerGamerBR
Aug 12 2016 20:11
@lenis0012 I understand your feeling right now, 50%+ on my server still uses 1.7.2/1.7.10 but I want to update my server
lenis0012
@lenis0012
Aug 12 2016 20:11
yes
they probably would upgrade
but im short on time
i havent released any updates in a while
so people are already fed up
MrPowerGamerBR
@MrPowerGamerBR
Aug 12 2016 20:12
At least now people are starting to use 1.8 instead of 1.7 on my server
I also can't update to 1.10 because, in 1.7, I gave some custom skulls to the players (it is just an skull with a custom display name and the player's skin), and, if I update to 1.10 and someone has those skulls in the inventory, they crash
lenis0012
@lenis0012
Aug 12 2016 20:14
isnt there a fix for that tho
MrPowerGamerBR
@MrPowerGamerBR
Aug 12 2016 20:14
(I think it is related to the Skull exploit Myles was talking about a few days ago, except that I caused it with my own plugin and my server isn't a creative server)
lenis0012
@lenis0012
Aug 12 2016 20:14
like an inventory patcher
I think this plugin may fix it
lenis0012
@lenis0012
Aug 12 2016 20:15
test it
give yourself a skull
on a test server
and update
MrPowerGamerBR
@MrPowerGamerBR
Aug 12 2016 20:15
iirc I don't need to give the skull in 1.7
I will test it later