These are chat archives for Nethereum/Nethereum

3rd
Oct 2017
Chandra Sekhar
@tcsekhar
Oct 03 2017 19:16

@juanfranblanco
I know this is off topic. You are the most informative and responsive person in this subject area. Please help me if you could:

I am trying to build a 4 node Geth cluster on CentOS. I was following the documentation here: https://ethereum.gitbooks.io/frontier-guide/content/cluster.html

I'm not able to add any nodes to the cluster. I was able to start the geth process on the node and when I do a admin.nodeInfo, I do get the node details:

    {
    enode: "enode://5b810de07ceabb81cad1cad4cc1a277bfe7eabfd78019095565dcb6243b38be700f38aab55e3c083c991ff227afa0e5665c062466b65912cd3394ad096366894@[::]:30301",
    id: "5b810de07ceabb81cad1cad4cc1a277bfe7eabfd78019095565dcb6243b38be700f38aab55e3c083c991ff227afa0e5665c062466b65912cd3394ad096366894",
    ip: "::",
    listenAddr: "[::]:30301",
    name: "Geth/v1.7.1-unstable-c2d93ded/linux-amd64/go1.8.3",
    ports: {
    discovery: 30301,
    listener: 30301
    },
    protocols: {
    eth: {
    difficulty: 17179869184,
    genesis: "0xd4e56740f876aef8c010b86a40d5f56745a118d0906a34e69aec8c0db1cb8fa3",
    head: "0xd4e56740f876aef8c010b86a40d5f56745a118d0906a34e69aec8c0db1cb8fa3",
    network: 1
    }
    }
    }

But, when I request for "admin.nodeInfo.NodeUrl" I get "undefined"

Also when I try adding the peers I get "true" for all the below commands:

    admin.addPeer("enode://5b810de07ceabb81cad1cad4cc1a277bfe7eabfd78019095565dcb6243b38be700f38aab55e3c083c991ff227afa0e5665c062466b65912cd3394ad096366894@10.20.11.111:30301")
    true
    admin.addPeer("enode://8e4ffc9cd87cf6029a8fd4bdd34c68393ee69ee8f1e7b639a0b9339af40435c00d87c3d0496c1af85d4eb546ebbb6bdca892c2e3b6a2649a46414b3fb13de327@10.20.11.113:30302")
    true
    admin.addPeer("enode://ca82e1bbe3234695ebf8782aa1fede1b1e48999ac470e0a6338e5ddf1fb5f1726e050a4e8db43c7eb4719aae7ec83003bf64fa5fb5ead560f1f1976e5322ccc5@10.20.11.114:30302")
    true
    admin.addPeer("enode://c28c8bf87ad4bfc1ceb9a6b860cc991d03c740cc13462eb3a4edfcbf2ae6b1c5a2061cde4a34d357568399f0b8930400c4f45ad7e508a501eac9ea2f9bc71c1a@10.20.11.117:30302")    
    true

But when I request for "admin.peers" I get "[]".

Can you please help me if you could?

sorry a bit late here now
Chandra Sekhar
@tcsekhar
Oct 03 2017 21:51

I tried this as well. It doesn't error but I still can't get the peers added even with --bootnodes listed. I have raised this question on few other forums as well. You were the only one to respond :)

Thanks again.