These are chat archives for Nithmr/ProxyHelper

1st
Jul 2016
Utkarsh Raj
@clearnote01
Jul 01 2016 07:02 UTC
@akshendra I'm having issues in setting System Socks proxy from kde Proxy Module. Can you try to set socks proxy in gnome NM using the following commands. Then set ff to use System Proxy and then try https://check.torproject.org/ if it works or not.
gsettings set org.gnome.system.proxy.socks host 127.0.0.1
gsettings set org.gnome.system.proxy.socks port 9050
gsettings set org.gnome.system.proxy mode 'manual'
Note: You need cli tor running in bg
Akshendra Pratap Singh
@akshendra
Jul 01 2016 07:03 UTC
Okay let me check
Utkarsh Raj
@clearnote01
Jul 01 2016 07:03 UTC
thanks a lot
Akshendra Pratap Singh
@akshendra
Jul 01 2016 07:13 UTC
It worked
Utkarsh Raj
@clearnote01
Jul 01 2016 07:24 UTC
what are the values for httpProxy, ftpProxy, ssl?
did you have to reset them??
Akshendra Pratap Singh
@akshendra
Jul 01 2016 07:25 UTC
I did reset them
Utkarsh Raj
@clearnote01
Jul 01 2016 07:26 UTC
manually?
gsettings set org.gnome.system.proxy.http.host ''
^^ does something like this work
Akshendra Pratap Singh
@akshendra
Jul 01 2016 07:28 UTC
I did exactly that
Utkarsh Raj
@clearnote01
Jul 01 2016 07:28 UTC
awesome
i'm having a lot difficulty for kde rn, so i'll go on with just gnome support for now...
hopefully i get that to work as well : )
Akshendra Pratap Singh
@akshendra
Jul 01 2016 07:30 UTC
Okay
Utkarsh Raj
@clearnote01
Jul 01 2016 07:30 UTC
Just to double check...
@akshendra when you changed proxy via gsetting, did $socks_proxy $http_proxy, etc
change as well?
Akshendra Pratap Singh
@akshendra
Jul 01 2016 08:00 UTC
No changes there
Utkarsh Raj
@clearnote01
Jul 01 2016 08:06 UTC
ok, as expected : )