Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Andrei Sheina
    @andrei-sheina
    ok, ty
    Andrei Sheina
    @andrei-sheina
    if someone else would be interested of how to do that, here is the answer that works for me: http://stackoverflow.com/questions/15955139/how-to-check-if-current-user-is-logged-in-through-omniauth
    Brad Cantin
    @bcantin
    oh hai
    Grzegorz Witek
    @arnvald
    Hi @bcantin
    Brad Cantin
    @bcantin
    Are there any PRs for allowing someone to use scrypt instead of bcrypt ?
    I did not notice any, but I figured I would ask before giving it a shot
    Grzegorz Witek
    @arnvald
    no, I don't think anyone's ever sent such PR
    Brad Cantin
    @bcantin
    ok. thanks much!
    Brad Cantin
    @bcantin
    PR for SCrypt has been submitted. Enjoy!
    Marvin
    @marvwhere

    Hey there: Rails 4.2.1 - Could not find generator 'sorcery:install'. Maybe you meant 'rspec:install' or 'rspec:request' or 'erb:mailer'
    Run rails generate --help for more options.

    Any ideas?

    ok all fine :D just beeing stupid :D
    Grzegorz Witek
    @arnvald
    you didn't run bundle? :>
    Marvin
    @marvwhere
    Hey there, question: How exactly is after_login working? And how do i use it? I though it is useable, as: that a given after_login method is called after each login.
    Grzegorz Witek
    @arnvald
    after_login is an array of methods to be called after each login
    so you can use it like this: Sorcery::Controller::Config.after_login << :inform_admin
    Marvin
    @marvwhere
    thats what i actually did in the sorcery initializer, but then i got and error on the login(...) method with 2 for 0. guess i need to check on this.
    Grzegorz Witek
    @arnvald
    simply add 2 parameters to the method you want to call:
    def inform_admin(_, _)
      ...
    end
    the first param is user, the other one is credentials, but if you're not going to use them, you can just use _ as the names
    Marvin
    @marvwhere
    ah n1 thx
    Marvin
    @marvwhere

    hey, run in a different problem:

    undefined method `user_activation_mailer=' for #<Sorcery::Model::Config:0x007ff182dd1a28> (NoMethodError)

    got this:

    user.user_activation_mailer = ActivationMailer

    and i've got a

    class ActivationMailer < ApplicationMailer
    lol thx debug teddy channel: :user_activation was not loaded
    Gonzalo Rodríguez-Baltanás Díaz
    @Nerian
    Hi, I am getting a undefined method `authenticates_with_sorcery!' for User:Class error
    I am using sorcery (0.9.1) and Mongoid (5.0.1)
    User.rb looks like this:
    class User
      authenticates_with_sorcery!
      include Mongoid::Document
    end
    ➜  cucu git:(master) ✗ rails generate sorcery:install
          create  config/initializers/sorcery.rb
        generate  model User --skip-migration
          invoke  mongoid
       identical    app/models/user.rb
          invoke    rspec
       identical      spec/models/user_spec.rb
          insert  app/models/user.rb
          insert  app/models/user.rb
    Gonzalo Rodríguez-Baltanás Díaz
    @Nerian
    solved: authenticates_with_sorcery! needs to go after include Mongoid::Document.
    Zack Siri
    @zacksiri
    hey guys
    having issue with login using sorcery
    followed all the tutorials out there
    but the session doesn't seem to be saving
    Temur
    @istickz
    Hello there! Sorcery is compatible with rails5 or who now using sorcery with rails 5?
    Luca G. Soave
    @lgs
    This message was deleted

    $ git log
    commit 63eea75ac4b583223241173d0970874021f5b2f6
    Author: Luca G. Soave luca.soave@gmail.com
    Date: Sun Jan 31 21:27:36 2016 +0100

    add Simple Password Authentication with sorcery:
    https://github.com/NoamB/sorcery/wiki/Simple-Password-Authentication

    commit a296cf145585335484d389f5a021ba65a365d8d7
    Author: Luca G. Soave luca.soave@gmail.com
    Date: Sun Jan 31 19:16:38 2016 +0100

    starting Rails 5.0.0.beta1
    Until now seems it works
    Luca G. Soave
    @lgs
    $ egrep " sorcery | rails " Gemfile.lock
    rails (5.0.0.beta1)
    sorcery (0.9.1)
    rails (>= 5.0.0.beta1, < 5.1)
    o_tomomichi
    @Tomomichi

    hey guys, what do you think about the idea of adding an email login with no-password to sorcery?

    The concept is well shown here: https://nopassword.alexsmolen.com/
    Authentication with magic linked email is now used by Slack, Medium and many others.
    So I guess this "magic login" is really useful if it's supported by sorcery!

    Here is my example implementation of sorcery with magic login.
    https://github.com/notsobad-jp/sorcery/tree/magiclogin

    If you guys think it's useful, I'll add the tests and send pull-request.
    Tell me what you think.

    lambda211
    @Lambda211
    Hi
    I am having an issue setting up sorcery in my rails 4.17 project
    I setup sorcery with remember_me and reset_password
    for an unknown reason, when I try to logout, I receive the following error:
    undefined method `forget_me!' for nil:NilClass
    is there some particular config to do for forget_me! like added the user mail for reset_password?
    Josh Buker
    @athix
    Testing testing, 123.
    Oleg
    @youzik
    Hi there, i want to be a part of sorcery development team, but know that now this project maintained by another guy. Maybe someone could tell me where is a current git repo?
    Paulo Abreu
    @pama
    @youzik NoamB/sorcery#777
    Josh Buker
    @athix
    @youzik, @pama: Sorcery/sorcery is where we're moving the repo to. Any contributions are appreciated!
    Denis Gorbunov
    @denisgorbunov

    Hi! Tell me, please, what is wrong?
    can’t integrate Sorcery to Rspec..
    Do as instructed: https://github.com/Sorcery/sorcery/wiki/Integration-Testing-with-Rspec%2C-Capybara-and-Fabricator
    and get error:
    /spec/spec_helper.rb:20:in `block in <top (required)>': uninitialized constant Sorcery (NameError)

    Rails 5, Sorcery 0.9.1
    Thx

    Josh Buker
    @athix
    @denisgorbunov There's a couple of known issues with 0.9.1 and Rails 5, we're pushing out 0.10.0 this friday which should fix them. Once you've updated, let me know if the problem persists. Btw, Sorcery has moved to an organization so it's easier for us to work on it! https://github.com/Sorcery/sorcery
    Punita Ojha
    @punitaojha
    This message was deleted
    Nijeesh Joshy
    @nijeesh4all
    remember_me only works with one browser
    is there any workaround for supporting multiple browsers