These are chat archives for NodejsRUS/chat

8th
Jan 2018
Igor
@Steiner87
Jan 08 2018 11:20
Люди. Кто понимает почему у меня node и nodejs? И обое разных версий. Одну из них нужно удалить.Верно? И скорее всего nodejs. Верно?
Dmitriy Simushev
@JustBlackBird
Jan 08 2018 11:21
Debian?
Igor
@Steiner87
Jan 08 2018 11:21
Ubuntu
Dmitriy Simushev
@JustBlackBird
Jan 08 2018 11:21
Одна хрень
У них в репозитории пакет node.js включает бинарник nodejs
А node ты скорее всего ставил как-то ещё
Либо компилил, либо из стороннего репозитория
Igor
@Steiner87
Jan 08 2018 11:23
sudo n stable
вот так поставил
node
Dmitriy Simushev
@JustBlackBird
Jan 08 2018 11:24
Возможно
Igor
@Steiner87
Jan 08 2018 11:24
ибо тот nodejs я так и не смог обновить
Dmitriy Simushev
@JustBlackBird
Jan 08 2018 11:24
А ты и не смог бы: в дебианах все пакеты потухшие
Если хочешь снести nodejs используй apt-get
sudo apt-get remove nodejs
Igor
@Steiner87
Jan 08 2018 11:27
удалил
и все работает.Мерси.
а вы с9.io кто-то пользуетесь?
во бред) Я попытался установить yald а оно мне сново установило nodejs ) но уже норм версии) значит удалю node)
Dmitriy Simushev
@JustBlackBird
Jan 08 2018 11:32
Ты из репозитория пакетов ставишь что ли?
Через apt?
Igor
@Steiner87
Jan 08 2018 11:33
sudo apt-get update && sudo apt-get install yarn
вот это я писал
Dmitriy Simushev
@JustBlackBird
Jan 08 2018 11:34
Ну логично
Пакет yarn зависит от пакета nodejs
vedun
@vedun
Jan 08 2018 11:35
@Steiner87 ты в начале поставь node из репозиториев с сайта ноды, потом ставь yarn
тогда он старую версию не подтянет
я так понял в этом проблема ?
Dmitriy Simushev
@JustBlackBird
Jan 08 2018 11:36
Ребят, вы вообще понимаете как в линуксах работают репозитории пакетов?))
Igor
@Steiner87
Jan 08 2018 11:36
у меня была версия 4 какая-то nodejs. Я пытался ее обгрейдить до 8 какой-то
vedun
@vedun
Jan 08 2018 11:36
я в глубокии подробности не вдавался =)
Igor
@Steiner87
Jan 08 2018 11:37
но не получалось. А потом я прочитал один метод через программу n
vedun
@vedun
Jan 08 2018 11:37
просто у меня убунта и стоит yarn и 9 нода
Igor
@Steiner87
Jan 08 2018 11:37
и установил саму новую но не nodejs а node
vedun
@vedun
Jan 08 2018 11:37
@JustBlackBird раскажи, будет интересно узнать что то новое :)
Dmitriy Simushev
@JustBlackBird
Jan 08 2018 11:38
На оф сайте ноды есть чудо скриптик, который добавляет в систему кастомный репозиторий с пакетом для node.js
Igor
@Steiner87
Jan 08 2018 11:38
а еще попытался удалить node но вижу что он так и не удалился
vedun
@vedun
Jan 08 2018 11:38
всё, так есть такой скриптик
Dmitriy Simushev
@JustBlackBird
Jan 08 2018 11:39
@vedun ещё б я сам в этом глубоко разбирался))))
Igor
@Steiner87
Jan 08 2018 11:42
не удалилось
Igor
@Steiner87
Jan 08 2018 11:51
вроде удалил
ура! yarn работает)
а вообще это когда я Bower Устанавливал то мне написало что нужно мигрировать на Yarn
Что? Bower уже все?
vedun
@vedun
Jan 08 2018 11:55
да он вроде давно не поддерживается
Igor
@Steiner87
Jan 08 2018 11:56
ну я смотрю уроки 2016 года так там он еще был живой
vedun
@vedun
Jan 08 2018 11:57
да он вроде и сейчас живой, в эмбере вроде до сих пор используется наряду с npm
Igor
@Steiner87
Jan 08 2018 11:57
а что на счет графики в убунту?
vedun
@vedun
Jan 08 2018 11:58
opengl ?
Igor
@Steiner87
Jan 08 2018 11:58
не уверен
а где посмотреть?
vedun
@vedun
Jan 08 2018 11:59
вопрос в чём ?
Igor
@Steiner87
Jan 08 2018 12:00
ну картинка такая как буд-то в виновсе была в безопасном режиме
ну не идеально четко и быстро
работает
vedun
@vedun
Jan 08 2018 12:00
не знаю, у меня в 16.04 отличная картинка
может с оборудованием проблемы
Igor
@Steiner87
Jan 08 2018 12:01
виндовс работает идеально
а может разрешение тут не настроено
vedun
@vedun
Jan 08 2018 12:01
вообще это наверно уже тема не для этого чата :)