These are chat archives for NomadicWeb/whereswall.ie

14th
Nov 2014
Martin O'Grady
@grady-lad
Nov 14 2014 00:38
logo top with navbar in the middle seems the best!
rad edit!
yeah, and works better because the rest of the page is filled up sometimes (for example, the /about-us page)
ok, we'll switch up the logo position and sort out those fonts
Any problems with the alignment do you think?
I worked a bit with them, the about-us page is dropped a bit and then the others just have text, so I moved them around
Martin O'Grady
@grady-lad
Nov 14 2014 00:40
Lets try get this before next week to the lads anyway?
Yep agreed, Ill make the changes tomorrow morning and then we can all give it another review and then we can send it out to the bros to see what they say (the list of emails)
after that it is going live!!!
waddhuiy
@waddhuiy
Nov 14 2014 12:31
Martin you prick. That fucking video. How do you even find shit like that?
As for the alignment, I think everything's good except for the three opening jpegs of the wallie, on my laptop they're slightly aligned to the top left, but I don't really think that's a problem. Then once the fonts are set, I'm pretty happy to launch. Oh! Martin, do you have a better quality photos/portraits for the about section? I tried to get one off NOB yesterday but he didn't really have any..
Screen Shot 2014-11-14 at 12.29.20.png
Screen Shot 2014-11-14 at 12.29.16.png
Here's just two examples of the jpeg alignments..
ok, for the fonts, everything is getting the Helvetica Neue Light style. That is what we want right?
waddhuiy
@waddhuiy
Nov 14 2014 13:30
Yep. Except the titles are helvetica neue bold I think
ok, need to change that
waddhuiy
@waddhuiy
Nov 14 2014 13:31
Sorry its helvetica neue medium. The version I had was 22pts but thats easily adjustable
for the text or for the titles?
waddhuiy
@waddhuiy
Nov 14 2014 13:33
Titles just. Body text was light 20 pts...
ok cool, got it
waddhuiy
@waddhuiy
Nov 14 2014 13:34
Sweet
waddhuiy
@waddhuiy
Nov 14 2014 13:54
Quick logo update. I know it's super trendy but I had to change the font. Any thoughts?
WheresWallie-logo-and-text-2.png
haha cool, looks fine to me. hipster
waddhuiy
@waddhuiy
Nov 14 2014 13:56
Fuck. It looks a little more down with the kids though. Do you want me to send on the actual file or is that one ok?
haa, it looks good, just pushing that now
that one is fine
righto, give that a look now
I tested it and it all looks to be level but that could just be my browser :|
seems to be working for all mobile devices as well
centered the gifs a bit more ...
oh wait, massive bug
waddhuiy
@waddhuiy
Nov 14 2014 14:21
Gifs are perfect, in the centre for my browser now too.
on mobile devices haha
ok sweet
waddhuiy
@waddhuiy
Nov 14 2014 14:23
The only two issues I have are that the fonts still aren't helvetica yet and the arrows for the menu navigator aren't functional, so if they can't be made functional we should just remove them and have the circles on their own, so users aren't confused/frustrated.
oh yeah, right, the arrows, we never meant them to be functional. I just wanted dots, marty said it would be confusing if we didn't have them
emmm ... what do you think? Dots or arrows for navigation
I think it looks rad without them
waddhuiy
@waddhuiy
Nov 14 2014 14:27
Get rid of them then. They have to be touch responsive or not there at all. People will get it I think. Fairly confident. Just showed Annick. She's pretty happy with it. Thinks it looks good and works smoothly
ok, lets see how it goes, cool
looking into this font stuff so
Martin O'Grady
@grady-lad
Nov 14 2014 14:52
sent on images to your email paddy!
ok, from what I can see, the fonts are set correctly on every page ... martin has the same
are you still seeing the wrong font paddy? Make sure with the 'ol 'inspect element' tool
waddhuiy
@waddhuiy
Nov 14 2014 15:21
Ok. The first page is perfect then after that the fonts are all a serif font. I've no idea why though because in the inspect element it is supposed to be helvetica neue alright. Let me clear my cache
hmmmm ... weird one
waddhuiy
@waddhuiy
Nov 14 2014 15:32
Cleared my cache and it just made the first one a serif font as well now... Really weird. Gonna try safari
Screen Shot 2014-11-14 at 15.33.00.png
Same in safari but here, inspect element spat this at me..
Screen Shot 2014-11-14 at 15.34.37.png
Little error, any relation?
emmm ... could be, Ill keep working on it
any luck now?
ok, I think I got rid of the menu bug and things are lining up responsively for different browser widths
waddhuiy
@waddhuiy
Nov 14 2014 16:35
Fonts are still the same. I've no idea why the fuck? :(
fuck, is that error still there?
waddhuiy
@waddhuiy
Nov 14 2014 16:39
Nope, the error is gone.
what browser are you on?
waddhuiy
@waddhuiy
Nov 14 2014 16:49
Chrome on mac.
Mavericks is the OS
And you are simply seeing 'TImes New Roman' as the font?
Is Helvetica Neue Light / Medium a standard free font?
I asked someone to check it there and they are just seeing 'Helvetica Neue'
fook, working for me on chrome ...
waddhuiy
@waddhuiy
Nov 14 2014 16:56
So I'm just seeing a standard serif font, most likely times new roman or something similar. To get technical Helvetica Neue is a typeface and Light/Medium/Bold are the fonts. They are all weights around a style of font. Fascinating, obviously
Helvetica wouldn't be free but it does come as standard on almost all computers.
Can you screenshot it there for me Luke.
strange ...
waddhuiy
@waddhuiy
Nov 14 2014 17:00
OK
This is mental
we could load the font though something like google-fonts, but I can't find Helvetica Neue there
but you clearly have the font as well
waddhuiy
@waddhuiy
Nov 14 2014 17:00
So thats not Helvetica Neue either but its still different to my font...
Let me check something...

Ok, so the title is suppose to be:

  • Helvetica Neue Medim

and the text is supposed to be:

  • Helvetica Neue
or:
  • Helvetica Neue Light
waddhuiy
@waddhuiy
Nov 14 2014 17:01
Hel Neue Light yeah
ok, cool
waddhuiy
@waddhuiy
Nov 14 2014 17:02
See this font here Luke?
where?
waddhuiy
@waddhuiy
Nov 14 2014 17:03
The one that this chat uses.
ah yeah, ok, it is ...
"Open Sans","HelveticaNeue-Light",sans-serif
?
waddhuiy
@waddhuiy
Nov 14 2014 17:03
This is way closer to Helvetica. It has no slabs on any of the letters
ok, I don't know what a slab is but should we use this one?
waddhuiy
@waddhuiy
Nov 14 2014 17:04
All the ones loading up on wheres wally are serifed, kind of old fashioned fonts with tiny slabs
Hahaha. Sorry. This is such nerdy nonsense and I'm coming off like a cunt
Open sans should be perfect
no no no, it needs to be fixed haha
feck, Ill check our defaults .. they probably all just set to Serif, Sans-serif
or somet
Sorry, really amn't trying to be a condescending wanker. And I'm not being helpful either because I don't exactly understand webfonts and the like. Trying to figure it out
hahaha paddy relax, I wanna learn this stuff too
waddhuiy
@waddhuiy
Nov 14 2014 17:07
Cool. I don't want to lose mates over a fucking serif
So the actual problem is probably that Helvetica Neue is a paid font and I got it with my mac but you chaps don't have it and I've been sending you in loops for no reason. So apologies.. So yeah, open sans should be fine. It's a lovely little typeface
haha fucking serif
righto!
wonder how the feck we have it though ...
But Helvetica Neue (the typeface?) is bootstrap code as a default ...
are you sure it is a paid font yeah?
waddhuiy
@waddhuiy
Nov 14 2014 17:12
Is it!!??
Yeah it is.
But if it's there then you do have the licence to use it. It's just that implementing it is failing and I have no idea, but at this stage that's probably metacode and nothing to do with you...
hmmmmmmm
waddhuiy
@waddhuiy
Nov 14 2014 17:14
THIS IS FUN YEAH?!
hahaha ...
FONTS BRO
ok, check it now, pushed some changes to the fonts
waddhuiy
@waddhuiy
Nov 14 2014 17:17
I was starting to like them after the mag work. Ruined for me now
Fonts are rad, I mean, they look nice and you can do lots with them ... for example this project. It just looks rad with text
waddhuiy
@waddhuiy
Nov 14 2014 17:18
It's identical for me.. Will I try turning on/off?
Maybe mu
nooooooooooo
waddhuiy
@waddhuiy
Nov 14 2014 17:19
typo
hahaha
clear that cache nigga
waddhuiy
@waddhuiy
Nov 14 2014 17:21
Still the same. Did it change for you?
Martin O'Grady
@grady-lad
Nov 14 2014 17:21
JUST PLAY THE FUCKING CHORD
waddhuiy
@waddhuiy
Nov 14 2014 17:21
Try and make some font green there or something or maybe use a completely different, stupid font, just to see if it affects me
Only do that if it can be reset easily!
ok, ok, try again
and play the fucking chord
wait, two secs
ok, pushed
waddhuiy
@waddhuiy
Nov 14 2014 17:26
Exact same. FUCK!
Do you believe me? I'm not sure I believe myself anymore
I must be wrong. This is madness!
haha wow. I removed every reference to sans-serif
waddhuiy
@waddhuiy
Nov 14 2014 17:28
I am not a credible source
right ... I dunno, it says Helvetica in your browser though when you inspect the element right?
waddhuiy
@waddhuiy
Nov 14 2014 17:29
switch-content p, #switch-content a, #switch-content li {
font-family: "Helvetica Neue Light";
line-height: 1.4em;
font-size: 12pt;
}
Everything seems perfect
Are you getting a sans serif font now or is it still serif'd?
yeah, that is the one ... I targeted each one individually to make sure it would work
I am always getting the right fonts
waddhuiy
@waddhuiy
Nov 14 2014 17:31
You didn't on your last screen shot. You had a serifed font
oh jeebus confused now
Martin O'Grady
@grady-lad
Nov 14 2014 17:32
Every time I checked it was fine
what are we even trying to do here
haa
Martin O'Grady
@grady-lad
Nov 14 2014 17:33
who else do we know that owns a mac that can test it real quick
here I am off for more breakfast, font off
waddhuiy
@waddhuiy
Nov 14 2014 17:33
I own it alright
fuckingfonts-2.jpg
waddhuiy
@waddhuiy
Nov 14 2014 17:40
This is just to show you what you have versus what you should have according to the code/site. Common sense is telling me that it's an error of the browser or language and not due to you. But I haven't a fucking clue...
Martin O'Grady
@grady-lad
Nov 14 2014 17:54
another solution is to pick a different font from google fonts and just load it from the internet
waddhuiy
@waddhuiy
Nov 14 2014 18:00
Awh you're so smart Martin, you lazy fuck. Why don't you do that then?
Martin O'Grady
@grady-lad
Nov 14 2014 18:02
we havta pick a font ya thick cunt
waddhuiy
@waddhuiy
Nov 14 2014 18:08
Oh my god. Doing my nut in from 3000 miles away. You're a fucking nightmare
Martin O'Grady
@grady-lad
Nov 14 2014 18:29
here we tested on a mac here and its fine
waddhuiy
@waddhuiy
Nov 14 2014 18:30
Whats fine?
Martin O'Grady
@grady-lad
Nov 14 2014 18:30
sure we'll send it on to the lads anyway
the font
waddhuiy
@waddhuiy
Nov 14 2014 18:30
But it's not the right font
Haha
Martin O'Grady
@grady-lad
Nov 14 2014 18:30
we tested it on a mac and the font was right
waddhuiy
@waddhuiy
Nov 14 2014 18:31
Was it a sans serif font?
Martin O'Grady
@grady-lad
Nov 14 2014 18:31
nope
waddhuiy
@waddhuiy
Nov 14 2014 18:31
Ok
Martin O'Grady
@grady-lad
Nov 14 2014 18:31
no sign of the sans cunt
waddhuiy
@waddhuiy
Nov 14 2014 18:31
We want it to be sans serif martin
Martin O'Grady
@grady-lad
Nov 14 2014 18:31
what ?
waddhuiy
@waddhuiy
Nov 14 2014 18:31
Hahaha!
Fucking hell
What have I done
Helvetica Neue is a sans serif font and Times new roman (or whatever font that was being pushed) was a serif font.
I don't mind either way though. Send it on there :)
Martin O'Grady
@grady-lad
Nov 14 2014 18:33
Helvetica Neue was the one that appeared
Did it look like the red examples here?
If so then you solved it
And you're an absolute genius
(Whoever did it)
Martin O'Grady
@grady-lad
Nov 14 2014 18:35
jesus sorry I was mad confused, ok
when I load it on my machine
I dont get the red examples
its like the other why
below the red example
what browser you using?
waddhuiy
@waddhuiy
Nov 14 2014 18:35
Yeah, thats wrong unfortunately
Martin O'Grady
@grady-lad
Nov 14 2014 18:35
because sent it to a mate who couldnt open it on safari
waddhuiy
@waddhuiy
Nov 14 2014 18:35
I'm running chrome here stull
Martin O'Grady
@grady-lad
Nov 14 2014 18:36
try on safari there
waddhuiy
@waddhuiy
Nov 14 2014 18:37
Yeah it's not doing anything on safari now...
Martin O'Grady
@grady-lad
Nov 14 2014 18:37
fuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuck
waddhuiy
@waddhuiy
Nov 14 2014 18:38
It was working earlier. I was trying it as I went along
Martin O'Grady
@grady-lad
Nov 14 2014 18:44
is it just the header text that was wrong?
waddhuiy
@waddhuiy
Nov 14 2014 18:44
No the whole lot is wrong I'm afraid.
Martin O'Grady
@grady-lad
Nov 14 2014 18:48
Ah we to get it right
sure we havta to find out what the safari proboe
problem is also
fucking web development
right, I am getting back on it so
Martin O'Grady
@grady-lad
Nov 14 2014 18:49
how we meant to make a site if we cannot get a bloody font correct
HELVETICA
I don't even know what a font is at this stage
waddhuiy
@waddhuiy
Nov 14 2014 18:50
That's exactly why I think it's an issue that we either don't realise (eg. helvetica is behind a paywall or something) or that it's just busted and out of your control, because this seems way more complicated than it should ever be...
alright, I am going to google for this one
ok, ok, ok
has anyone got the helvetica font files
!! -> twbs/bootstrap#13823
We need a new font
for titles and the text
waddhuiy
@waddhuiy
Nov 14 2014 18:55
Holy shit
What fucking NOOB picked that font
there are so many of these gotchas for web site development
right paddy, roll the dice again please
waddhuiy
@waddhuiy
Nov 14 2014 18:56
Want to try out Arial? I know it's everyones go to font and it seems like shit but its actually extremely close to helvetica
OK, gonna give it a whirl
waddhuiy
@waddhuiy
Nov 14 2014 18:56
It should be easy to implement there.
Martin was begging me to use Helvetica Neue but I knew it'd be a disaster. Especially when you bootstrap it. Fucking noob
He just cost us a a days work?!
MARTY
look, if this doesn't work we're going Comic Sans
waddhuiy
@waddhuiy
Nov 14 2014 18:58
Perfect
RIGHT. EVERYONE CLEAR THEIR CACHE AND LOOK AND PLAY THE FUCKING CHORD
waddhuiy
@waddhuiy
Nov 14 2014 19:02
Hahaha
what, is it just me or is everything broken now
waddhuiy
@waddhuiy
Nov 14 2014 19:03
It's working here, but with the same fonts...
:crying_cat_face:
hahahaha I have no idea ... it says we are using Arial now for me
"Arial, Helvetica, sans-serif" !important
waddhuiy
@waddhuiy
Nov 14 2014 19:04
ok
and which font does it look closer to...
am I retarded, what is happening
The top 'Why' or the bottom one?
Martin O'Grady
@grady-lad
Nov 14 2014 19:05
here Luke is confused
what is the font
hahahahahaha
Martin O'Grady
@grady-lad
Nov 14 2014 19:05
paddy go on skype
9 hours later
this is nuts
lets just quit
Maybe this has something to do with heroku
and no fonts on the machine
waddhuiy
@waddhuiy
Nov 14 2014 19:07
But which did it look more like there Luke? Maybe it's my machine...
Worked beautifully there on safari by the way
the top one right?
"Ill give you a hint, you live there"
waddhuiy
@waddhuiy
Nov 14 2014 19:08
Holy fuck
So your machine got closer then...
Martin O'Grady
@grady-lad
Nov 14 2014 19:08
get on skype paddy
waddhuiy
@waddhuiy
Nov 14 2014 19:08
If it looked like the above font
I'm signing in MARTIN! GET OFF MY CASE!
AM I GOING INSANE?
Martin O'Grady
@grady-lad
Nov 14 2014 19:08
PLAY THE FUCKING CHORD !!!!!!!!!!!!11
waddhuiy
@waddhuiy
Nov 14 2014 19:09
FUCK SAKE!!!
FUCKING CHORD
waddhuiy
@waddhuiy
Nov 14 2014 19:10
Screen Shot 2014-11-14 at 19.09.49
fuckingfonts-2.jpg
Screen Shot 2014-11-14 at 19.09.49.png
Screen Shot 2014-11-14 at 19.09.49.png
that is what I am seeing
that's under the profiler ...
looks like the bootstrap stuff is a killer ... also the picture of my face
profiler.png
:worried:
profiler.png
fuck I can;'t even upload the photo
waddhuiy
@waddhuiy
Nov 14 2014 19:23
You need me to resize that and make it smaller so?
oh wait, there they are
ok, so the font is working
we need to get the safari shit sorted
do you think it is specifically safari or its just the app loads so slowly and random shit breaks
Martin O'Grady
@grady-lad
Nov 14 2014 19:31
?
Martin O'Grady
@grady-lad
Nov 14 2014 19:38
how slow is the site for you
and when ya click the nav buttons real fast does it go all over the place?
recompiling the node modules there, app will de down
nerdlinger
back up
check that marty
emails:
waddhuiy
@waddhuiy
Nov 14 2014 21:49
Yo I'm back. So it loaded in safari perfectly there and then when I tried to reload it it did the same thing from earlier. The progress bar filled up fully and the first image began to fade in and then the whole screen went white and won't budge. It still works fine on Chrome and the font is still arial (yes!).
It does start losing its shit when I try and press the buttons too fast though too...
Screen Shot 2014-11-14 at 21.50.09.png
So it loads up and goes to the intro text as normal but none of the menu circles are filled in. That hasn't happened before. Not exactly a massive deal though.
hey, we're just stopping work on it now
just pushed a menu fix there. Don't think anyone is going to be going mad with the menu
the email is currently broken
haha
nightmare, will get this out the door tomorrow. nice one on the safari check
loading times are much better here, we stripped out a load of crap
BEER TIME
waddhuiy
@waddhuiy
Nov 14 2014 23:18
Good job lads. Drinks well deserved. Sorry about the wild goose chase. Enjoy!