Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • May 26 09:42
    win1010525 synchronize #232
  • May 25 01:49
    zxystd commented #778
  • May 25 01:48
    zxystd commented #778
  • May 23 16:07
    efeckgz opened #778
  • May 23 15:03
    singhalrishi27 commented #764
  • May 20 13:26
    19521679 commented #769
  • May 19 08:33
    fanlasila commented #777
  • May 19 08:22
    williambj1 labeled #777
  • May 19 08:21
    williambj1 closed #777
  • May 19 08:21
    williambj1 commented #777
  • May 19 06:15
    Core-i99 commented #777
  • May 19 05:47
    Torstenp122 commented #777
  • May 19 05:40
    Core-i99 commented #777
  • May 19 05:38
    Torstenp122 opened #777
  • May 17 14:16

    github-actions[bot] on v2.2.0-alpha

    (compare)

  • May 17 14:16

    github-actions[bot] on v2.2.0-alpha

    (compare)

  • May 17 14:12

    zxystd on master

    In RUN state, we should not cha… (compare)

  • May 15 16:13
    williambj1 commented #776
  • May 15 14:51
    qqsir-dev commented #776
  • May 15 10:56
    zxystd labeled #764
war1644
@war1644

[ 2.614417]: AirportItlwm::init IO80211Legacy_kexts-30.4 "IO80211Legacy_kexts-30.4" Feb 4 2022 21:23:40
[ 2.759575]: IO80211Controller::createIOReporters 0xf7a9a1e40c13ae4d
[ 2.762916]: IO80211Controller::findAndAttachToFaultReporter no pipe found, making it
[ 2.763074]: IO80211Controller::start _controller is 0xf7a9a1e40c13ae4d, provider is 0xf7a9a1e8d8aebc4d
[ 2.773837]: itlwm: Found device cfg: Intel(R) Wi-Fi 6 AX201 160MHz fw: iwlwifi-QuZ-a0-hr-b0-48.ucode index: 29:192
[ 2.773842]: itlwm: Found PCI dev 06f0/0074, rev=0x354, rfid=0x10a100 fw: iwlwifi-QuZ-a0-hr-b0-48.ucode
[ 2.796426]: itlwm: taskq taskq_create_thread lock
[ 2.796429]: itlwm: taskq taskq_create_thread lock
[ 2.796430]: itlwm: taskq taskq_create_thread unlock
[ 2.796433]: itlwm: taskq taskq_create_thread unlock
[ 2.796438]: itlwm: taskq taskq_create_thread lock
[ 2.796440]: itlwm: taskq taskq_create_thread lock
[ 2.796441]: itlwm: taskq taskq_create_thread unlock
[ 2.796442]: itlwm: taskq taskq_create_thread unlock
[ 2.796443]: itlwm: taskq taskq_thread schedule task
[ 2.796444]: itlwm: ieee80211_channel_init
[ 2.796445]: itlwm: taskq taskq_thread schedule task
[ 2.796451]: itlwm: ieee80211_set_link_state nstate=2, old_state=-1
[ 2.796452]: itlwm: ieee80211_set_link_state LINK_STATE_IS_DOWN
[ 2.796454]: itlwm: ieee80211_media_init
[ 2.796500]: itlwm: iwx_prepare_card_hw
[ 2.796501]: itlwm: iwx_set_hw_ready
[ 2.796569]: itlwm: iwx_start_hw
[ 2.796570]: itlwm: iwx_prepare_card_hw
[ 2.796571]: itlwm: iwx_set_hw_ready
[ 2.807261]: itlwm: : L1 Disabled - LTR Enabled
[ 2.807579]: itlwm: iwx_check_rfkill RF_KILL hw: 0
[ 2.807581]: itlwm: iwx_run_init_mvm_ucode
[ 2.807582]: itlwm: iwx_load_ucode_wait_alive
[ 2.813504]: itlwm: load firmware iwlwifi-QuZ-a0-hr-b0-48.ucode done
[ 2.813507]: itlwm: parsing firmware iwlwifi-QuZ-a0-hr-b0-48.ucode
[ 2.813514]: itlwm: TLV_FW_FSEQ_VERSION: FSEQ Version: 43.2.23.17
[ 2.813517]: itlwm: iwx_read_firmware: found debug dest; n_dest_reg=0
[ 2.813519]: itlwm: Found debug configuration: 0
[ 2.813520]: itlwm: firmware parse done
[ 2.813642]: itlwm: iwx_start_fw
[ 2.813643]: itlwm: iwx_prepare_card_hw
[ 2.813644]: itlwm: iwx_set_hw_ready
[ 2.813894]: itlwm: : L1 Disabled - LTR Enabled
[ 2.813957]: itlwm: iwx_nic_config Radio type=0x0-0x2-0x1
[ 2.813978]: itlwm: iwx_load_firmware
[ 2.813979]: itlwm: iwx_ctxt_info_init
[ 2.935941]: itlwm: iwx_enable_fwload_interrupt
[ 3.937172]: itlwm: SecBoot CPU1 Status: 0x5ef9, CPU2 Status: 0x3
[ 3.937188]: itlwm: UMAC PC: 0x8048dbd2
[ 3.937190]: itlwm: LMAC PC: 0x4b5208
[ 3.937341]: itlwm: : could not load firmware
[ 3.937611]: itlwm: : failed to load init firmware
[ 3.937627]: itlwm: iwx_stop_device
[ 3.954820]: itlwm: iwx_check_rfkill RF_KILL hw: 0
[ 3.954821]: itlwm: iwx_prepare_card_hw
[ 3.954822]: itlwm: iwx_set_hw_ready
[ 3.955458]: itlwm: ieee80211_ifdetach
[ 3.955461]: itlwm: ieee80211_proto_detach
[ 3.955462]: itlwm: ieee80211_crypto_detach
[ 3.955464]: itlwm: ieee80211_node_detach
[ 3.955470]: itlwm: ifmedia_delete_instance
[ 3.955477]: itlwm: taskq taskq_thread schedule task done
[ 3.955480]: itlwm: taskq taskq_thread schedule task wakeup
[ 3.955488]: itlwm: taskq taskq_thread schedule task done
[ 3.955490]: itlwm: taskq taskq_thread schedule task wakeup
[ 3.955517]: itlwm: attach fail
[ 3.956468]: itlwm: free
[ 3.956486]: itlwm: virtual void ItlHalService::free()

Time ran: 2022-03-25 22:24:11.4860
Kext not loaded

macOS 版本12.3(版号21E5206e)

@zxystd 大佬能帮忙看看吗,非常感谢
zxystd
@zxystd
@war1644 QQ群号:1132224334
war1644
@war1644
ok
Dr Itachi
@Dr-Itachi
Hi. Before my iPhone didn’t able to detect my hack’s Airdrop now it detects without problem but i cannot send files. @zxystd i think you’re near the success please fix this if you can
xrntamd
@xrntamd:matrix.org
[m]
Hello. Airportitlwm randomly decided to stop working and I've been trying my hardest to fix it. Both IO80211FamilyLegacy and Airportitlwm can be seen when running kextstat. I've tried everything: using different builds of Airportitlwm, using regular Itlwm, resetting NVRAM, using older OpenCore versions, using older macOS versions, booting to the recovery partition, changing the arrangements of the kexts inside Config.plist, changing the SecureBootModel from Disabled, Default and j132 (the closest match for my SMBIOS, which is MacBookPro14,2)
I'm going to post the log I got
This is a really odd issue because as I said, the kexts can be seen when you run kextstat and the wireless card appears in the PCI section of Hackintool, and it's even recognized properly
xrntamd
@xrntamd:matrix.org
[m]
zxystd
@zxystd
@xrntamd:matrix.org Your card can't not be woke up by this driver, can you try to reboot to Windows and see if it can work? if so, reboot again to macOS and see if the issue fixed.
1 reply
xrntamd
@xrntamd:matrix.org
[m]
To mess around with the config and kexts since networking doesn't work on macOS
I just woke up, I left my PC running Windows before I went to sleep, I wake up and immediately boot to macOS
Nope
I recently upgraded to Windows 11 so maybe this new Windows driver handles the WiFi card differently?
xrntamd
@xrntamd:matrix.org
[m]
And yes WiFi always works on Windows
余航
@hang111881:matrix.org
[m]
有时候会出现网络面板显示已经连接,而且有ip地址,但是设备没网,而且右上角显示没网
ax201 + airportitlwm-montery v2.2.0 alpha 配置了DHCP手动设定地址
之前没配置DHCP手动设定地址的时候经常会出现连接到wifi但是没有分配ip地址的问题(使用一段时间或者休眠重新点亮),但是在网络中手动点击DHCP续租可以让wifi恢复工作
Sometimes the network panel will show that it is connected and has an IP address, but the device is not connected, and the upper right corner shows that there is no network
ax201 + airportitlwm-montery v2.2.0 alpha configured with DHCP to manually set the address
When DHCP was not configured to manually set the address, there was often a problem of connecting to the wifi but not assigning an IP address (it was used for a period of time or hibernation to re-ignite), but manually clicking DHCP to renew the lease in the network can make the wifi work again
Sometimes the network panel will show that it is connected and has an IP address, but the device is not connected, and the upper right corner shows that there is no network
ax201 + airportitlwm-montery v2.2.0 alpha configured with DHCP to manually set the address
When DHCP was not configured to manually set the address, there was often a problem of connecting to the wifi but not assigning an IP address (it was used for a period of time or hibernation to re-ignite), but manually clicking DHCP to renew the lease in the network can make the wifi work again
Sometimes the network panel will show that it is connected and has an IP address, but the device is not connected, and the upper right corner shows that there is no network
ax201 + airportitlwm-montery v2.2.0 alpha configured with DHCP to manually set the address
When DHCP was not configured to manually set the address, there was often a problem of connecting to the wifi but not assigning an IP address (it was used for a period of time or hibernation to re-ignite), but manually clicking DHCP to renew the lease in the network can make the wifi work again
1 reply
xrntamd
@xrntamd:matrix.org
[m]
I just tried booting to Linux, and it seems like the WiFi card isn't recognized there either
xrntamd
@xrntamd:matrix.org
[m]
miyuege
@miyuege
我的小米ruby15.6使用OC引导,换的 intel ax200网卡尝试添加itlwn和airportitlwn都出现白苹果无法开机,设置intel驱动需要注意哪些设置呢
rebecool
@rebecool
intel ax201你们会偶尔出现掉线的情况么
jazza
@jazza:phuks.co
[m]
jesus christ
A Human
@Human7900
Hi
My intel 7265 ngw wifi is not working
Seeing the networks but not connecting
Bluetooth works
@zxystd
bisaalz
@bisaalz
I have intel hd 3160 but on macos monterey bluetoolfixup kext causes bluetoothd crashes. Sometimes when i toggle bluetooth it shows volume hash mismatch and bluetoothd crash which result bluetooth not working. If i remove bluetoolfixup no crashes but bluetooth doesnot work.
zxystd
@zxystd
@bisaalz You can fire this issue to BluetoolFixup repo.

My intel 7265 ngw wifi is not working

No log, and any other useful information.

1 reply
mylife1234-cmd
@mylife1234-cmd
hello everyone
I don't understand between heliport and airport itlwm
Heliport is better than airport ?
Please help me
Thank everyone
Future is now
@0xd0a

Hey guys. There's a problem with App Store and Heliport (irlwm) on Catalina. I have an intel wifi 9260 and App store doesn't sign in or update. I confirmed that the problem is with the software cause USB dongle immediately fixes the problem. Also the logs on intel wifi show weird messages (specifically "Failed to obtain MAC address for no interface"):

default 02:22:02.375171+0300 App Store "Starting credential verification for account <private>."
error 02:22:02.376420+0300 accountsd "<private> is trying to verify account credentials for account: <private>"
default 02:22:02.376478+0300 accountsd "Account type <private> does support multiples."
default 02:22:02.379901+0300 accountsd AMSAccountAuthenticationPlugin: [*] Queuing a request to verify credentials for <ACAccount: ***** type = iTunesStore | backingID = ***** | username = ***** | altDSID =*****f | DSID = ***** | active = itunes; appstore | storefront = itunes:143456-2,42>. caller = com.apple.AppStore | originalOptions = {
ACShouldSave = 1;
AMSAuthenticateOptionsAllowSecondaryCredentialSource = 0;
AMSAuthenticateOptionsAllowServerDialogs = 1;
AMSAuthenticateOptionsAuthenticationTypeKey = 2;
AMSAuthenticateOptionsCanMakeAccountActiveKey = 1;
AMSAuthenticateOptionsClientInfo = {length = 691, bytes = * };
AMSAuthenticateOptionsCredentialSourceKey = 2;
AMSAuthenticateOptionsDefaultButtonString = "Sign In";
AMSAuthenticateOptionsLogKeyKey = *;
AMSAuthenticateOptionsPromptTitle = "Sign in to download from the App Store.";
AMSAuthenticateOptionsReason = "Enter the password for your Apple ID.";
AMSAu
default 02:22:02.380527+0300 accountsd AMSAccountAuthenticationPlugin: [*] Verifying credentials for <ACAccount: ***** type = iTunesStore | backingID = ***** | username = ***** | altDSID =***** | DSID = **** | active = itunes; appstore | storefront = itunes:143456-2,42>. attempt = 1 | maxAttempts = 1 | options = <AMSAuthenticateOptions: *****> {
AMSAuthenticateOptionsAllowSecondaryCredentialSource = 0,
AMSAuthenticateOptionsAllowServerDialogs = 1,
AMSAuthenticateOptionsAuthenticationTypeKey = 2,
AMSAuthenticateOptionsCanMakeAccountActiveKey = 1,
AMSAuthenticateOptionsClientInfo = {length = 691, bytes =* },
AMSAuthenticateOptionsCredentialSourceKey = 2,
AMSAuthenticateOptionsDefaultButtonString = Sign In,
AMSAuthenticateOptionsLogKeyKey = *,
AMSAuthenticateOptionsPromptTitle = Sign in to download from the App Store.,
AMSAuthenticateOptionsReason = Enter the password for
default 02:22:02.381501+0300 accountsd AMSAccountAuthenticationPlugin: [*] Performing the authentication.

AMSDevice: "Failed to obtain MAC address for no interface."

Yasoga Nanayakkarawasam
@Psycho649
Hey guys, I have an Intel(R) Dual Band Wireless-AC 3165. I have already installed Heliport but it can cannot provide intenet access. I can connect to the network, but no internet access. I'm running Monterey.
Yasoga Nanayakkarawasam
@Psycho649
UPDATE: I figured it out. All i had to do was create a network profile
1 reply
mlinton
@mlinton
so I think I'm following the guide to get my AX200 running on my macos vm, here is my list of kexts: ❯ kextstat|grep -v com.apple|more Executing: /usr/bin/kmutil showloaded No variant specified, falling back to release Index Refs Address Size Wired Name (Version) UUID <Linked Against> 51 3 0 0x2e000 0x2e000 as.vit9696.Lilu (1.6.0) 6167D1C2-7FCA-3319-8246-9CAAFA704235 <9 7 6 3 2 1> 52 0 0 0x81000 0x81000 as.vit9696.WhateverGreen (1.5.8) 82AA95B6-925F-35BF-A10E-527D98B3F235 <51 16 9 7 6 3 2 1> 53 0 0 0x197000 0x197000 as.vit9696.AppleALC (1.7.0) 57537BA7-ADE5-3112-A27B-C45F0CC6414A <51 16 9 7 6 3 1> 54 0 0 0xa000 0xa000 as.acidanthera.BlueToolFixup (2.6.1) 18E5797A-7E34-3670-9013-1F04275F75FF <51 9 7 6 3 2 1> 79 0 0 0xf92000 0xf92000 com.zxystd.itlwm (2.1.0) 9EA21A95-A8E4-3ED3-976D-EB380BDD7073 <49 16 7 6 3 1> 96 0 0 0x6d5000 0x6d5000 com.zxystd.IntelBluetoothFirmware (2.1.0) EB72D6E1-12D7-3035-8E82-2EC10ED3F7A9 <24 7 6 3> 167 3 0xffffff7f9a2f6000 0xb3000 0xb3000 org.virtualbox.kext.VBoxDrv (6.1.32) 2966CECD-ED9D-33B1-9B19-35D5B2F3C2A3 <9 7 6 3 1> 168 0 0xffffff7f9a3ca000 0x2000 0x2000 org.virtualbox.kext.VBoxNetAdp (6.1.32) 596D7961-E512-363D-B8C0-12F4B22D8678 <167 7 6 1> 169 0 0xffffff7f9a3d0000 0x4000 0x4000 org.virtualbox.kext.VBoxNetFlt (6.1.32) FCFA4205-F86E-3847-87F9-FD20D97978B2 <167 9 7 6 3 1> 171 0 0xffffff7f9a3d5000 0x5000 0x5000 org.virtualbox.kext.VBoxUSB (6.1.32) 2A227B02-53F7-3AC9-8633-3DA6BC2C99F6 <170 167 66 9 7 6 3 1>
oh that's ugly
but when I try to open heliport it complains that it isn't loaded
Sansyy
@Sansyyxd
Can problems about the IntelBluetoothFirmware be discussed here appropriately.
Here is the error log I get whenever I press the CAPS LOCK key on my Bluetooth Keyboard.
Ronein
@Ronein

intel ax201你们会偶尔出现掉线的情况么

recommend use the latest alpha version , I'd the same issue and solved until I had use the alpha version which's date 2022.4.5

jehuty2018
@jehuty2018
monterey 12.3.1版本网络使用一段时间后wifi会失去响应,进而相关wifi相关设置都会卡住,不能进行wifi相关操作,网卡是intel8265
bisaalz
@bisaalz
This message was deleted
2 replies
bisaalz
@bisaalz
So bluetooth Has Strange Toggle bug in monterey tested in intel ac 3160
1 .Bluetooth DO work with bluetoolfixup kext+IntelFirmware kext, It do connects and works. 2. But sometimes when you toggle bluetooth, bluetoolhd crashes and it shows volume hash mismatch. 3. If you check console app you see bluetoolhd crash. 4. It happens randomly when toggling bluetooth after sometimes or in a middle of work it crash. 5. If you toggle after reboot it start working. 6. Bluetooth doesnot work when wake from sleep.
bisaalz
@bisaalz
[bluetoothhdcrashAC3160.txt] Here is
log file when bluetooth crash r when toggling bluetooth. I asked in bluetoolfixup repo unfortunately no one reply. (https://files.gitter.im/5ecde0a9d73408ce4fe4fe2d/clQV/bluetoothhdcrashAC3160.txt)
559911
@559911
@bisaalz I have the same problem as you.😞intel 8260ac
Dr Itachi
@Dr-Itachi
@zxystd hi bro what’s up ? Please there’s not something that you can do with iPhone hospot ? Connecting my hack to my iPhone’s hospot is pain in ass