These are chat archives for PHPOffice/PhpSpreadsheet

29th
Dec 2017
santu1252
@santu1252
Dec 29 2017 04:25
We need to install only with composer?
I think autoload.php file is missing.
Adrien Crivelli
@PowerKiKi
Dec 29 2017 04:26
@santu1252 you must install with composer
If you are not familiar with composer, then require 'vendor/autoload.php'; is the key part here
santu1252
@santu1252
Dec 29 2017 04:32
How can we install composer in shared hosting. Do you have any idea?
Adrien Crivelli
@PowerKiKi
Dec 29 2017 04:34
develop on your local machine with composer, when everything is ready, upload everything to your host, including vendor folder
santu1252
@santu1252
Dec 29 2017 04:34
oh ok thank you so much @PowerKiKi
santu1252
@santu1252
Dec 29 2017 06:34
@PowerKiKi Could not find package phpoffice/phpspreadsheet at any version matching you
r PHP version 5.5.12.0
while installing with composer. Please help
Adrien Crivelli
@PowerKiKi
Dec 29 2017 06:35
PhpSpreadsheet requires PHP 5.6 minimum
PHP 5.5 has been out of maintenance for 1.5 years: http://php.net/supported-versions.php
jbtsp
@jbtsp
Dec 29 2017 21:30
What does scrutinizer at 3.94 and coverage 67% mean? Is PHPSpreadsheet trying to get to 100% on these?