Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Oct 19 11:27
    ephraimlambarte closed #55
  • Oct 19 11:27
    ephraimlambarte commented #55
  • Oct 19 10:01
    ephraimlambarte opened #55
  • Oct 19 02:59
    ephraimlambarte opened #54
  • Jan 25 17:13
    crearc commented #51
  • Jan 21 23:27
    PommeVerte commented #51
  • Jan 21 23:26

    PommeVerte on v3.1.1

    (compare)

  • Jan 21 23:23
    PommeVerte closed #52
  • Jan 21 23:23
    PommeVerte commented #52
  • Jan 21 23:20
    PommeVerte closed #51
  • Jan 21 23:20

    PommeVerte on master

    adding support for 3.4.x line o… adding configuration files for … made some changes to the test. … and 9 more (compare)

  • Jan 21 23:20
    PommeVerte closed #53
  • Jan 21 23:16
    PommeVerte opened #53
  • Jan 21 22:38

    PommeVerte on fix-missing-token

    added changelog for new version (compare)

  • Jan 21 00:57

    PommeVerte on fix-missing-token

    travis tests #3 (compare)

  • Jan 21 00:48

    PommeVerte on fix-missing-token

    travis tests #2 (compare)

  • Jan 21 00:41

    PommeVerte on fix-missing-token

    travis tests #2 (compare)

  • Jan 21 00:04

    PommeVerte on fix-missing-token

    travis tests (compare)

  • Jan 20 23:46

    PommeVerte on fix-missing-token

    adding key gebneration for test… (compare)

  • Jan 20 23:02

    PommeVerte on fix-missing-token

    copying missing files on instal… (compare)

Scott
@smolinari
ah. Ok.
Now we know where I went wrong. Doh!
Pulling spider/vagrant-update now.
Dylan Millikin
@PommeVerte
:))))) I get lost between branches and repos ALLLL the time lol
Scott
@smolinari
It is actually spider/vagrant-udate?
Dylan Millikin
@PommeVerte
yeah with the typo lol
Dylan Millikin
@PommeVerte
any success?
Scott
@smolinari
I am having trouble with composer.
 [RuntimeException]
  Failed to clone git@github.com:satooshi/php-coveralls.git via git, https, s
  sh protocols, aborting.
  - git://github.com/satooshi/php-coveralls.git
    fatal: No such remote 'composer'
  - https://github.com/satooshi/php-coveralls.git
    fatal: No such remote 'composer'
  - git@github.com:satooshi/php-coveralls.git
    fatal: No such remote 'composer'
Dylan Millikin
@PommeVerte
that’s a weird error. no such remote composer? whaa
Scott
@smolinari
:smile:
S............................................................S.  63 / 112 ( 56%)
............S...............SS...................               112 / 112 (100%)

Time: 51.8 seconds, Memory: 28.00Mb

There were 5 skipped tests:

1) Spider\Test\Integration\QueryBuilder\WithNeo4jTest::testDrop
Cypher processor needs traversal logic before being able to drop.

/var/www/public/Spider/tests/Integration/QueryBuilder/WithNeo4jTest.php:45

2) Spider\Test\Unit\Drivers\Gremlin\DriverTest::testFormatTree
Tree is not yet implemented as gremlin-server doesn't currently support it

/var/www/public/Spider/tests/Unit/Drivers/Gremlin/DriverTest.php:254

3) Spider\Test\Unit\Drivers\Neo4J\DriverTest::testFormatTree
Tree is not yet implemented as gremlin-server doesn't curently support it

/var/www/public/Spider/tests/Unit/Drivers/Neo4J/DriverTest.php:216

4) Spider\Test\Unit\Drivers\OrientDB\DriverTest::testFormatTree
Tree is not yet implemented as orient doesn't currently support it

/var/www/public/Spider/tests/Unit/Drivers/OrientDB/DriverTest.php:239

5) Spider\Test\Unit\Drivers\OrientDB\DriverTest::testFormatPath
Path is not yet implemented as orient doesn't currently support it

/var/www/public/Spider/tests/Unit/Drivers/OrientDB/DriverTest.php:244

OK, but incomplete, skipped, or risky tests!
Tests: 112, Assertions: 557, Skipped: 5.

Generating code coverage report in Clover XML format ... done

Generating code coverage report in HTML format ... done
It also worked without having to change the password too. So, theoretically, that step can be removed from the docs?
Dylan Millikin
@PommeVerte
awesome
well I’m not sure because normally vagrant should do everything automatically? the docs are for people who ant to do it manually?
Scott
@smolinari
Ah, yeah. That is correct.
Scott
@smolinari
Ok. Things seem to be stable now. Trying to upgrade to OrientDB 2.1.6, which was what I wanted to do to begin with.
Dylan Millikin
@PommeVerte
:)
cool
Scott
@smolinari
I've made some changes, so both the web clients work with Neo4j and OrientDB. Still need other work, so this is more automated.
Scott
@smolinari
Ok. I didn't make any changes to the gremlin stuff, and only changed the ODB version to 2.1.6 and now I am back to the "no property: g for class" errors. Buggers....
I think I'll quit for the day.
Dylan Millikin
@PommeVerte
oh damn that’s so strange
maybe michael will be able to join in on this and have a better idea. I’m not familiar with vagrant so it’s a little difficult for me
Scott
@smolinari
No problem.
ahhhh... wait. It is that problem with /tmp/neo4j
Hmm..
Dylan Millikin
@PommeVerte
ohh there you go
Scott
@smolinari
Actually. It isn't that. Hmm...
This is happening on startup.
[WARN] GraphManager - Graph [graphT] configured at [conf/neo4j-empty.properties] could not be instantiated and will not be available in Gremlin Server.                 GraphFactory message: GraphFactory could not find [org.apache.tinkerpop.gremlin.neo4j.structure.Neo4jGraph] - Ensure that the jar is in the classpath
java.lang.RuntimeException: GraphFactory could not find [org.apache.tinkerpop.gremlin.neo4j.structure.Neo4jGraph] - Ensure that the jar is in the classp               ath
        at org.apache.tinkerpop.gremlin.structure.util.GraphFactory.open(GraphFactory.java:63)
        at org.apache.tinkerpop.gremlin.structure.util.GraphFactory.open(GraphFactory.java:104)
        at org.apache.tinkerpop.gremlin.server.GraphManager.lambda$new$28(GraphManager.java:50)
        at java.util.LinkedHashMap$LinkedEntrySet.forEach(LinkedHashMap.java:663)
        at org.apache.tinkerpop.gremlin.server.GraphManager.<init>(GraphManager.java:48)
        at org.apache.tinkerpop.gremlin.server.util.ServerGremlinExecutor.<init>(ServerGremlinExecutor.java:94)
        at org.apache.tinkerpop.gremlin.server.GremlinServer.<init>(GremlinServer.java:89)
        at org.apache.tinkerpop.gremlin.server.GremlinServer.main(GremlinServer.java:301)
[INFO] ServerGremlinExecutor - Initialized Gremlin thread pool.  Threads in pool named with pattern gremlin-*
[INFO] ScriptEngines - Loaded nashorn ScriptEngine
[INFO] ScriptEngines - Loaded gremlin-groovy ScriptEngine
[WARN] GremlinExecutor - Could not initialize gremlin-groovy ScriptEngine with scripts/gremlin-spider-script.groovy as script could not be evaluated - j               avax.script.ScriptException: groovy.lang.MissingPropertyException: No such property: graphT for class: Script1
Dylan Millikin
@PommeVerte
that’s because the -i neo4j install wasn’t done
Scott
@smolinari
This?
# get neo4j dependencies
#$INSTALL_DIR/$GREMLIN_DIR/bin/gremlin-server.sh -i org.apache.tinkerpop neo4j-gremlin $GREMLINSERVER_VERSION-incubating
How the heck did the # get in there, if it is that.
Scott
@smolinari
Ok. The same thing is under the dependencies.
Dylan Millikin
@PommeVerte
yeah that’s the line you need to run to install neo
Scott
@smolinari
Ok. It says the neo4j plugin is already installed. I think I need to start over and rebuild the server. It worked earlier without any issues.
But, I am quitting for the day.
Too tired.
Have a nice evening and thanks for the help.
Dylan Millikin
@PommeVerte
I can understand. debugging can get really old real fast ;p
have a nice night
Scott
@smolinari
Oh brother. I let Vagrant rebuild the server from scratch and now the Gremlin/Neo4j side works, but the Orientdb side doesn't. Though, I am working with 2.1.6 now. Hmm... I think I'll go back to 2.1.0 and see if it works.
Scott
@smolinari
Aha! It is a permissions issue. It seems the Orientdb installation gets the user 501, which isn't even a user. Don't understand why this is happening now. But, the vagrant build did it for 2.1.0 too. Hmm....
Scott
@smolinari
Drum roll please......
Scott
@smolinari
Didn't work. This is strange, because if I restart the ODB server through SSH, then it starts working.
Scott
@smolinari
Ok. I have it. Not sure why, but it is because of the startup script uses server.sh and not orientdb.sh. I changed them to use /orientdb.sh start and it seems to work properly now. I'll ask Chris what he thinks.
Scott
@smolinari
Oh yeah!
S............................................................S.  63 / 112 ( 56%)
............S...............SS...................               112 / 112 (100%)
Dylan Millikin
@PommeVerte
awesome!!
vij4yk
@Vij4yk
i need php - gremlin - laravel driver