Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 15:58
    mrcrille commented #97
  • 15:23
    mrcrille commented #97
  • 15:20
    mrcrille commented #97
  • 15:18
    mrcrille opened #97
  • 15:11
    rom1504 commented #97
  • 15:06
    mrcrille opened #97
  • Mar 12 10:08
    SuperOP535 closed #92
  • Jan 13 21:26
    rom1504 commented #95
  • Jan 13 18:12
    rom1504 opened #96
  • Jan 13 18:11
    rom1504 opened #95
  • Nov 29 2018 20:42

    rom1504 on master

    Change some functions to arrow … (compare)

  • Nov 29 2018 20:42
    rom1504 closed #94
  • Nov 29 2018 20:33
    SuperOP535 synchronize #94
  • Nov 29 2018 20:31
    SuperOP535 synchronize #94
  • Nov 29 2018 20:29
    SuperOP535 opened #94
  • Nov 29 2018 18:31
    SuperOP535 closed #93
  • Nov 29 2018 08:56
    SuperOP535 opened #93
  • Nov 25 2018 15:53

    rom1504 on master

    update chat badges (compare)

  • Nov 15 2018 13:29
    SuperOP535 opened #92
  • Nov 15 2018 13:23
    SuperOP535 commented #75
mhsjlw
@mhsjlw
and my terminal does as well so i use nvim
William Gaylord
@wgaylord
So why is the json file not a protoDef json file? Or has protoDef added a ton of new stuff in the last day?
mhsjlw
@mhsjlw
vscode for typescript, nvim for everything else
Robin Lambertz
@roblabla
IC
@chibill Basically, hansihe had a few ideas that he thought would make the JSON more readable, so they were added there as well.
notably, the union type, that combines Mapper and Switch
Hans Elias J.
@hansihe
chibill: that's how the protocol.json equivalent would look like. some of the builtin types have been changed to be more composable
Robin Lambertz
@roblabla
and the virtual type.
I like your union type so much better than the mapper type BTW
Hans Elias J.
@hansihe
it also cleans up the way count works by a big margin
William Gaylord
@wgaylord
so you made the JSON very make less sense? Not sure how its more readable now...... THe union type is fine...
Hans Elias J.
@hansihe
what about it do you think makes less sense?
mhsjlw
@mhsjlw
but i'll likely do tmLanguage (atom and sublime), vim and (maybe) emacs
William Gaylord
@wgaylord
Guess either have to fight with messy json or use a new lang.... hard choices.
Hans Elias J.
@hansihe
if you give me something concrete to work with, I can improve it
Suggestions?
William Gaylord
@wgaylord
Well whats with fields? And why can a thing have more then one type?
Also would ref to do?
Robin Lambertz
@roblabla
fields popped up because of virtual.
I wonder if we could find a not-too-shitty way to remove it though
Hans Elias J.
@hansihe
I'm all for removing it if there is a nice way
William Gaylord
@wgaylord
Also calling your unions unions might confuse people who code C... As unions are things that reference the same data different ways.
Robin Lambertz
@roblabla
Well, that's sort of what we're doing here.
Hans Elias J.
@hansihe
chibill: that's exactly what unions do here though
Robin Lambertz
@roblabla
Specifically, we're a tagged union.
Hans Elias J.
@hansihe
besides, calling them enums might confuse people who code java or rust
mhsjlw
@mhsjlw
^
Robin Lambertz
@roblabla
@hansihe well, they are pretty close to rust enums :P
Hans Elias J.
@hansihe
calling them sum types might confuse mathematicians
Robin Lambertz
@roblabla
And calling them switch might confuse old protodef users
:O
William Gaylord
@wgaylord
its not an enum or union its a switch...... as it just maps a value to a type..
thats all it does.
Hans Elias J.
@hansihe
it represents a "tagged union"
Robin Lambertz
@roblabla
^
William Gaylord
@wgaylord
unions reference the same data both ways at the same time... your union represents data in a way depending on what it is.
Robin Lambertz
@roblabla
oh wait. That link has too much maths on it
@chibill Yup. And that's called a tagged union
here shortened "Union"
mhsjlw
@mhsjlw
aside : i think this is fucking awesome compared to protodef's switch
William Gaylord
@wgaylord
what ever.
mhsjlw
@mhsjlw
fields obviously have to be in order, right ?
Robin Lambertz
@roblabla
yup
mhsjlw
@mhsjlw
@chibill we want your feedback, what do you suggest ?
Hans Elias J.
@hansihe
that's the mathematically correct naming
mhsjlw
@mhsjlw
with the constructive criticism that we've explained
William Gaylord
@wgaylord
Also one problem... having two types like one of the things has won't work....
Hans Elias J.
@hansihe
right, yeah