These are chat archives for PySide/pyside2

1st
May 2017
Ethan Smith
@ethanhs
May 01 2017 00:18
I would like to point out that the conda build is not official nor supported by either the PySide project or the Qt Company to my knowledge.
giumas
@giumas
May 01 2017 01:41
Good point! I don't know the source of the conda build, but the Gohlke one is https://github.com/krrr/PySide (http://www.lfd.uci.edu/~gohlke/pythonlibs/#pyside)
From IRC (bridge bot)
@FromIRC
May 01 2017 17:16
<grekkos> I'm trying to get PySide installed and working on my mac. Does PySide work well with the latest Qt 5.8 or is it better to use Qt4?
<grekkos> I am having some trouble setting up PySide and I think I might be trying to set up the older pyside (Qt4) with the newer Qt libraries (Qt5)
From IRC (bridge bot)
@FromIRC
May 01 2017 17:22
<Siecje> grekkos: I think you might need to use Qt 5.6 at this time.
From IRC (bridge bot)
@FromIRC
May 01 2017 17:39
<grekkos> Siecje: when I grab pyside from pip it shows PySide (1.2.4)
<grekkos> is PySide 1.2.4 for Qt4?
<grekkos> oh I see
<grekkos> thanks this is different from the one I was reading before
<grekkos> Siecje: would you recommend PySide 1 (Qt4) or PySide 2 (Qt5) ?
<grekkos> I have some experience with PySide in the past and Qt4
Padraig O Cuinn
@PadraigOCuinn
May 01 2017 17:41
hey guys does qtreewidget support contextmenus
From IRC (bridge bot)
@FromIRC
May 01 2017 17:41
<grekkos> and python 2.7
Padraig O Cuinn
@PadraigOCuinn
May 01 2017 17:42
grekkos how do you feel about the divide in python
From IRC (bridge bot)
@FromIRC
May 01 2017 17:45
<grekkos> Hmm I'm not sure, I used to use python a lot mostly for small support scripts to do file conversions and stuff like that on the command line and I learned in 2.7. Since Python 3 went stable I haven't used python much so I still use 2.7. I don't mind learning py3 but I still don't know what to do myself
Padraig O Cuinn
@PadraigOCuinn
May 01 2017 17:46
in the CG field there is only 2.7 available 3 isn't ready yet but it kind of saddens that they put a divide in and stopped full support of 2.7
From IRC (bridge bot)
@FromIRC
May 01 2017 17:48
<grekkos> So from what I'm reading now it looks like it depends on library support
<grekkos> Well it is 7 years old at this point so it's understandable
Padraig O Cuinn
@PadraigOCuinn
May 01 2017 18:31
yeah but 3 is still in its infancy and not studio ready yet
Ethan Smith
@ethanhs
May 01 2017 18:49
Fwiw, if the libraries you use support it, use Py 3
It is now 9 years old and quite mature