These are chat archives for PySide/pyside2

25th
Jun 2017
Conny WH Yu
@connyyu_twitter
Jun 25 2017 13:59

Hello, I have problems install PySide2 on a Mac os X. I am using a csh shell.

I have xcode installed and the following installed by homebrew:
qt 5.9.0_1
cmake 3.8.2
libxslt 1.1.29
libxml2 2.9.4_3

When I try to install pyside2 using the following command, I got a long list of error ending "Error compiling shiboken2".

python setup.py bdist_wheel --ignore-git --qmake=/usr/local/Cellar/qt5/5.6.1-1/bin/qmake --cmake=/usr/local/Cellar/cmake/3.8.2/bin/cmake --openssl=/usr/local/Cellar/openssl/1.0.2h_1/bin

The detailed error message is as follows
In file included from /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/apiextractor.cpp:40: /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/typesystem.h:1161:13: warning: 'targetLangPackage' overrides a member function but is not marked 'override' [-Winconsistent-missing-override] QString targetLangPackage() const ^ /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/typesystem.h:802:21: note: overridden virtual function is here virtual QString targetLangPackage() const ^ /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/typesystem.h:1170:13: warning: 'targetLangName' overrides a member function but is not marked 'override' [-Winconsistent-missing-override] QString targetLangName() const ^ /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/typesystem.h:790:21: note: overridden virtual function is here virtual QString targetLangName() const ^ /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/typesystem.h:1404:10: warning: 'isComplex' overrides a member function but is not marked 'override' [-Winconsistent-missing-override] bool isComplex() const ^ /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/typesystem.h:842:18: note: overridden virtual function is here virtual bool isComplex() const ^ /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/typesystem.h:1486:13: warning: 'targetLangPackage' overrides a member function but is not marked 'override' [-Winconsistent-missing-override] QString targetLangPackage() const ^ /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/typesystem.h:802:21: note: overridden virtual function is here virtual QString targetLangPackage() const ^ /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/typesystem.h:1884:25: warning: 'designatedInterface' overrides a member function but is not marked 'override' [-Winconsistent-missing-override] InterfaceTypeEntry *designatedInterface() const ^ /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/typesystem.h:815:33: note: overridden virtual function is here virtual InterfaceTypeEntry *designatedInterface() const ^ /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/apiextractor.cpp:171:47: error: use of undeclared identifier 'qAsConst' for (const AbstractMetaClass* metaClass : qAsConst(metaClasses)) { ^ /Users/Conny/pyside-setup/sources/shiboken2/ApiExtractor/apiextractor.cpp:259:41: error: use of undeclared identifier 'qAsConst' for (const HeaderPath &headerPath : qAsConst(m_includePaths)) ^ 5 warnings and 2 errors generated. make[2]: *** [ApiExtractor/CMakeFiles/apiextractor.dir/apiextractor.cpp.o] Error 1 make[1]: *** [ApiExtractor/CMakeFiles/apiextractor.dir/all] Error 2 make: *** [all] Error 2 error: Error compiling shiboken2
Any help will be much appreciated... thanks in advance.