These are chat archives for PySide/pyside2

19th
Jul 2017
Fredrik Averpil
@fredrikaverpil
Jul 19 2017 09:15
I’m having issues compiling pyside2 5.6 branch. Getting errors on compiling shiboken2… https://pastebin.com/NnUKEePR
Any idea in general what could be causing this? I’m using the Qt-provided libclang for RHEL/Centos7.
And by the way, why is it called /pyside-setup/pyside3_install? Why the "pyside3”?
From IRC (bridge bot)
@FromIRC
Jul 19 2017 09:22
<alcroito> the 3 is probably your python version
<alcroito> also saying errors without showing does not really help
Fredrik Averpil
@fredrikaverpil
Jul 19 2017 09:58
The errors are in the pastebin link
Ah, I edited my post and you probably don’t see edits...
From IRC (bridge bot)
@FromIRC
Jul 19 2017 10:00
<alcroito> @fredrikaverpil: judging by the errors, it seems you are not using the 5.6 branch but the 5.9 branch
Fredrik Averpil
@fredrikaverpil
Jul 19 2017 10:00
Hmm..
From IRC (bridge bot)
@FromIRC
Jul 19 2017 10:00
<alcroito> qAsConst is not used in the 5.6 branch of shiboken
Fredrik Averpil
@fredrikaverpil
Jul 19 2017 10:01
Ok, that’s odd
I’ve done a git --git-dir=pyside-setup/.git checkout remotes/origin/5.6
And I can see all the files being removed and added from that command
Fredrik Averpil
@fredrikaverpil
Jul 19 2017 10:08
After having checked out that branch, I get this when running a git branch: * (detached from origin/5.6)
ah, I think I got it now. Thanks @alcroito!
git clone -b 5.6 …… was a better way of getting the proper branch
From IRC (bridge bot)
@FromIRC
Jul 19 2017 10:11
<alcroito> np