These are chat archives for PySide/pyside2

10th
Jan 2018
From IRC (bridge bot)
@FromIRC
Jan 10 08:55
<venu> frkleint: Yes native C++ works but not PySide2
<venu> frkleint: I have tried it on two different linux machines running different versions of Ubuntu (17.10 and 16.04).
From IRC (bridge bot)
@FromIRC
Jan 10 09:02
<frkleint> weird but anyways
From IRC (bridge bot)
@FromIRC
Jan 10 14:14
<ctismer> frkleint venu said " instread of the proprietary NVIDIA driver"
<frkleint> did he
Fredrik Averpil
@fredrikaverpil
Jan 10 21:00

What can I do to fix this PySide2 build warning? (Windows)

-- Could NOT find LibXml2 (missing: LIBXML2_LIBRARIES LIBXML2_INCLUDE_DIR) (Required is at least version "2.6.32")
-- Could NOT find LibXslt (missing: LIBXSLT_LIBRARIES LIBXSLT_INCLUDE_DIR) (Required is at least version "1.1.19")
CMake Warning at ApiExtractor/CMakeLists.txt:12 (message):
  libxslt and/or libxml not found, disabling support for doc strings!

I’m doing a pip install lxml which installs fine prior to the build:

pip install lxml
Collecting lxml
  Downloading lxml-4.1.1-cp35-cp35m-win32.whl (3.2MB)
Installing collected packages: lxml
Successfully installed lxml-4.1.1

Any ideas?

Fredrik Averpil
@fredrikaverpil
Jan 10 21:05