These are chat archives for RSATom/Qt-RPi

17th
Jun 2016
SPlatten
@SPlatten
Jun 17 2016 07:13
Hi
I started installation from a clean build this morning of Ubuntu 16.04, started at 5am, its 8:15 here now, had to leave it and go to work, at work now...but install is going a lot better, will continue it this evening.
@RSATom Hi
I started installation from a clean build this morning of Ubuntu 16.04, started at 5am, its 8:15 here now, had to leave it and go to work, at work now...but install is going a lot better, will continue it this evening.
Sergey Radionov
@RSATom
Jun 17 2016 07:37
3 hours to install Ubuntu ?
it's very long I think...
Ubuntu is very very slow for me on ubuntu
I've tried make it fister, but decided it will be quicker just switch to xubuntu...
SPlatten
@SPlatten
Jun 17 2016 07:39
No, I installed it very quickly, but it was doing all the rsync stuff, thats what was taking the time.
Sergey Radionov
@RSATom
Jun 17 2016 07:39
ah... yes, it's long task.
btw, what rpi do you have? 2 or 3?
SPlatten
@SPlatten
Jun 17 2016 07:39
Hopefully when I get home tonight this will be better
3
I have a 2 but one of my son's is using that
Sergey Radionov
@RSATom
Jun 17 2016 07:39
I have both :)
my first Qt build was with RPi 3
SPlatten
@SPlatten
Jun 17 2016 07:40
I also have some beaglebone blacks was thinking of trying to install Qt on those.
I'm using Qt5.6 at work everyday on RedHat 7.2, but would like to get it running on the Pi3 so I can try out stuff on that
Sergey Radionov
@RSATom
Jun 17 2016 07:41
Hm.. It could be interesting... Does it have OpenGL support on board?
SPlatten
@SPlatten
Jun 17 2016 07:41
On which the Pi or at work?
At work I'm working on an i7
Sergey Radionov
@RSATom
Jun 17 2016 07:42
I'm about beaglebone blacks
SPlatten
@SPlatten
Jun 17 2016 07:43
ok, not sure, I haven't done anything on mine for quite a while....I think it has openGL support, they are 1Ghz arm processors, were faster than the Pi 1 at the tiem.
*time
Sergey Radionov
@RSATom
Jun 17 2016 07:44
understand...
btw, what sort of applications do you want develop on RPi? QML or Widgets apps?
SPlatten
@SPlatten
Jun 17 2016 07:45
Widgets
I am contracting for a defence company using Qt5.6 for a battleship gun GUI
Sergey Radionov
@RSATom
Jun 17 2016 07:46
Interesting
SPlatten
@SPlatten
Jun 17 2016 07:46
it is, very interesting, I want to see if I can run the same application on the Pi
Sergey Radionov
@RSATom
Jun 17 2016 07:47
But if you want use Widgets - it's possible you want run it as usual desktop app?
SPlatten
@SPlatten
Jun 17 2016 07:47
yes
Sergey Radionov
@RSATom
Jun 17 2016 07:48
hm... Then you don't need build Qt yourself
you could just get it with sudo apt-get install qt5-default
SPlatten
@SPlatten
Jun 17 2016 07:48
My application uses XML to define the placement of widgets and what to display where, the application reads the XML and renders the widgets
really ? that would be so good
Sergey Radionov
@RSATom
Jun 17 2016 07:49
yes
SPlatten
@SPlatten
Jun 17 2016 07:49
I will try it tonight, will that include QtCreator 5.6 in the install?
Sergey Radionov
@RSATom
Jun 17 2016 07:49
the only reason to build Qt from sources - is if you need hardware accelerated QML
I don't remember what Qt version is included to latest raspbian
SPlatten
@SPlatten
Jun 17 2016 07:50
That useful bit of information should be at the top of the various Wiki pages, would save so much time.
Sergey Radionov
@RSATom
Jun 17 2016 07:50
maybe something like 5.3
and even if you want it to hardware accelerated QML - it will work only fullscreen
and only single application at same time
SPlatten
@SPlatten
Jun 17 2016 07:51
thats all I need.
thank you, I will try tonight and let you know, do you have an email address I could send you updates on?
Sergey Radionov
@RSATom
Jun 17 2016 07:52
just write here
I'll get notifications
SPlatten
@SPlatten
Jun 17 2016 07:52
ok, ty
Sergey Radionov
@RSATom
Jun 17 2016 07:52
I'll try do the same on my side. Just a little bit limited in time. Same as you I think :)
SPlatten
@SPlatten
Jun 17 2016 07:53
ok, have to go now, will let you know.
Sergey Radionov
@RSATom
Jun 17 2016 07:53
have a good day
SPlatten
@SPlatten
Jun 17 2016 18:56
Hello Sergey, are you there?
I installed Qt with "sudo apt-get install qt-5default"
I meant "sudo apt-get install qt5-default"
however it installs 5.3, which my projects aren't compatible with, is there anyway to get 5.6 installed with this?