These are chat archives for RSATom/Qt-RPi

18th
Jun 2016
Sergey Radionov
@RSATom
Jun 18 2016 03:28
Hi
@SPlatten, sorry for long answer, I'm at GMT+7 so just was sleeping already :)

however it installs 5.3, which my projects aren't compatible with, is there anyway to get 5.6 installed with this?

no, there are only 5.3 in official repo, but I've seen some not official. I'll try find it.

Sergey Radionov
@RSATom
Jun 18 2016 03:35
@SPlatten, I've found it: https://twolife.be/raspbian/
SPlatten
@SPlatten
Jun 18 2016 05:36
@RSATom, I downloaded the script with "wget https://github.com/Topguy/Raspberry-Qt5-experiments/blob/master/qt5_twolife_jessie_setup.sh", then "chmod +x qt5_twolife_jessie_setup.sh", excuted "./qt5_twolife_jessie_setup.sh", but it reports errors with "./qt5_twolife_jessie_setup.sh": line 5: syntax error near unexpected token 'newline' ./qt5_twolife_jessie_setup.sh: line5 '<!DOCTYPE html>'"
Sergey Radionov
@RSATom
Jun 18 2016 07:08
you should use wget https://raw.githubusercontent.com/Topguy/Raspberry-Qt5-experiments/master/qt5_twolife_jessie_setup.sh
i.e use raw file presentation. By wget https://github.com/Topguy/Raspberry-Qt5-experiments/blob/master/qt5_twolife_jessie_setup.sh you downloaded html page
SPlatten
@SPlatten
Jun 18 2016 07:14
Thanks I'll try it now
hmmmm. I get "No such file or directory"
is /blob/ supposed to be in the URL ?
Sergey Radionov
@RSATom
Jun 18 2016 07:19
try open https://raw.githubusercontent.com/Topguy/Raspberry-Qt5-experiments/master/qt5_twolife_jessie_setup.sh directly
in browser
ah... I gave you wrong url
hm... not
ok, try open https://raw.githubusercontent.com/Topguy/Raspberry-Qt5-experiments/master/qt5_twolife_jessie_setup.sh in browser
SPlatten
@SPlatten
Jun 18 2016 07:20
thats better
its downloading now
Sergey Radionov
@RSATom
Jun 18 2016 07:21
tbh there are nothing specific in this script
you could do all the same by hand
SPlatten
@SPlatten
Jun 18 2016 07:22
what does it do?
Sergey Radionov
@RSATom
Jun 18 2016 07:23
it adds repo from https://twolife.be/raspbian/ to system and installs qt from there
SPlatten
@SPlatten
Jun 18 2016 07:23
excellent, thank you so much for your time and help
Sergey Radionov
@RSATom
Jun 18 2016 07:23
and also change OpenGL libs to valid one
/me have to go for couple hours
SPlatten
@SPlatten
Jun 18 2016 07:28
ok, thanks again
Sergey Radionov
@RSATom
Jun 18 2016 07:28
np
SPlatten
@SPlatten
Jun 18 2016 10:21
Sorry to say that update has bricked my Pi 3, I will have to reflash the SD card.
@RSATom, Sorry to say that update has bricked my Pi 3, I will have to reflash the SD card.
Sergey Radionov
@RSATom
Jun 18 2016 11:55
really? hm... sounds strange...
Sergey Radionov
@RSATom
Jun 18 2016 12:31
Did you enable experimental OpenGL drivers?
Sergey Radionov
@RSATom
Jun 18 2016 14:43
I've finished building Qt 5.7 on xubuntu 16.04 - didn't get any errors...
The only thing not mentioned in https://wiki.qt.io/RaspberryPi2EGLFS I had to do is sudo apt-get install build-essential
SPlatten
@SPlatten
Jun 18 2016 15:29
I didn't, I just downloaded the link then did and update and upgrade, I noticed it uninstalled qtcreator then I did an dist-upgrade and it bricked.
Sergey Radionov
@RSATom
Jun 18 2016 15:30
using dist-upgrade on raspberry pi is bad idea
SPlatten
@SPlatten
Jun 18 2016 15:30
The odd thing is when I switch on I don't get any self test or bios messages either.
I think I'm going to have to reflash the SD card
Sergey Radionov
@RSATom
Jun 18 2016 15:31
rpi don't have any bios
SPlatten
@SPlatten
Jun 18 2016 15:31
ok, I mean the startup boot tests
the display never wakes up
Sergey Radionov
@RSATom
Jun 18 2016 15:32
bootloader on rpi don't show any output exept color square
SPlatten
@SPlatten
Jun 18 2016 15:32
I normally see lots of tests during boot
Sergey Radionov
@RSATom
Jun 18 2016 15:33
it's from linux, not from bootloader
SPlatten
@SPlatten
Jun 18 2016 15:33
ok, I guess my sd card is screwed
Sergey Radionov
@RSATom
Jun 18 2016 15:34
maybe...
SPlatten
@SPlatten
Jun 18 2016 15:36
g2g now, I'll be back l8r
SPlatten
@SPlatten
Jun 18 2016 17:42
SD card flashed, updating jessie now, with qt5_twolife_jessie_setup.sh
SPlatten
@SPlatten
Jun 18 2016 18:19
Having now got back to where I was, I've installed qt5-default, which seems to have installed Qt5.5, but I cannot install qtcreator, it comes up with: qtcreator: Depends qtbase-abi-5-3-2, qtdeclarative-5-3-2 qtquickl-abi-5-2-1
I've just rebooted the Pi and now it doesn't boot again.