These are chat archives for RSATom/Qt-RPi

19th
Jun 2016
Sergey Radionov
@RSATom
Jun 19 2016 02:50
@SPlatten, hm... let me do the same
Sergey Radionov
@RSATom
Jun 19 2016 03:29
it looks like install script a little bit wrong or outdated
Sergey Radionov
@RSATom
Jun 19 2016 04:55
what about qtcreator - https://twolife.be/raspbian/ doesn't contain it.
so you will have build it yourself
SPlatten
@SPlatten
Jun 19 2016 05:37
Does the download include the source for qtcreator?
SPlatten
@SPlatten
Jun 19 2016 05:39
Thank you
Sergey Radionov
@RSATom
Jun 19 2016 05:40
but maybe it will require Qt 4.7 - don't know.
SPlatten
@SPlatten
Jun 19 2016 05:40
Mmmm.... It isn't simple is it?
Sergey Radionov
@RSATom
Jun 19 2016 05:40
I've successfully built Qt 4.7 for RPi, but it looks like it not so easy for you by some reason...
SPlatten
@SPlatten
Jun 19 2016 05:41
I don't think the version of qtcreator follows the versions of qt
Sergey Radionov
@RSATom
Jun 19 2016 05:42
yes, it don't, but it could use some new features from newer Qt versions
SPlatten
@SPlatten
Jun 19 2016 05:42
I'll be back later got to go out now thanks again
Sergey Radionov
@RSATom
Jun 19 2016 05:43
ok
SPlatten
@SPlatten
Jun 19 2016 08:17
Hi, when I try to 'wget' the script I get a html file again.
SPlatten
@SPlatten
Jun 19 2016 08:29
nvm, got it
SPlatten
@SPlatten
Jun 19 2016 09:09
@RSATom, I got the script from your last link, applied to my Pi3 and it bricked it...again! fortunately I backed up the image before applying, did you try this on a Pi3?
Sergey Radionov
@RSATom
Jun 19 2016 10:11
hm... I don't understand why. There are nothing related to boot in this script. And yes, I've tested it on RPi 3
You could look to script contents, I've removed all potentially dangerous stuff from there...
SPlatten
@SPlatten
Jun 19 2016 10:15
I don't understand either, the image was clean and a fresh install. I applied the script and when compete restarted. I am booting with a monitor connected to the hdmi port nothing is visible after the image.
Sergey Radionov
@RSATom
Jun 19 2016 10:16
how much time did you wait? Did you try power off/on it?
All I can recommend you - try execute commands from .sh one by one, with reboot after every one, to find out what exactly command breaks your system.
SPlatten
@SPlatten
Jun 19 2016 10:22
The script runs and completes without error but the pi will not come back after boot
It takes too long to rebuild to try every command then rebuild
Sergey Radionov
@RSATom
Jun 19 2016 10:23

then you could try this

sudo apt-get update
sudo apt-get -y --force-yes install apt-transport-https

# Add the twolife.be repository.
sudo bash -c 'cat << EOF > /etc/apt/sources.list.d/twolife.list
# Raspbian Jessie (stable)
deb https://twolife.be/raspbian/ jessie main qt
deb-src https://twolife.be/raspbian/ jessie main qt
EOF'

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-key 2578B775

as first step

it just adds twolife.be/raspbian repo to your system
SPlatten
@SPlatten
Jun 19 2016 10:24
I'm still waiting for my sd card to be restored from backup takes a long time