These are chat archives for RSATom/Qt-RPi

2nd
Jul 2016
Sergey Radionov
@RSATom
Jul 02 2016 04:02

I got QT5.7 installed on the pi3 but it doesn't install qtcreator. I then installed QtCreator now it doesn't work anymore

how exactly did you install Qt5.7? As described in https://wiki.qt.io/RaspberryPi2EGLFS ?

SPlatten
@SPlatten
Jul 02 2016 05:34
By replacing 5.6 with 5.7 on the git pull line that's it.
Sergey Radionov
@RSATom
Jul 02 2016 08:54
I think when you installed QtCreator (with apt-get install, right?) you've replaced some library
btw, it's better skip step 11. Still on the device, fix the EGL/GLES library nonsense: and load GL libs with LD_PRELOAD
SPlatten
@SPlatten
Jul 02 2016 11:05
hi are you there, sorry been out
I'm just redoing the SD card, already have Qt already downloaded and built on my ubuntu 16.04 virtual machine ready to roll out once SD card is ready
what do mean about LD_PRELOAD ?
Sergey Radionov
@RSATom
Jul 02 2016 13:25

what do mean about LD_PRELOAD ?

I just recommend not delete/change default system .so files (to not break something), and load libEGL.so and libGLESv2.so via LD_PRELOAD.
Something like add
export LD_PRELOAD=/opt/vc/lib/libEGL.so /opt/vc/lib/libGLESv2.so
before run your Qt QML based appliation

SPlatten
@SPlatten
Jul 02 2016 14:55
ok, will do