Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Trustfarm-heart
    @trustfarm-dev
    Anyone who interested and can do in HLS/DASH Player please PM me. I want to hire shortly.
    Sergey Radionov
    @RSATom
    @trustfarm-dev, Hi, It should support HLS/DASH since libvlc supports it.
    what about hire, if you need something JavaScript related then better ask @jaruba about it.
    but keep in mind WebChimera.js has multiple issues and not maintained atm.
    Alexandru Branza
    @jaruba
    i can confirm i'm capable of doing this
    Xiangjun Huang
    @xiangjunhuang
    I'm wondering how webchimera.js is able to work technically? Is it a npapi plugin or a ppapi plugin?
    Sergey Radionov
    @RSATom
    @xiangjunhuang, WebChimera.js is node.js addon. It's not use npapi nor ppapi.
    grougrou86
    @grougrou86
    Hello, I have an issue getting webchimera working but i seems i can not post an issue in github
    where should i ask my question
    ?
    thanks
    Sergey Radionov
    @RSATom
    @grougrou86, hi, Webchimera.js is in abandoned/deprecated state, that's why it's in read only mode on GitHub. But you still can ask your questions here.
    DN1985
    @DN1985
    Hello. What version of NW.JS is worked with WebChimera.js, what version of jquery?
    Sergey Radionov
    @RSATom
    @DN1985, don't know, I'm afraid you have to check it yourself. As start point you could look at releases page https://github.com/RSATom/WebChimera.js/releases
    haoyanhong
    @haoyanhong
    我需要在pc端,仅仅是浏览器展示,不包括桌面程序,展示rtsp格式的视频流,请问大家有案例嘛
    特别需要帮助
    Sergey Radionov
    @RSATom
    @haoyanhong, in English please...
    haoyanhong
    @haoyanhong

    I need to show the video stream in RTSP format in pc, browser. Do you have any cases?

    Especially in need of help

    haoyanhong
    @haoyanhong
    Asking for help
    Sergey Radionov
    @RSATom
    @haoyanhong, you can try to use Janus Server (https://janus.conf.meetecho.com/) - but your RTSP video stream format should be supported by browser or you will have to implement transcoding.
    haoyanhong
    @haoyanhong
    Could you tell me the specific implementation process, and I don't know where to start?
    Sergey Radionov
    @RSATom
    @haoyanhong, you will need setup Janus Server (read docs: https://github.com/meetecho/janus-gateway) and configure streaming plugin to connect to RTSP source (demo: https://janus.conf.meetecho.com/streamingtest.html)
    but keep in mind, it's not "5 minutes to run" solution.
    haoyanhong
    @haoyanhong
    Excuse me, is this what JavaScript can do? Or do we need other languages?
    Sergey Radionov
    @RSATom
    I don't know any way play RTSP directly in browser
    haoyanhong
    @haoyanhong
    ??
    Sergey Radionov
    @RSATom
    What exactly didn't you understand? I don't know any way connect from browser directly to RTSP source. Only with some sort of server which can transform RTSP to some format supported by browsers.
    竞走丷凝霜
    @ZhongAndGit
    How does the github address run after NPM install, NPM start or NPM run dev both fail
    Sergey Radionov
    @RSATom
    Sorry, don't understand you
    竞走丷凝霜
    @ZhongAndGit
    The github resource file is not working
    Sergey Radionov
    @RSATom
    @ZhongAndGit, if you need prebuilt binaries for latest Electron/NW.js versions - it's not available. You have to build it yourself from sources since project is in abandoned state.
    竞走丷凝霜
    @ZhongAndGit
    @RSATom Isn't there a complete project?It would be very confusing to rebuild
    Sergey Radionov
    @RSATom
    @ZhongAndGit , complete, but it's not supported anymore. I just don't want spend my limited time to update it.
    呼叫吃鸡小队
    @CallEatChicken
    hello,I'm on win64, i install Electron with npm install -g electron-prebuilt --arch=ia32
    image.png
    呼叫吃鸡小队
    @CallEatChicken
    Is there any other way around this error?
    Sergey Radionov
    @RSATom
    @CallEatChicken why you try use outdated Electron version?
    呼叫吃鸡小队
    @CallEatChicken
    Is it better to use the old version or the new version ? i have tried v1.3.9 . the version i should use corresponds to VLC
    image.png
    呼叫吃鸡小队
    @CallEatChicken
    I successfully used v1.4.13, but my VLC needs to play encrypted .mp4. Which method can directly add the corresponding parameter
    呼叫吃鸡小队
    @CallEatChicken
    i can not open file WebChimera.js.node,is there anything i can do?
    Sergey Radionov
    @RSATom

    @CallEatChicken

    Is it better to use the old version or the new version ? i have tried v1.3.9 . the version i should use corresponds to VLC

    It's better not use WebChimera.js at all. It's not supported anymore.

    呼叫吃鸡小队
    @CallEatChicken
    @RSATom ok , thank you!
    TheWanderingYouth
    @TheWanderingYouth
    the exe run another server, happened an error is " Cannot set property 'setting' of undefined
    at wjs.addPlaylist",but at my develop server , it was right. @RSATom .
    Sergey Radionov
    @RSATom
    @TheWanderingYouth, I'm pretty sure it can't load libvlc by some reason.
    TheWanderingYouth
    @TheWanderingYouth
    @RSATom Could you tell me what causes it?some key word.thank you!
    Sergey Radionov
    @RSATom
    @TheWanderingYouth I can't there are many possible reasons. I don't know even what OS do you use....
    Ruurd Bijlsma
    @RuurdBijlsma
    I saw there was some recent development on the webchimera repo, will the npm package also update?
    the package looks really nice, I can't get it to work though :( i can read the vlc version, so i think it does connect to libvlc. But any more than that basically does nothing, no errors, output or events
    but that was with the latest release from the repo, idk if that's stable or if i did something wrong