These are chat archives for RaiMan/SikuliX-2014

12th
Jul 2015
Jason Tolotta
@jtolotta
Jul 12 2015 11:50

I created an Eclipse Maven project and using the 1.1.0-SNAPSHOT of the sikulixapi.

The issue I have is that I used to be able to run my tests with just the following dependency.
<dependency>
<groupId>com.sikulix</groupId>
<artifactId>sikulixapi</artifactId>
<version>1.1.0-SNAPSHOT</version>
</dependency>

However, I started receiving a classpath dump with a RunTimeINIT error that requested that the /sikulixlibs/windows/libs64 be on the classpath.

I resolved this error by adding the following to POM.

    <dependency>
        <groupId>com.sikulix</groupId>
        <artifactId>sikulixlibsvision</artifactId>
        <version>1.1.0-SNAPSHOT</version>
    </dependency>
    <dependency>
        <groupId>com.sikulix</groupId>
        <artifactId>sikulixlibswin</artifactId>
        <version>1.1.0-SNAPSHOT</version>
    </dependency>
    <dependency>
        <groupId>com.nativelibs4java</groupId>
        <artifactId>bridj</artifactId>
        <version>0.7.0</version>
    </dependency>

Everything works again, but I am curious what changed in the nightly build to cause this to happen.

Great work though, SikuliX beats anything out there for flexibility and control.