Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Rintagi Development Team
    @rintagi-team
    Finally does Rintagi support workflow and is their documentation ie document can be approved through the different level like the way document are processed in an organization.
    Yes, this sounds this like a business requirement and can easily be built into the application using business rules
    enezatech
    @enezatech
    Hi, @rintagi-team thank you for your reply. ready to dive in.
    ali-alhuwswe
    @ali-alhuwswe
    Hi every one i am trying to install rintagi after installation complate i brows to http://localhost/ro but i getting this error "The requested page cannot be accessed because the related configuration data for the page is invalid."
    3 replies
    garyng2000
    @garyng2000
    change app pool to integrated mode
    Jousers
    @Jousers
    Hello Can anyway help me with this crystal reports error? I am following inital setup guide. choose the SP 20 Version 13.0.20 and the 64bit runtime. from https://www.tektutorialshub.com/crystal-reports/how-to-download-and-install-crystal-report-runtime/ I have installed the Could not load file or assembly 'CrystalDecisions.CrystalReports.Engine, Version=13.0.3500.0, Culture=neutral, PublicKeyToken=692fbea5521e1304' or one of its dependencies. The system cannot find the file specified.
    please remove "I have installed the" message from above as it was a typo
    garyng2000
    @garyng2000
    what version of crystal report runtime have you installed ? you may need to change 13.0.3500.0 to 13.0.2000.0 or something that machines your version
    Jousers
    @Jousers
    under installed programs, I show crystal reports runtime engine for .net framework as version 13.020.2399 and the Crystal reports version for Microsoft Visiual Studio as version 13.0.20.2399 also. Its intersted that the runtime error shows version 13.0.3500. What would be the resone for that?
    Jousers
    @Jousers
    no luck cant get past the crystal issue. To bad I really wanted to test out Rintagi.
    Jousers
    @Jousers
    I installed on another pc. Now the issue is ODBC driver. error IM002 Data source name not found and no default driver specified. Obviously, there is one. I can use odbc data source 64 bit and bring up the manager. do I connect with user dns or system dns. How do I configue the odbc driver?
    garyng2000
    @garyng2000
    did you use the power shell script to install the pre-requisites ? the only thing that need to be manually installed is the crystal report runtime which you need to get from SAP(need registration process) and depending on version you install, change the web.config
    Jousers
    @Jousers
    Thanks for the reply garyng2000. Yes I used the PS script. SAP is still working on my registration request before I can download version 13.0.3500.0, going on week now for them. however I was able to download Version=13.0.30.3805 and I changed all references to other version of Crystal in webconfig file to Version=13.0.30.3805 with same error just diffrent version references. Even when I use the crystal version 13.0.2000.0 it doesnt work. Do I need to change the publickey token too?
    garyng2000
    @garyng2000
    13.0.30 I think would be 13.0.4000.0, assuming it is the latest
    garyng2000
    @garyng2000
    for odbc, you can change it to 'sqloledb' in the web.config. It mostly work unless you disable TLS 1.0/1.1 for SQL server
    Jousers
    @Jousers
    thanks Gary The odbc is fixed, now I am back to the Crystal error. Sap gave the links to install Cr Version 13.0.30.3805. I did change all reference to version in webconfig to be 13.0.30.3805. This is correct right?
    I can confirm in control panel that the SAP Crystal Reports runtime engine for .NET frameworks for both 32 and 64 bit is version 13.0.30.3805
    I also have SAP Crystal Reports version for Microsoft Visual Studio version 13.0.30.3805
    But when I launch the localhost/ro from chrome I still receive Could not load file or assembly 'CrystalDecisions.CrystalReports.Engine, Version=13.0.30.3805, Culture=neutral, PublicKeyToken=692fbea5521e1304' or one of its dependencies. The system cannot find the file specified
    Line 414: <add assembly="CrystalDecisions.CrystalReports.Engine, Version=13.0.30.3805, Culture=neutral, PublicKeyToken=692fbea5521e1304" />
    I am at a loss any help you can provide please would be greatful. thanks
    Jousers
    @Jousers
    I replace all references to version 13.0.2000.0 to version 13.0.30.3805 also correct?
    garyng2000
    @garyng2000
    wrong 13.0.4000.0
    Jousers
    @Jousers
    you are saying that 13.0.4000.0 is the latest version right? but the link SAP provided me was 13.0.30.3805 How do I get the latest? if my webconfig show the 13.0.30.3805 version that is installed what makes it error out? does it point back to crystal?
    This is what SAP sent me in email link SAP Crystal Reports for Visual Studio (SP30) runtime engine for .NET framework MSI (64-bit)
    garyng2000
    @garyng2000
    they have two set of version numbers, what you are using are not the correct one, never.
    Jousers
    @Jousers
    Do I add as assemblies in VS? I am going to wipe and reinstall. I missed something someowhere. this cant be this difficutl
    Jousers
    @Jousers
    Garyng thank you for your help. I rebuilt my machine and now it works. Have a great weekend
    Jousers
    @Jousers
    yes I got it working. something about rebuilding from scratch really helps when all else fails.
    I am looking to build a digital bank. I neobank like Chime or vero. Do you think rintagi will be able to create the interface and scale?
    do you know anyone who has built similar application that I can pay and work with?
    Mark Martindale
    @MarkMartindal15_twitter
    I just installed and when I try to log in I get an error that the system cannot find RO.Common3. How do I install this?
    Nathanaƫl Hajjar
    @nhsolutions:matrix.org
    [m]
    hi, i finish the installation but i have a odbc problem --> any ideas ?
    garyng2000
    @garyng2000

    I just installed and when I try to log in I get an error that the system cannot find RO.Common3. How do I install this?

    try to switch to .NET 4.8 in web.config

    hi, i finish the installation but i have a odbc problem --> any ideas ?

    try to switch to sqloledb in web.config

    Nathanaƫl Hajjar
    @nhsolutions:matrix.org
    [m]
    "try to switch to sqloledb in web.config" --> that works !
    thanks
    Harshtone
    @Harshtone
    Screenshot (5).png
    i ran the Powershell scripts available in User guide to install all the dependencies . the crystal reports installation got auth error , so i installed crystal reports runtime for visual studio manually , and once completion of all the installation , i am getting the following error when i try to access rintagi in the URL
    Please help me with this , Thanks!
    Harshtone
    @Harshtone
    @Jousers .. i See you got the similar error, it would be really helpfull if you can help me with this thanks !!
    garyng2000
    @garyng2000
    not sure which version of crystal report runtime you have installed, the web.config needs to be changed to 13.0.3500.0 or 13.0.4000.0(or whichever version you have installed).
    Harshtone
    @Harshtone
    is there any possibility that we can conifgure rintagi without crystal reports !!.. if not can anyone share link for the crystal reports 13.0.2000.0 !.... cause i see crystal reports are not free anymore and they only provide with free trial version of 30 days !!
    garyng2000
    @garyng2000
    just remove the reference in web.config. the reports would not work but the rest is fine. Of course, if you open the project in vs studio, you may see compilation error for those pages as well.
    Gasper Milazzo
    @GasperMilazzo_twitter
    image.png
    when trying to install I get the following error in compile install Could not find a part of the path 'C:\Rintagi\RO\DeployROComDev\Install.csproj'.
    garyng2000
    @garyng2000
    this comes from a on screen button action, the package do not have the installer package. which screen you are using that trigger this ?
    Gasper Milazzo
    @GasperMilazzo_twitter
    Just installed it and was following the steps in the docs. Installing Development Package from RO
    Gasper Milazzo
    @GasperMilazzo_twitter
    ok reinstalled using install from github and now have this error
    image.png