Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    donicrosby
    @donicrosby
    Hi, I'm trying to figure out how to get Openroast to run on Ubuntu is there a way to build a deb file for it?
    Mark Spicer
    @lodge93
    There certainly can be a deb package built, and I would love to add it to the release if you create one. I am currently only looking to build packed versions for Mac and Windows for the time being, but would like to release deb and rpm packages in the future.
    segallis
    @segallis
    I am trying to get Openroast installed and running on Ubuntu. Tried the instructions for loading the pyserial driver and setting up a development environment (with lots of errors and warnings). I can't figure out how to install and run this software. I am also unable to find clear instructions on how to do so. Can anyone please point me in the right direction.
    Mark Spicer
    @lodge93
    @segallis I apologize, the documentation is a bit dated. I will update that now. The necessary versions of pyserial and freshroastsr700 are now in pypi. The Ubuntu instructions on the setting up a development environment should still be accurate. I last tested the instructions on Ubuntu 14.04. https://github.com/Roastero/Openroast/wiki/Setting-Up-A-Development-Environment#ubuntu-linux
    Mark Spicer
    @lodge93
    If you are running in a virtualenv, you will have to copy the pyqt files into it similar to the Mac instructions. Let me know what errors you are fighting with
    segallis
    @segallis
    So I was a bit confused by the instructions... looks like I don't need the development environment until I am ready to play with modifying the code? I did finally find Openroast-1.0.1.tar.gz and it took me a while to realize I didn't need to install anything, just need to open the tar and run "python3 Openroast.py". I did find that I either need to change permission to 777 for /dev/ttyUSB0 or else run python3 as sudo. I did roast some beans using one of the canned recipes, although it took closer to 40 mins to hit 2nd crack instead of the 14 mins in the recipe. My big question is that the "CURRENT TEMP" seems stuck. During the entire roast it stayed at 232, and then during cool down it was stuck at 237. And ideas on that one?
    segallis
    @segallis
    Any ideas on what is going on with the frozen current temp readings? I fumbled around a little with looking at the messages returned form the roaster, and I am wondering if the the SW may be looking at the wrong fields for the temp, and I also dont see weel behaved values coming back in the status messages
    segallis
    @segallis
    Still trying to find out if the temp logging works? Looks like either my unit is bad, or the software isn't ready for prime time?
    tony kerz
    @tony-kerz
    anyone have any luck running on el-capitan?
    int3ll3ct
    @int3ll3ct
    I have an alpha of Openroast 1.2 for Windows, v1.2.0a3, that I would need one or two volunteers to sanity-check. It nominally works for me. Please let me know, I'll arrange for an EXE installer drop in the next couple of days. (Openroast 1.2 is essentially a compatibility upgrade to work with the freshroastsr700 driver version 0.2.1, which has been extensively revised, including new PID control implementation and more parsimonious CPU usage.)
    Rikk Sullenberger
    @rikksullenber_twitter
    @int3ll3ct
    I'd like to try your new version
    int3ll3ct
    @int3ll3ct
    @rikksullenber_twitter I can transmit the installer to you using any reasonable method (Dropbox etc) let me know.
    int3ll3ct
    @int3ll3ct
    Decided to post the alpha installer on GitHub. Please go there to find it. I have tested 1.2.0a3 on my machines, but 1.2.0a4 remains untested right now (no code changes, only build script differences).
    Rikk Sullenberger
    @rikksullenber_twitter
    I'll grab it from there, thank you!
    int3ll3ct
    @int3ll3ct
    Just confirmed that 1.2.0a4 also runs fine on my clunker 2011-era Core i3 laptop running Windows 10 64-bit. Startup seemed a bit laborious, but once loaded it ran fine.
    tomacct4
    @tomacct4
    It also worked for me on a similarly aged Core i5, win10 64bit, 8MB. I've been running the 1.0.1 version for about a year. Response is good now, edit now usable with roaster connected. Thanks a lot!!!! Any chance of getting a 32bit windows build to test?
    int3ll3ct
    @int3ll3ct
    @tomacct4 , can I understand the motivation for a 32-bit build? I'm weighing this against working on the Mac build next, I couldn't easily find Win 10 64 vs 32 bit install base numbers to make a data-driven decision. Extending the build to support 32-bit Win 10 is possible, it'll likely take a few weeks however, at the expense of Mac support.
    tomacct4
    @tomacct4
    I use an old netbook with win10 32bit for roasting, but I have another option. I'm fine with waiting until after Mac builds are done.
    int3ll3ct
    @int3ll3ct
    Ok thanks for the context. It's on my list.
    int3ll3ct
    @int3ll3ct
    Openroast v1.2.0a7 for OS X installation package released. See https://github.com/Roastero/Openroast/releases.
    int3ll3ct
    @int3ll3ct
    @tomacct4 I've posted an untested alpha build, 1.2.0a9, for Win10 32-bit. Please test it and let me know if this works on your 32-bit machine.
    tomacct4
    @tomacct4
    I picked up the 32bit build and roasted one batch so far. It worked fine. Thanks a lot.
    int3ll3ct
    @int3ll3ct
    Good, thanks for trying it out.
    Mike
    @mikenolet
    Will give it a go. I was having issues with the old version where it would stop when it was moving on to the next step of a roast.
    @int3ll3ct can it run on a 64-bit OS version?
    int3ll3ct
    @int3ll3ct
    If you haven't tried it yet, build 1.2.0a4 is a 64-bit build. What version is "the old version" you're referring to?
    Mike
    @mikenolet
    @int3ll3ct I would have to check the build #. I am pretty sure it was the only Windows package available 3-4 months ago.
    int3ll3ct
    @int3ll3ct
    Oh ok, version 1.1 posted on the FB group I assume
    Mike
    @mikenolet
    @int3ll3ct ran 1.20a4 and it had no issues going from one step to another
    int3ll3ct
    @int3ll3ct
    Yes it took some fixing, that... All related to the freshroastsr700 package, which I rewrote to fix that problem, among other things. Glad it worked for you.
    Luca Pinello
    @lucapinello
    @int3ll3ct your software is super cool, I learned so much reading your code! I was wondering how you have optimized the settings for the PID
    which method did you use?
    Edward Lau
    @EdwardFLau_twitter
    Hello, it seems after updating to macOS big sur, openroast no longer detects the roaster. I've also checked with the usb driver maker, they said it should support big sur and above, so I'm thinking it might be openroast itself..
    big sur was the first to introduce support for both intel and arm platforms