Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Mar 24 18:06
    StevenLiekens commented #59
  • Mar 24 18:05
    StevenLiekens closed #59
  • Mar 24 18:05
    StevenLiekens commented #59
  • Mar 24 17:47
    StevenLiekens closed #58
  • Mar 24 17:47
    StevenLiekens commented #58
  • Mar 19 13:02
    Friesinator edited #59
  • Mar 19 13:01
    Friesinator opened #59
  • Mar 18 12:38
    StevenLiekens commented #58
  • Mar 15 15:19
    GHOSCHT commented #58
  • Mar 14 22:01
    Seeker1437 commented #58
  • Mar 14 20:08
    GHOSCHT commented #58
  • Mar 12 15:40
    StevenLiekens commented #58
  • Mar 10 15:46
    GHOSCHT opened #58
  • Apr 15 2018 16:43

    Ruhrpottpatriot on ServiceClient

    Remove superfluous compression … Add simple caching to Core proj… Move files into different folde… and 8 more (compare)

  • Apr 10 2018 21:09

    Ruhrpottpatriot on ServiceClient

    Add fluent api to create HttpRe… Fix Stylecop errors Remove dead code and 3 more (compare)

  • Mar 29 2018 13:11

    Ruhrpottpatriot on NetCore2.0

    Remove disabled and superseded … Delete unused leftover code fro… Move V1.Guild test to appropria… and 8 more (compare)

  • Mar 29 2018 12:17

    Ruhrpottpatriot on NetCore2.0

    Update .gitignore to exclude St… Add Api builder class (compare)

  • Feb 01 2018 09:33

    Ruhrpottpatriot on master

    Refactorize ServiceClient.GetHt… Merge pull request #57 from Kor… (compare)

  • Feb 01 2018 09:33
    Ruhrpottpatriot closed #57
  • Dec 27 2017 17:37
    Korjam opened #57
Steven Liekens
@StevenLiekens
yes
Robert Logiewa
@Ruhrpottpatriot
good
Steven Liekens
@StevenLiekens
now there is only netstandard1.0 to netstandard1.4 for compatibility with legacy crap
and netstandard1.5 for all current platforms
Robert Logiewa
@Ruhrpottpatriot
ok, if you could give me the explanation page, I'd be really grateful
I'm a bit confused right now
yeah me too
yaaay
empty
Steven Liekens
@StevenLiekens
haha
Robert Logiewa
@Ruhrpottpatriot
so basically, if i understood it correctly: We switch to the latest netstandard and go on from there?
Steven Liekens
@StevenLiekens
no, we switch to the lowest
for maximum compatibility
Robert Logiewa
@Ruhrpottpatriot
that'd be netcore?
Steven Liekens
@StevenLiekens
I think the lowest we can do is netstandard1.3
because HttpClient is 1.3
Robert Logiewa
@Ruhrpottpatriot
ah ok
ah
there's the explanation
Steven Liekens
@StevenLiekens
netstandard1.3.png
purple are the platforms we cannot support
Robert Logiewa
@Ruhrpottpatriot
ok
Steven Liekens
@StevenLiekens
I forgot to make Mono green
oh well
Robert Logiewa
@Ruhrpottpatriot
ok
seriously
native .NET compilation on almost every OS?
This message was deleted
AWESOME!
and it seems we can even compile it, so we don't need .NetCore installed
Steven Liekens
@StevenLiekens
yup
Steven Liekens
@StevenLiekens
@Ruhrpottpatriot you can get 6 months of pluralsight for free with microsoft dev essentials
Steven Liekens
@StevenLiekens
@Ruhrpottpatriot it's official, RC2 is released https://www.microsoft.com/net/download#core
uninstall all dnu/dnx/dnvm crap first
Robert Logiewa
@Ruhrpottpatriot
thanks for the heads up
Darnell Williams
@Seeker1437
Hey guys I just joined this chat after discovering the GW2NET library
I have been spending the last 6 months wrapping APIs in .NET and im like loving the structure and cleaness of this library :O
@Ruhrpottpatriot you rock. I wanted to see if there was any way I could help with this project.
XD
Steven Liekens
@StevenLiekens
yes you can
there are a bunch of unsolved issues
and there is a LOT that still needs to be implemented
and somehow make sure that the stuff we implement stays up to date
because the API is constantly changing
Darnell Williams
@Seeker1437
Oh I can definately look at those
Hey I was curious
Why not keep all the DataTypes together?