These are chat archives for SMERM/EMUForm

27th
May 2016
Giuseppe
@grammaton
May 27 2016 11:38
@nicb come da issue #65 si è rotto l’upload… sto provando a fixarlo
Nicola Bernardini
@nicb
May 27 2016 12:08
@grammaton come sarebbe si è rotto l'upload?
Io l'avevo provato prima di committare e funzionava benissimo
@grammaton cosa c'è che non va?
Ah poi ti volevo dire:
non va bene di innestare javascripts all'interno dei headers, footers e quant'altro
quel fix che hai fatto per sidecar
si ottiene la stessa cosa
invertendo l'ordine degli inserimenti dei javascripts
tipo::
 <!-- emufest style -->
  <%= javascript_include_tag 'application', 'data-turbolinks-track' => true %>
  <!-- GITTER SIDECAR  -->
  <%= javascript_include_tag 'https://sidecar.gitter.im/dist/sidecar.v1.js' %>
poiché quello script che dici tu
si trova in vendor/assets/javascript/gitter/sidecar.js
che viene per l'appunto incluso in app/assets/application.js
altrimenti in questo modo lo includi due volte
Nicola Bernardini
@nicb
May 27 2016 12:18
@grammaton a me l'upload funziona. Il problema è che quando si va a editare un lavoro non si vedono i file già uploadati...
Giuseppe
@grammaton
May 27 2016 12:22
@nicb ok per gitter…
per quanto riguarda l’upload… sul server da questo errore:
Asset was not declared to be precompiled in production.
Add Rails.application.config.assets.precompile += %w( file_upload.css ) to config/initializers/assets.rb and restart your server
mentre in locale la pagina carica ma senza bottone di scelta del file
Nicola Bernardini
@nicb
May 27 2016 12:24
non c'entra una mazza l'upload :-)
è che devi fare:
rake assets:precompile
Giuseppe
@grammaton
May 27 2016 12:24
no, infatti la issue era per l’errore che ho rilevato in locale
Nicola Bernardini
@nicb
May 27 2016 12:24
prima di far girare il server
in produzione gli assets vanno compilati
mentre in development te li serve al volo
perché così li puoi cambiare
ah sulla sparizione dei bottoni in upload non ti so aiutare :-(
io so solo che se tu premi quel coso nero funziona...
che cos'è la dropzone?
torno fra poco
Giuseppe
@grammaton
May 27 2016 12:42
@nicb ne su locale ne su server il coso nero funziona
la dropzone era insieme al bottone, se si trascinava il file sulla pagina veniva selezionato.
Nicola Bernardini
@nicb
May 27 2016 12:58
@grammaton a me funziona...
non ho provato a fare il drag and drop perché non lo so fare
ma il bottone a me funziona ho appena riprovato
mi dirai che è tutto nero per cui non si vede niente, ma a me funziona
Giuseppe
@grammaton
May 27 2016 13:09
anche andando sul server?
Nicola Bernardini
@nicb
May 27 2016 13:09
no in locale
non mi ricordo piu` come ci si va sul server
ma poi bisognerebbe avere un modo per monitorare il log
io su entrambi nella console non ho nessun errore
solo non succede nulla
provo con un altro browser
Nicola Bernardini
@nicb
May 27 2016 13:13
allora è un problema di javascript morto
io sto provando con google chrome
Giuseppe
@grammaton
May 27 2016 13:14
qui nemmeno chrome
Nicola Bernardini
@nicb
May 27 2016 13:14
sto provando con chrome
io ho provato e a me funziona
Nicola Bernardini
@nicb
May 27 2016 13:19
il secondo file l'ho uploadato proprio adesso
Giuseppe
@grammaton
May 27 2016 13:23
non posso vederlo, appartiene al tuo account
Nicola Bernardini
@nicb
May 27 2016 13:23
beh puoi vederlo sulla consolle
basta che fai:
rails server -e production
Giuseppe
@grammaton
May 27 2016 13:23
in ogni caso ho pullato i miei fixes sul server, ora ci sta girando gs-masterfixes
Nicola Bernardini
@nicb
May 27 2016 13:24
ma i tuoi fixes stanno sul master?
Giuseppe
@grammaton
May 27 2016 13:24
no
per provarli li ho messi su gs-masterfixes
Nicola Bernardini
@nicb
May 27 2016 13:24
e poi fai
w = Work.find(4)
w.submitted_files.count
ti dovrebbe dare 2
Giuseppe
@grammaton
May 27 2016 13:36
eh adesso c’è già il server che gira per la demo… cmq ho preso appunti
Nicola Bernardini
@nicb
May 27 2016 13:36
si si ma tu puoi far partire la consolle anche sul server che gira eh?
sono due processi separati
la puoi far girare live and technicolor proprio sullo stesso deployment
Nicola Bernardini
@nicb
May 27 2016 13:47
hai letto quello che ti ho scritto sul problema di gitter? ho riaperto la issue :-)
Giuseppe
@grammaton
May 27 2016 13:47
si ho corretto e richiuso
Nicola Bernardini
@nicb
May 27 2016 13:48
grazie
Giuseppe
@grammaton
May 27 2016 13:48
travis ha passato i miei fixes
Nicola Bernardini
@nicb
May 27 2016 13:48
è importante tenere sgombri i layout altrimenti fra pochissimo non ci si ricapisce più nulla
ok puoi mergiare su master?
Giuseppe
@grammaton
May 27 2016 13:49
ok lo fo
Giuseppe
@grammaton
May 27 2016 14:00
posso aggiungere la gem di passenger?
Nicola Bernardini
@nicb
May 27 2016 14:00
huh?
a che serve la gem di passenger?
ho fatto ripartire travis che era andato a sbattere per un problema di git
io ora devo andare, e sarò di ritorno solo stasera
provo a seguire gitter da mobile
ma non so quanto aiuto potrò dare
Giuseppe
@grammaton
May 27 2016 14:10
ok
Giuseppe
@grammaton
May 27 2016 14:37
@nicb non sono stato capace di settare appropriatamente passenger
Giuseppe
@grammaton
May 27 2016 14:43
emuformtest.giuseppesilvi.com
e dopo aver attivato passenger su dh mi è comparso questo:
Error loading RubyGems plugin "/home/emuform/.rvm/gems/ruby-2.3.0@global/gems/executable-hooks-1.3.2/lib/rubygems_plugin.rb": libssl.so.0.9.8: cannot open shared object file: No such file or directory - /home/emuform/.rvm/rubies/ruby-2.3.0/lib/ruby/2.3.0/x86_64-linux/openssl.so (LoadError)

Could not load OpenSSL.
You must recompile Ruby with OpenSSL support or change the sources in your Gemfile from 'https' to
'http'. Instructions for compiling with OpenSSL using RVM are available at
http://rvm.io/packages/openssl.
Nicola Bernardini
@nicb
May 27 2016 15:21
Scusa ma a cosa serve passenger?
Tu sai che c'è un one-click installare di passenger per rails su dh, vero?
Pensavo stessi usando quello
Giuseppe
@grammaton
May 27 2016 15:23
Si è quello
Solo che non va
Non ho aggiunto nulla.
Nicola Bernardini
@nicb
May 27 2016 15:58
Ma scusa com'era andato finora?
Giuseppe
@grammaton
May 27 2016 16:00
Nohup
Nicola Bernardini
@nicb
May 27 2016 16:11
Senti ma io ho un sito con passenger e Jekyll che funziona senza problemi...
nicb.github.io :-)
Ma stai cercando di usare https?
Comunque l'errore ti sta dicendo tutto di quello che devi fare
Devi installare una versione di ruby con SSL