Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Feb 05 20:04
    tablatronix edited #18
  • Feb 05 20:03
    tablatronix opened #18
  • Jan 11 12:25
    raydiy commented #14
  • Nov 03 2020 13:43
    jpmeijers commented #8
  • Oct 16 2020 18:35
    urs8000 commented #14
  • Aug 21 2020 16:59
    PDegenPortnoy commented #12
  • Jul 31 2020 07:32
    lozziboy opened #17
  • Jul 07 2020 12:58
    arkhipenko commented #8
  • Jun 18 2020 07:36
    zareiramin commented #14
  • May 18 2020 09:21
    SMasanneck opened #16
  • May 18 2020 09:18
    SMasanneck opened #15
  • Jan 29 2020 17:09
    polachz opened #14
  • Jan 17 2020 07:30
    mike2003 opened #13
  • Dec 31 2019 19:25
    afefer commented #8
  • Dec 31 2019 19:24
    afefer commented #8
  • Dec 31 2019 19:22
    afefer commented #8
  • Dec 31 2019 18:12
    jarickc opened #12
  • Dec 26 2019 16:44
    duccio opened #11
  • Jun 17 2019 09:45
    SokoFromNZ opened #10
  • May 30 2019 12:47
    JoaoLopesF commented #9
Joao Lopes
@JoaoLopesF
Welcome to gitter public room for SerialDebug Library
Please help me to bring a better debug for Arduino. Your feedback is very important
chinswain
@chinswain
Hi, I tried to run on an ESP32, I get the following error:
Arduino: 1.8.5 (Windows 10), Board: "ESP32 Dev Module, Default, QIO, 80MHz, 4MB (32Mb), 921600, None"
In file included from C:\Users\alanm\AppData\Local\Temp\arduino_modified_sketch_252239\SerialDebug_basic.ino:51:0:
C:\Users\alanm\AppData\Local\Temp\arduino_modified_sketch_252239\SerialDebug_basic.ino: In function 'void setup()':
C:\Users\alanm\AppData\Local\Arduino15\packages\esp32\hardware\esp32\1.0.0-rc2\cores\esp32/WString.h:38:95: error: expression cannot be used as a function
 #define F(string_literal) (reinterpret_cast<const __FlashStringHelper *>(PSTR(string_literal)))
D:\OneDrive\Arduino\libraries\SerialDebug\src/SerialDebug.h:432:44: note: in definition of macro '_debug'

      Serial.printf("(%c p:^%04lu %s C%d) " fmt "\r\n", \

C:\Users\alanm\AppData\Local\Temp\arduino_modified_sketch_252239\SerialDebug_basic.ino:92:5: note: in expansion of macro 'debugA'
debugA(F("**** Setup: initializing ..."));
Joao Lopes
@JoaoLopesF
Hi, I will see this bug in basic example. For while, please open the advanced/others. Thanks for your feedback.
Joao Lopes
@JoaoLopesF
Hi @chinswain , I just updated SerialDebug, is an issue in use debug* with Flash (F()). How your board is an Esp32, with a lot of memory, I suggest you use the advanced/others, due not need F() , it is for old Arduino with 2k of Ram. Thanks for your feedback