Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Tobias Witt
    @ohcibi
    today I upgraded macvim and all plugins and now some plugins aren't loaded properly anymore... are there some important changes recently?
    Tobias Witt
    @ohcibi
    it is not loading any plugins at all
    will dein.vim be more stable some day? Almost every update brings major problems and it totally blocks from work
    Shougo
    @Shougo
    I think dein.vim is stable.
    It works well.
    will dein.vim be more stable some day? Almost every update brings major problems and it totally blocks from work
    Why dein.vim is unstable?
    I think MacVim just broken. Because, when you have updated MacVim, your dein.vim is broken.
    afk
    @afk-mario
    Triying to lazy load emmet on html and jsx
                    \ 'on_ft': ['html', 'jsx', 'css', 'javascript', 'javascript.jsx']
    Is there something i'm missing?
    Tobias Witt
    @ohcibi
    @Shougo i'm buying that macvim sucks but dein.vim was the only plugin manager that broke on that update.. still using it, but just saying
    Shougo
    @Shougo
    @ohcibi You should build Vim from the source.
    I think MacVim is old.
    Current Vim update pace is very high.
    You should not use districuted Vim.
    @Shougo i'm buying that macvim sucks but dein.vim was the only plugin manager that broke on that update.. still using it, but just saying
    dein.vim uses newer feature in Vim.
    So if the feature is broken, dein.vim will be broken.
    ranranking
    @ranranking
    Hello, I am using the load_state and hook source feature. My question is that whether it is possible to cache the functions that are sourced by hook_source? I put my function inside the if dein#load_state() statement and it worked well at first. When I opened another file, it told me that the function is not found. I have to clear the state, and reload to make it work. If I put the function outside the if dein#load_state() statement, the error won't happen. Is this the only way to make it work?
    Shougo
    @Shougo
    @ranranking The function cannot be saved.
    I recommend for you to use string instead of function object.
    Hm
    You should know dein#load_state() behavior.
    If the cache is loaded correctly, the block is skipped.
    So, you must define the function before dein#load_state().
    Mike Hartington
    @mhartington
    Hmm, I'm getting this error when adding the vim-devicons plugin
    [dein] Vim(helptags):E670: Mix of help file encodings within a language: /Users/mhartington/.config/nvim/.dein/doc/webdevicons.txt
    but going through the plugins doc file, I'm not seeing what could be the issue
    ranranking
    @ranranking
    @Shougo Thank you very much, I got it!
    Khalid H. Ahmed
    @khalidchawtany
    @mhartington I have the same issue. After each update, I remove the file and regenerate the docs.
    Mike Hartington
    @mhartington
    Hmm, hadn't thought of that
    I submitted a PR to fix this on vim-devicons end, but I'm not sure why it's still happening
    Albert Kottke
    @arkottke
    What's the prefered approach to setting the runtimepath used a shared configuration across multiple computers with different paths?
    wention
    @wention
    Hi ! @all . Is there a nice way to config lazy load plugin.
    Shougo
    @Shougo
    Nice way?
    wention
    @wention
    @Shougo can i see your dein config?
    Here
    wention
    @wention
    Thanks very much
    Vyacheslav
    @alexeevit
    hi guys
    juegas
    @juegas
    sup
    Vyacheslav
    @alexeevit
    i just chose plug, sry ;3
    Keri Zane Volans
    @kerizane
    Is there any way to silence the "runtimepath has been updated" message?
    Shougo
    @Shougo
    No.
    It is the important message.
    Tobias Witt
    @ohcibi
    so I build vim from source instead using macvim and everything works nice except for systems clipboard... the build is with +clipboard as vim --version says but when I yank to the + register or try to paste from it, it does not work (i.e. the register or the clipboard is empty). does anyone know how to fix this?
    Shougo
    @Shougo
    This is dein.vim issue?
    You should ask it in other place.