Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Shougo
    @Shougo
    Please create new issue with minimal vimrc
    ggerico
    @ggerico
    ok
    ggerico
    @ggerico
    I found it out. There were some conflicts between dein and neoclide/coc.nvim. I removed coc.nvim and everything works well
    Shougo
    @Shougo
    Oh
    I don't know why
    coc is huge plugins, so it may be conflicted
    Shougo
    @Shougo
    I have improved dein installer.
    It is better performance than previous version
    Shougo
    @Shougo
    It improves dein#check_update().
    You can test it.
    John Meow
    @j0hnmeow
    For some reason I can't install dein-ui and some other plugins, call dein#install() reports all plugins being installed.
    Config
    Shougo
    @Shougo
    I don't support dein-ui plugin.
    Because I don't create the plugin.
    For some reason I can't install dein-ui and some other plugins,
    you need to reproduce the instruction.
    If not, I will ignore it.
    I have tested and it works.
    John Meow
    @j0hnmeow
    How do I uninstall unused plugins?
    Without manually deleting them
    Shougo
    @Shougo
    Q: How to remove the disabled plugins?
    
    A: You can remove them like below.
    Note: You must call |dein#recache_runtimepath()| after the remove.
    >
        call map(dein#check_clean(), "delete(v:val, 'rf')")
        call dein#recache_runtimepath()
    <
    John Meow
    @j0hnmeow
    Thanks
    Joxos
    @Joxos
    image.png
    I've got the warning when using Neovim and it really makes me confused.
    Is there anything wrong?
    Shougo
    @Shougo
    It seems SpaceVim problem.
    Please ask it in SpaceVim gitter instead
    Nureddin Bedewi
    @NurdinDev
    Screen Shot 2021-01-07 at 8.13.34 AM.png
    what does this mean?
    Screen Shot 2021-01-07 at 8.14.46 AM.png
    Shougo
    @Shougo
    None of the plugins are installed
    Hm. It seems your configuration error.
    But you have not upload the file
    We have not ESP
    SolarAquarion
    @SolarAquarion
    hi @Shougo how do i "lazy load on command" and what are the formats that the plugins can take, yaml, toml, and the original?
    Shougo
    @Shougo
    :help dein-options-on_cmd
    SolarAquarion
    @SolarAquarion
    gotcha
    SolarAquarion
    @SolarAquarion
    @Shougo is there a way to get a Plug styled Changelog of what was updated
    Shougo
    @Shougo
    echo dein#get_log()
    SolarAquarion
    @SolarAquarion
    @Shougo dein yaml isn't documented?
    i don't think the other grammar's one can is, is either
    Shougo
    @Shougo
    It is not yaml. It is toml
    Please read :help dein-toml.
    SolarAquarion
    @SolarAquarion
    using yaml2json , for the usage of yaml as the format of dein plugins
    SolarAquarion
    @SolarAquarion
    dein yaml is too complicated, moving my plugins to toml
    too complicated, lmao
    SolarAquarion
    @SolarAquarion
    @Shougo feature request: Yaml syntax for plugins. lmao
    Shougo
    @Shougo
    I don't add it.
    SolarAquarion
    @SolarAquarion
    fine. I guess i need to ping rafi to figure out what is going on in the dotfiles