These are chat archives for SirVer/ultisnips

30th
Oct 2015
Kareem Hepburn
@magicalbanana
Oct 30 2015 15:51
I keep getting a warning that this plugin requires python 2.7 or 3 but I am already using pyhton 2.7.3
Holger Rapp
@SirVer
Oct 30 2015 16:59
@magicalbanana That seems unlikely. Please verify inside vim: :py import sys; print(sys.version)
Holger Rapp
@SirVer
Oct 30 2015 17:12
@magicalbanana My theory is that your Vim is using some sort of system python, not the one you are using on your console.
Kareem Hepburn
@magicalbanana
Oct 30 2015 18:42
@SirVer It's telling me that command is not available in this version.
Holger Rapp
@SirVer
Oct 30 2015 23:12
@magicalbanana That explains that: You do not have a Python enabled Vim. UltiSnips cannot work there and that is why it is complaining. Which OS are you on? If on Linux, try installing something like vim-huge or vim-gnome to fix that.
Kareem Hepburn
@magicalbanana
Oct 30 2015 23:13
It's both on my OSX and Debian.
Holger Rapp
@SirVer
Oct 30 2015 23:13
on debian install vim-gnome to fix
on mac, use homebrew to build a python and a vim
something like
brew install python
brew install macvim