These are chat archives for SmingHub/Sming

16th
Jan 2016
zhivko
@zhivko
Jan 16 2016 00:08
@laurentppol : i had problems ;)
Great to hear you made readings
You use voltage divider?
What voltage range are you measuring?
riban-bw
@riban-bw
Jan 16 2016 11:10
I have added some documentation to http://sminghub.github.io. There is a (very) simple landing page with links to the github projects and links to API docs. Most versions of API docs only have a placeholder page. http://sminghub.github.io/sming-api-develop/index.html has the current version of the API for the Sming develop branch. This is incomplete but there is a fair amount of stuff there - I am working on adding more API documentation (just another 35 files to go!). I hope this helps developers to understand the framework and enable greater engagement.
laurentppol
@laurentppol
Jan 16 2016 12:12
@zhivko voltage is ~25mV on Pt1000, HX need to have this "floating" -> I used 100k from E+ to Pt1000, and 47k from Pt to E-, and now readings make sense. When I simply grounded A- readings were order of magnitude less than expected.
gain is set to 64

Hello , I'm having trouble trying to boot with rBoot.
My project without RBOOT_ENABLE is working fine. With RBOOT_ENABLE, the esp does not seem to boot.

I tried the basic_rboot example, I have the same problem.
BUT if in that example I disable SPIFFS with DISABLE_SPIFFS = 1 it works.
Am I missing something ?

hreintke
@hreintke
Jan 16 2016 19:32
@ram-one :
Could be an issue with SPI_SIZE. Did you set that correctly for your esp ?
I tried setting it to 1M, but still does not work.
My flash Id reports spi_flash_get_id() -> 1440E0, system_get_chip_id() -> 7bfbd
zhivko
@zhivko
Jan 16 2016 20:25
@laurentppol I dont get this - I have output for sharp distance sensor - I have voltage and gnd from sharp and I connected GND from sharp to A-, and then voltage divider to get 25mV to A+ - is that not OK? How should I connect it then?
laurentppol
@laurentppol
Jan 16 2016 20:48
@zhivko look at datasheet, BOTH inputs must be above GND: "AGND+1.2V -> AVDD-1.3V, table on page 3. You may try to put sensor's GND above ADC GND (2x Si diode?)
A+ and A-
now I get h79xxxx reading for ~25mV and gain 64
A- is at 1.1V... maybe not enough
fabiangl
@fabiangl
Jan 16 2016 20:59
@riban-bw very impressive in a short time. Congratulation!!!
@hreintke I tried all size 512K, 1M, 2M, 4M. But it does not work if SPIFFS is enabled with rBoot. If i'm right my flash should be 1M.
What's the flash offset for SPIFFS on 1M ?
zhivko
@zhivko
Jan 16 2016 23:27
@laurentppol can you draw schematics for me? With free hand and picture it with photo how should i wire this?
laurentppol
@laurentppol
Jan 16 2016 23:33
@zhivko 100k from module's E+ to Pt1000, 100k from other Pt side to E-, Pt1000 connected to A+ and A-
aaa, for You...
zhivko
@zhivko
Jan 16 2016 23:34
Yes :)
laurentppol
@laurentppol
Jan 16 2016 23:34
connect sharp's + to Vcc, sharp's GND to 2x Si diode, then to GND
voltage divider from sharp's output to sharp's GND
A+ to sharp's output, A- to sharp's GND
is that clear?
zhivko
@zhivko
Jan 16 2016 23:36
Aaaaaa not really. Pic please.
laurentppol
@laurentppol
Jan 16 2016 23:36
not now, sorry
zhivko
@zhivko
Jan 16 2016 23:36
You can draw on piece of paper and take photo... It does not to be fancy...
laurentppol
@laurentppol
Jan 16 2016 23:37
please remember me tomorrow
zhivko
@zhivko
Jan 16 2016 23:38
Ok