These are chat archives for SmingHub/Sming

26th
Jan 2016
slaff
@slaff
Jan 26 2016 10:18
@hreintke There is a new PR (SmingHub/Sming#565) with MQTT improvements that I've tested on my ESP8266 device. It would be great if they are merged into the develop branch.
riban-bw
@riban-bw
Jan 26 2016 12:53
@kireevco Should we (you) remove AppVeyor checks from Sming develop branch and add it to a PR or other branch? Currently all PRs are failing and showing up as failed in the list which may influence how quickly PRs get applied, e.g. an admin looking at a failed PR may ignore it, expecting the submitter to fix the problem. These are all failing becuase AppVeyor is not yet configured correctly.
hreintke
@hreintke
Jan 26 2016 14:32
@riban-bw
I have asked @kireevco the same several times but he only pointed to the issue but did not solve.
Just merged a PR from me that removes an appveyor.yml file from the repo.
Probably this will solve, if not we have to search further.
@sfam : Your question is ambiguous.
You want to enable OTA and only one Rom ? That combination is not possible
sfam
@sfam
Jan 26 2016 14:43
@hreintke I mean like the way it was before rboot... back then, OTA was simple: specify links for new firmware and update... the end user didn't have to worry about two roms, big roms, memory offsets, ram length... how can I use rboot the same way?
robotiko
@robotiko
Jan 26 2016 14:44
@sfam the problem with that approach is that it was not fault tolerant
if it fails.. you need ot manually handle it .. on physically
I fi recall it correctly .. it can also be used similar way
sfam
@sfam
Jan 26 2016 14:45
I see... I could live with that...
unless it fails all the time :)
robotiko
@robotiko
Jan 26 2016 14:49
@sfam have look at rBootHttpUpdate
in the basic_rboot example you can see how to use it
If I'm not mistaken
you can do almost teh same as before
void addItem(int offset, String firmwareFileUrl);
and void applyUpdate();
you will only add 1 url
and the offset will be fixed
sfam
@sfam
Jan 26 2016 14:55
awesome... will try that tonigth. thanks!
what are the possible causes for this method to fail and cant recover? besides power failure...
robotiko
@robotiko
Jan 26 2016 14:56
corrupted file reception..
there is no file signature
wrong file format
etc
sfam
@sfam
Jan 26 2016 15:02
ok, thanks alot... I've been trying for a few days the two roms method and I think a regular 512k esp01 does not have enough space for two Sming roms... I always got invalid rom nr1 or device self reseting...
I will wait for my esp12 with 4M and try again...
robotiko
@robotiko
Jan 26 2016 16:48
@sfam simple sming with no spiff is almost half space of esp1 so two roms will be veery limited
if possible
Georgi Dobrishinov
@dobrishinov
Jan 26 2016 18:10
Hey, i have problem with HttpServer_ConfigNetwork example. After upload, i cant connect stable from Android smartphone to AP. Network is disappear for second and then phone connected for some seconds. From PC i dont have problem. I try with 2 phones (android 2.3 and android 5.0.1). I try other example, dont have any problem.
Georgi Dobrishinov
@dobrishinov
Jan 26 2016 18:28
after disconnect in debug console say : chg_A3:-180 chg_A3:0 chg_A3:-180 chg_A3:0 , then phone connected again for second ( try to load page, loaded correctly, and then disconected)
alonewolfx2
@alonewolfx2
Jan 26 2016 18:55
@dobrishinov can you try flashinit target?
make flashinit
For cleaning wifi settings?
Georgi Dobrishinov
@dobrishinov
Jan 26 2016 19:03
Yes i try ,but random disconnects from phone stills.
Dmitry Kireev
@kireevco
Jan 26 2016 19:31
Sorry guys, I've changed my day job.,I will be around but minimally. I'll be back completely in a week or two.
by the way
check out platform io
sle118
@sle118
Jan 26 2016 21:03
atom processor?
alonewolfx2
@alonewolfx2
Jan 26 2016 21:04
@sle118 yes but it didnt work for me
sle118
@sle118
Jan 26 2016 21:05
I'm still excited by the ESP8266....
Georgi Dobrishinov
@dobrishinov
Jan 26 2016 23:00
I found the problem... On my galaxy s 3 mini with cyanogenmod 12.1 (android 5.1.1) wi fi is very unstable. I try with Android 2.3 too. But with other phones and computers is ok... strange. Maybe bad port with wi fi drivers or something