These are chat archives for SmingHub/Sming

30th
Jan 2016
Jakub Sobieraj
@sobiso
Jan 30 2016 12:39
hi all
i have problem with soft-AP mode
I disable STA, run only AP with auth_open, when i connect to esp form phone and don't use it i see on console that phone was leave
station: 8c:3a:e3:39:0c:2e leave, AID = 1
anyone have similar situation ?
alonewolfx2
@alonewolfx2
Jan 30 2016 13:43
there isnt a problem
its dhcp leease log
this log says someone leaved ap network
Jakub Sobieraj
@sobiso
Jan 30 2016 13:49
but why ?
so phone leaved ap network ?
alon24
@alon24
Jan 30 2016 14:03
@matsstaff I am interested too
alonewolfx2
@alonewolfx2
Jan 30 2016 18:56
@sobiso due to dhcp leease time. you can change it as i know
i will look function
Jakub Sobieraj
@sobiso
Jan 30 2016 19:00
default is 120 mins but phone and laptop leave after few mins
alonewolfx2
@alonewolfx2
Jan 30 2016 19:03
what is your sdk?
Jakub Sobieraj
@sobiso
Jan 30 2016 19:04
1.5
and sming 2.1
alonewolfx2
@alonewolfx2
Jan 30 2016 19:13
ok let me look
Jakub Sobieraj
@sobiso
Jan 30 2016 19:15
``` spiffs_mount(); // Mount file system, in order to work with files
Serial.begin(SERIAL_BAUD_RATE); // 115200 by default
Serial.systemDebugOutput(true); // Enable debug output to serial
AppSettings.load();

WifiStation.enable(false);

// Start AP for configuration
WifiAccessPoint.enable(true);
WifiAccessPoint.config("Sming Configuration", "", AUTH_OPEN, false, 1, 1000);

// Run WEB server on system ready
System.onReady(startServers); ```
i change example HttpServer_ConfigNetwork
i try change beaconInterval but this nothing change
Georgi Dobrishinov
@dobrishinov
Jan 30 2016 19:27
@sobiso WifiAccessPoint.config("Sming Configuration", "", AUTH_OPEN) - only : ? did work. I have similar problem with this example soon. But my laptop connect without problem. Before I use 1.4 version on SDK, but after update latest SDK 1.5.1 problems is solved : ) try with 1.5.1
Jakub Sobieraj
@sobiso
Jan 30 2016 19:28
i use linux is there precompiled version ?
Georgi Dobrishinov
@dobrishinov
Jan 30 2016 19:43
Yes but i think is old, i dont know. I use this way
  1. ~git clone https://github.com/pfalcon/esp-open-sdk.git
  2. ~cd esp-open-sdk
  3. open Makefile, on line 13 VENDOR_SDK = 1.4.0 change to 1.5.1 (i dont view first time and i have issues whit AP and 1.4.0)
  4. Save Makefile change
  5. ~make STANDALONE=y
  6. I wait 20, 30 min. Drink some beers ;p
Jakub Sobieraj
@sobiso
Jan 30 2016 19:44
thx i try this
beers or whisky :D
Georgi Dobrishinov
@dobrishinov
Jan 30 2016 19:47
Cheers :D
Jakub Sobieraj
@sobiso
Jan 30 2016 19:48
thx :D and i will search how to cut 3d models because i have problem with this too :D
I like the esp8266, but this looks promising if sdk is available... 448k of RAM? Check! 160 MHz ARM Cortex-M3 ? Check!
I've seen Linux running on less valuable hardware 😉