These are chat archives for SmingHub/Sming

7th
Apr 2016
Murli Shenoy
@hmms
Apr 07 2016 06:59
I recently got a new laptop and moved sming to it, i updated sming framework using chocolatey and some stuff broke. I managed to fix some stuff related to the makefile. now I'm having issues flashing to the ESP module. esptool2 seems to be complaining, any pointers on how what changes need to be made to fix this? or any pointers to esptool2 documentation?
here's a screenshot http://imgur.com/LaZRet2
Patrick Jahns
@patrickjahns
Apr 07 2016 07:36
remake esptool and use the one from rburton directly
(linked from sming repo)
Murli Shenoy
@hmms
Apr 07 2016 07:45
i remade esptool from https://github.com/raburton/esptool2
still same issue, any changes needed in makefile?
Patrick Jahns
@patrickjahns
Apr 07 2016 07:50
are you sure it is the correct esptool in the path?
You can specifiy it manually by either setting ESPTOOL2 in your environment variables or in the Makefile
Murli Shenoy
@hmms
Apr 07 2016 07:51
i have it in my environment variables
i did not change the makefile, my question is about the flashing
esptool2.exe -p COM7 -b 115200 write_flash -ff 40m -fm qio -fs 4m 0x00000 out/firmware/0x00000.bin 0x09000 out/firmware/0x09000.bin 0x44000 out/firmware/spiff_rom.bin
this is what gets executed by the default makefile
and it gives the following error
Error: Unrecognised option '-p'.
/c/Espressif/utils/Terminal.exe COM7 115200
and then executes the terminal
@raburton any pointers as to why this could be happening?
have i misconfigured something maybe?
Patrick Jahns
@patrickjahns
Apr 07 2016 07:57
is COM7 the correct comport?
Murli Shenoy
@hmms
Apr 07 2016 07:57
yes
i have verified that its the correct com port
Patrick Jahns
@patrickjahns
Apr 07 2016 07:58
what about manually executing esptool2.exe and see if it is actually the correct esptool
this happened to me before, when it was pointed to the one distributed with the espsdk
Ah sorry - it was the other way around - esptool vs esptool2. esptool is supplied via SDK
Murli Shenoy
@hmms
Apr 07 2016 08:03
ok
is this correct way to invoke esptool2?
esptool2.exe -p COM7 -b 115200 write_flash -ff 40m -fm qio -fs 4m 0x00000 out/firmware/0x00000.bin 0x09000 out/firmware/0x09000.bin 0x44000 out/firmware/spiff_rom.bin
Patrick Jahns
@patrickjahns
Apr 07 2016 08:03
try using esptool instead
Murli Shenoy
@hmms
Apr 07 2016 08:03
or is it? esptool.py -p COM7 -b 115200 write_flash -ff 40m -fm qio -fs 4m 0x00000 out/firmware/0x00000.bin 0x09000 out/firmware/0x09000.bin 0x44000 out/firmware/spiff_rom.bin
Patrick Jahns
@patrickjahns
Apr 07 2016 08:04
/C/Espressif/utils/esptool.exe -p COM3 -b 115200 write_flash -ff 40m -fm qio -fs 32m 0x00000 out/firmware/0x00000.bin 0x09000 out/firmware/0x09000.bin 0x4C000 out/firmware/spiff_rom.bin
that`s what happens when I try to flash via makefile
Patrick Jahns
@patrickjahns
Apr 07 2016 08:10
@hmms
success?
i'll try again
Patrick Jahns
@patrickjahns
Apr 07 2016 08:15
now it`s the correct exe - you just need to point your environment vars to the correct directories
Murli Shenoy
@hmms
Apr 07 2016 08:17
this is what the result of my make looks like
Patrick Jahns
@patrickjahns
Apr 07 2016 08:18
try make flash to flash
Murli Shenoy
@hmms
Apr 07 2016 08:21
it again gives me the Error: Unrecognised option '-p'.
is this the command the make file should be executing?
esptool2.exe -p COM3 -b 115200 write_flash -ff 40m -fm qio -fs 4m 0x00000 out/firmware/0x00000.bin 0x09000 out/firmware/0x09000.bin
is the esptool2.exe a direct replacement for esptool.exe?
Patrick Jahns
@patrickjahns
Apr 07 2016 08:26
no
Patrick Jahns
@patrickjahns
Apr 07 2016 10:32

An initially code for multipart_uploads is here: https://github.com/patrickjahns/Sming/tree/feature/http-multipart-post

added a default writing to file part - feel free to test it and report back any issues. currently works on any path - just need to be a http-multipart request. Note: later this will need to be enabled per route

@avr39-ripe @alonewolfx2 @robotiko
feel free to also give some remarks/comments
alonewolfx2
@alonewolfx2
Apr 07 2016 20:25
@patrickjahns i flashed http basic auth example but it seems its resetting always
'/user_pass' registered
'/custom' registered
AP configuration was updated on system ready event
Fatal exception 9(LoadStoreAlignmentCause):
epc1=0x4020935f, epc2=0x00000000, epc3=0x00000000, excvaddr=0x4010041b, depc=0x00000000

 ets Jan  8 2013,rst cause:4, boot mode:(3,7)

wdt reset
l
Riley
@ril3y
Apr 07 2016 21:06
hey guys has anyone actually got the DHT22 humidity sample working with sming?
I found a glaring bug and fixed it but it still does not work for me. Just curious if I need to jump into the lib code or I am doing something dumb.
Riley
@ril3y
Apr 07 2016 21:13

Also not sure i understand this:
https://github.com/SmingHub/Sming/blob/develop/samples/Humidity_DHT22/app/application.cpp#L20

If you disable the wdt wont the board just reset?

That is if I have wifi going too
Patrick Jahns
@patrickjahns
Apr 07 2016 22:17
@alonewolfx2
that is odd - did you try reflashing? - will try again tomorrow and report back