Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Apr 15 23:00
    nektryn closed #913
  • Apr 15 22:57
    nektryn commented #913
  • Apr 15 22:34
    nektryn commented #913
  • Apr 15 22:33
    nektryn commented #913
  • Apr 15 22:33
    nektryn commented #913
  • Apr 15 22:32
    nektryn commented #913
  • Apr 15 22:27
    nektryn commented #913
  • Apr 15 22:24
    Flakebi labeled #913
  • Apr 15 22:23
    Flakebi commented #913
  • Apr 15 22:21
    nektryn commented #913
  • Apr 15 22:11
    Flakebi commented #913
  • Apr 15 22:05
    nektryn commented #913
  • Apr 15 17:46
    Flakebi commented #913
  • Apr 15 08:17
    nektryn opened #913
  • Apr 13 01:41

    Splamy on develop

    Improved some book chaching (compare)

  • Apr 12 20:53

    Flakebi on develop

    Encrypt audio packets by default (compare)

  • Apr 11 12:29
    SR-Lut3t1um closed #911
  • Apr 10 20:50
    meikmenzel commented #911
  • Apr 10 00:12

    Splamy on master

    Added the possibility to subscr… Merge pull request #912 from ya… Fixed missing type func convers… (compare)

  • Apr 10 00:11

    Splamy on 0.12.2

    (compare)

xd vape
@xd-vape
Can someone help me ?
Error: Could not load. (youtube: youtube-dl failed to load the resource.)
DerEineGamer
@DerEineGamer
sudo apt install youtube-dl
and go to https://yt-dl.org/ and download the newest version of youtube-dl place this in the ts3audiobot folder
JoDaS_04
@JoDaS_04_twitter
Hey, how do i login in the panel?
1 reply
So witch ! command?
To get a Auth Key
token*
Pls help me :(
notrengele
@notrengele
yo guys, how to connect points to another ts3 server and make a folder for it without entering the vps, what is the command?
1 reply
Mikkel
@MikkelDK
yo. is it no longer possible to use: "!bot token api" ? :eyes:
1 reply
liveuser1
@liveuser1
Hi all! I changed bot.connect.address in bot.toml, how do I force ts3audiobot to reread this config file and connect to a new address without restarting?
1 reply
Mikkel
@MikkelDK
Yo! - is it possible to make a "global template" so I don't need to change "rights.toml" every time...because no server/clients has access to "cmd.play" ??
3 replies
Ghost
@ghost~5fa878d9d73408ce4ff3943d
How to fix this? [ Error: Could not load. (youtube: youtube-dl failed to load the resource.) ] this comes out when I want to play music, youtube-dl is nicely tuned you don't have to write to me I know it's not up to it, everything worked normally and suddenly it stopped and kept coming out this
golubovic
@notgolubovic
How to fix this? Error: Could not load. (youtube: youtube-dl failed to load the resource.)
DerEineGamer
@DerEineGamer
update your ytdl
golubovic
@notgolubovic

@DerEineGamer

update your ytdl

I did update yt-dl and again the same thing, and it worked before and I don't know what it could be

DerEineGamer
@DerEineGamer
have you placed a youtube-dl and youtube-dl.exe file in your ts3ab folder
golubovic
@notgolubovic

have you placed a youtube-dl and youtube-dl.exe file in your ts3ab folder

https://prnt.sc/zi1jyk

I have yt-dl in the ts3audiobot.toml file, and yt-dl is in / usr / local / bin / youtube-dl

1 reply
ntmrc
@ntmrc
Hey, how can I add an local playlist?
1 reply
Ahmed Ćosović
@kodro2734_twitter
How do I confirm a playlist deletion, bot says "Do you really want to delete the playlist "1""?
Solved, it's !yes
MarvinTV Network
@MarvinTVNet_twitter
.
Baaasty
@Baaasty
Hey
DerEineGamer
@DerEineGamer
hey
n3kso134
@n3kso134
Yo someone can help :D
Why my bot connect to ts3 and got Connection lost after 5 min ? ;c
and i can't run more than 2 bots
5 replies
mrocznyzozo
@mrocznyzozo
how to login to webinterface ?
2 replies
PriinxYT
@PriinxYT
How do I activate auto-repeat?
1 reply
Mikkel
@MikkelDK
Hiyo. Is there someway to fix/prevent musicbot for disconnect/crash, so it can do unlimited reconnect? - Eg with error like: "Could not connect: parameter_invalid: the command failed to execute: invalid parameter" - since it can't reconnect again
Mateusz Dudziak
@MateuszDudziak1
Stable version run only on dotnet 2.2 or thats the minimal required version?
2 replies
Robin Wolff
@RobinDev03

Hey,

I#ve the problem, that my crashes instantly after starting :/
This is all, I get as output:
18:15:03.3033| INFO|Core| [============ TS3AudioBot started =============]
18:15:03.3693| INFO|Core| [ Date: Friday, 19 March 2021 18:15:03
18:15:03.4174| INFO|Core| [ Version: 0.12.0-alpha.52/develop/6fce0d95
18:15:03.4174| INFO|Core| [ Build: Release
18:15:03.4174| INFO|Core| [ Platform: Debian GNU/Linux 10 (buster) (64bit)
18:15:03.4174| INFO|Core| [ Runtime: .NET Core (3.1.12) ServerGC:True GC:SustainedLowLatency
18:15:03.4174| INFO|Core| [ Opus: libopus 1.3 (x64)
18:15:03.4174| INFO|Core| [==============================================]
18:15:04.0058| INFO|Core| Starting Webserver on port 58913
18:15:04.3044| INFO|Core| Bot "default" connecting to "ragebots.eu"
18:15:04.3893|FATAL|0| Critical program failure!
18:15:04.4225| INFO|0| TS3AudioBot shutting down.
Unhandled exception. System.Collections.Generic.KeyNotFoundException: The given key '123' was not present in the dictionary.
at System.Collections.Generic.Dictionary2.get_Item(TKey key) at LiteDB.IndexService.GetNodeList(IndexNode node, Boolean includeInitial)+MoveNext() at System.Collections.Generic.LargeArrayBuilder1.AddRange(IEnumerable1 items) at System.Collections.Generic.EnumerableHelpers.ToArray[T](IEnumerable1 source)
at System.Linq.Enumerable.ToArrayTSource
at LiteDB.LiteEngine.UpdateDocument(CollectionPage col, BsonDocument doc)
at LiteDB.LiteEngine.<>cDisplayClass33_0.<Upsert>b0(CollectionPage col)
at LiteDB.LiteEngine.TransactionT
at LiteDB.LiteEngine.Upsert(String collection, IEnumerable1 docs, BsonType autoId) at LiteDB.LiteCollection1.Upsert(IEnumerable1 documents) at LiteDB.LiteCollection1.Upsert(T document)
at TS3AudioBot.Environment.Stats.TrackPoint() in C:\projects\ts3audiobot\TS3AudioBot\Environment\Stats.cs:line 160
at System.Threading.Tasks.Task.<>c.<ThrowAsync>b139_1(Object state)
at System.Threading.QueueUserWorkItemCallback.<>c.<.cctor>b
6_0(QueueUserWorkItemCallback quwi)
at System.Threading.ExecutionContext.RunForThreadPoolUnsafeTState
at System.Threading.QueueUserWorkItemCallback.Execute()
at System.Threading.ThreadPoolWorkQueue.Dispatch()
at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()
Aborted

Ondřej Niesner
@Ondra3211
It is possible to send messages to the bot only if you are in the same channel as the bot? I tried to play with rigths.toml but i didnt get it.
2 replies
Kron Ja
@kronja_gitlab

Hi,

i have the following error:

2021-03-20 15:15:20.4452|FATAL||Core.UnobservedTaskExceptionHandler Critical program error!System.Threading.Tasks.UnobservedTaskExceptionEventArgs
System.ObjectDisposedException: Cannot access a disposed object.
Object name: 'System.Net.Sockets.Socket'.
   at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
   at System.Net.Sockets.TcpClient.EndConnect(IAsyncResult asyncResult)
   at System.Threading.Tasks.TaskFactory`1.FromAsyncCoreLogic(IAsyncResult iar, Func`2 endFunction, Action`1 endAction, Task`1 promise, Boolean requiresSynchronization)
2021-03-20 15:15:20.4452|FATAL||Core.UnobservedTaskExceptionHandler Critical program error!System.Threading.Tasks.UnobservedTaskExceptionEventArgs
System.ObjectDisposedException: Cannot access a disposed object.
Object name: 'System.Net.Sockets.Socket'.
   at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
   at System.Net.Sockets.TcpClient.EndConnect(IAsyncResult asyncResult)
   at System.Threading.Tasks.TaskFactory`1.FromAsyncCoreLogic(IAsyncResult iar, Func`2 endFunction, Action`1 endAction, Task`1 promise, Boolean requiresSynchronization)

@Splamy if u fix my bugs i will donate money for you

mrocznyzozo
@mrocznyzozo
how to fix ? : The connection could not be established.
Kron Ja
@kronja_gitlab
Cannot access a disposed object.
Martin
@mar8tin__twitter
hello
can someone help me pls
Martin
@mar8tin__twitter
my bot no working
PriinxYT
@PriinxYT
Can you somehow activate a bass mode?
MeMaTi
@M3M4Ti
Do you have an enable-ducking style plugin?
WeiHhh1
@WeiHhh1
How to set rights
WeiHhh1
@WeiHhh1
You cannot execute 'play'. You are missing the 'cmd.play' right!
Tuktron
@Tuktron
How do i bypass "HTTP Error 429: Too Many Requests" ?
I used to get it with "--cookies *link to my cookies.txt" in youtube-dl.conf but since the last update a few days ago for youtube-dl, that command doesnt work anymore? Any help?
WeiHhh1
@WeiHhh1

"WeiHhh": !api token

<17:54:41> "TS3AudioBot": Error: You cannot execute 'api token'. You are missing the 'cmd.api.token' right!

PriinxYT
@PriinxYT
You don't have Permissions to execute the command
WeiHhh1
@WeiHhh1
I've finished it now, but I'm the only one with permission to use the robot, and others don't have permission to use it. How can I solve this problem?
Maurice #TS5Nutzer ⛄
@OffizialMaurice_twitter
Good evening, I just wanted to ask if any of you might know whether I can somehow display it on a website like the current users who are in a channel with the bot?
BeastCore
@BeastCore
Hello, after updating bot to the 0.12.0 and youtube-dl to the newest version I'm facing issue with youtube, everytime I'm getting
"09:12:59.4297| WARN|0| Request timed out" in bot console and there is no music playing. Any idea how can I fix it?
Asasinek
@Asasinek
hi i have problem with voxility teamspeak i cant connect bots.