Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jun 23 21:49
    TheGoddessInari closed #249
  • Jun 23 21:49
    TheGoddessInari closed #264
  • Jun 23 21:49

    TheGoddessInari on master

    Update electron to 19.0.6 and e… Change URL for Facebook Message… (compare)

  • Jun 16 08:32
    akougblenou commented #334
  • Jun 15 07:37
    utamadonny commented #330
  • Jun 07 23:07
    brinesharks commented #334
  • Jun 07 23:03
    brinesharks opened #334
  • Jun 06 19:55
    BenHerbst opened #333
  • Jun 03 11:13
    solf opened #332
  • May 31 09:28
    gbarranco opened #331
  • May 30 15:30
    k0d3r1s commented #318
  • May 25 11:34
    paulclaude opened #330
  • May 23 17:14
    YoannPa opened #329
  • May 23 17:09
    YoannPa opened #328
  • May 08 16:03
    LiBOSS-CZ commented #321
  • May 07 04:35
    wefalltomorrow commented #184
  • May 06 10:52
    vukski edited #325
  • May 06 09:55
    vukski opened #325
  • May 05 17:55
    JackGraymer commented #289
  • May 05 15:39
    ManagedCloud-Hosting commented #321
Ray Vermey
@RayVermey_twitter
In the AUR it says 0.6.0.11
TheGoddessInari
@TheGoddessInari
Bleh. I know I need to make regular releases again, Electron (and Google with those changes) have been making it nigh impossible to actually "stabilize".
Ray Vermey
@RayVermey_twitter
things develop and change at the speed of light
so how can i install your latest version? Git clone and makepkg -i ??
TheGoddessInari
@TheGoddessInari
https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=hamsket-nightly-bin
That suggests you should just be able to reinstall and it'll pick up the latest.
Ray Vermey
@RayVermey_twitter
Then I have 0.6.0.11 already
or is yours newer ?
TheGoddessInari
@TheGoddessInari
I just released a new version. Like I keep saying, I can't control what third parties do.
Ray Vermey
@RayVermey_twitter
ok check
TheGoddessInari
@TheGoddessInari
Based on my reading of that, it should grab whatever the latest is when it's installed, the package version is theirs, not mine.
Ray Vermey
@RayVermey_twitter
ahhhh ok i thought you (devs) put the new version online to the AUR
TheGoddessInari
@TheGoddessInari
No. I'm the one doing the source code and use automation to produce the binaries and upload them to github. Very few people have made pull requests over the last two years. Anything not on the official github or azure devops is someone else doing something.
Ray Vermey
@RayVermey_twitter
ah ok, didnt know that
i will pull your git version then and build by hand ok?
TheGoddessInari
@TheGoddessInari
You don't have to. Sorry, I don't have reliable internet. :P
Ray Vermey
@RayVermey_twitter
ok, fine cause build failed :)
For AUR you need a maintainer
I flagged the lates Nightly out of date so the maintainer will get a message and will (hopefully) update the package so my yay will notice the new version :-)
LiBOSS-CZ
@LiBOSS-CZ
Hello, last build 29c2517 failed during windows artifact building. Could you trigger build again.
LiBOSS-CZ
@LiBOSS-CZ
Hello, is it just me or now is impossible to go through individual builds. Everytime I click on builds link ( https://dev.azure.com/TheGoddessInari/hamsket/_build?definitionId=2 ), browser goes to the page and wants me to login with MS account.
TheGoddessInari
@TheGoddessInari
Sorry for delay. Looks like you, I can't quite click on the artifacts using Edge, but it doesn't ask for login in anonymous browser window.
Clicking should work to download, but I'm not in control of that. That's a bug on their end, looks like.
TheGoddessInari
@TheGoddessInari
I've reported it to Microsoft.
Johannes Rövenstrunck
@rovenstrunck_twitter
Hallo, I have a peculiar problem with Hamsket 6.0.2. The Zoon in-function only seems to work in one tab. In other tabs there is no result. When I zoom in in other tha the functionig tab, the functionig tab is zoomed anyway.
sorry for the typos, its middle of the night :-)
TheGoddessInari
@TheGoddessInari
No worries. If it makes you feel any better, I haven't been able to sleep in a few days. :)
Johannes Rövenstrunck
@rovenstrunck_twitter
That makes me feel better :-)
Johannes Rövenstrunck
@rovenstrunck_twitter
TheGodessInari can you confirm the bug?
TheGoddessInari
@TheGoddessInari
@rovenstrunck_twitter Okay, could you rephrase it a little more clearly? Zoom-in is per-tab.
Johannes Rövenstrunck
@rovenstrunck_twitter
okay: under View there is the Zoom-in function. When I click on it, the zoom works in the first of 4 tabs. In the other three tabs its not working. When I click Zoom-in in the 2nd, 3rd or 4th tab, the first tab is zoomed, which is not wanted. Clearer @TheGodessInari ?
I have bad sight and need to zomm-in all tabs.
TheGoddessInari
@TheGoddessInari
So, if you have 4 tabs, you zoom in on tab 1, switch to tab 2, and zoom in. No zoom in happens on tab 2, and the zoom is increased on tab 1?
Johannes Rövenstrunck
@rovenstrunck_twitter
Exactly
TheGoddessInari
@TheGoddessInari
That's quite strange. I
I can't seem to get it to do that. What version / is / etc? Mmm
Johannes Rövenstrunck
@rovenstrunck_twitter
Hamsket 6.0.2
sorry, 0.6.2
Version: 0.6.2
Platform: linux (x64)
Electron: 10.1.7
Chromium: 85.0.4183.121
Node: 12.16.3
BuildVersion: fd10375 (grafted, HEAD, tag: 0.6.2, origin/fd1037521df6214a1b6b3751242cfa409c4ac236) Thu, 10 Dec 2020 17:32:22 -0800
TheGoddessInari
@TheGoddessInari
I'll have to try it on Linux. It's weird that I'm not seeing it.
Johannes Rövenstrunck
@rovenstrunck_twitter
Thank you. I would be grateful, if you look into it on Linux. It might be a Linux-problem.
vraravam
@vraravam:matrix.org
[m]
hi all - is this the room where we can discuss local devbox setup ? I am looking to contribute to hamsket development, and am in the process of setting up my local machine (macos) for development. Wanted to find the room where such help can be asked
vraravam
@vraravam:matrix.org
[m]
Question for @TheGoddessInari : Do you prefer to keep the system pre-requisites to the lowest versions or the latest versions? For eg, the Java version specified is 8.0, but, do you mind if we move to the latest version which works? That will ensure that new contributors with newer machines/OSes do not need to face issues related to installing specific old versions of such pre-requisites
1 reply
vraravam
@vraravam:matrix.org
[m]
I see a lot of the code is written in commonJS module format. Is it better to convert ot ESM module format (ie with imports)?
@TheGoddessInari: - I have raised a couple of PRs, please review and approve if they are ok. They are quite small/trivial - just getting my hands wet with the codebase
vraravam
@vraravam:matrix.org
[m]
Also - there are a bunch of lines in the README.md (lines 19 - 27) which don't show up in the html generated from the markdown, and I couldn't understand their purpose. Are these lines kept for some specific reason?
vraravam
@vraravam:matrix.org
[m]

:point_up: Edit: > I see a lot of the code is written in commonJS module format. Is it better to convert ot ESM module format (ie with imports)?

I see a lot of the code is written in commonJS module format. Is it better to convert ot ES module format (ie with imports)? Based on some reading, this is supposed to be the new standard and faster at runtime?

Josef Schlehofer
@BKPepe
@vraravam:matrix.org You should move rather to Ferdi. I stopped using Hamsket a few months ago.
vraravam
@vraravam:matrix.org
[m]
@BKPepe - I was one of 2 active owners/contributors of Ferdi for the past 8+ months. The original owner who was absent all these months, came back suddenly and started abusing (with lots of expletives) and then (without citing any reasons) downgraded me to a Member role. With such autocratic behavior and the use of derogatory words (I have a screenshot captured in case I need to refute it in future), I and my co-contributor (the other active person for the past few monhts) have both abandoned Ferdi
I was instrumental in almost all the new features, bug fixes, upgrades over the past 8+ months, and have lots of ideas that I would like implemented in Hamsket.