These are chat archives for TheMrMelc/mu0_simulator

31st
May 2015
Romain-Gobard
@Romain-Gobard
May 31 2015 16:30
hey
Clément T.
@TheMrMelc
May 31 2015 16:31
ah quand même. Est-ce que de ton côté aussi, il n'y a seulement que LDA, STO et STP qui fonctionnent ?
Romain-Gobard
@Romain-Gobard
May 31 2015 16:31
non tout fonctionne suaf rol
sauf
Clément T.
@TheMrMelc
May 31 2015 16:31
parce que tout le reste fait segmentation fault sur ma VM
Romain-Gobard
@Romain-Gobard
May 31 2015 16:32
chez moi tout fonctionne
Clément T.
@TheMrMelc
May 31 2015 16:33
et y a pas une surconso de mémoire sur ces instructions ? (j'ai 768 Mo de RAM max pour l'instant sur cette VM)
Romain-Gobard
@Romain-Gobard
May 31 2015 16:36
je vous ai transmis le bon code il y a pas de doutes
TheMrMelc @TheMrMelc pense que lui non plus
Clément T.
@TheMrMelc
May 31 2015 16:37
ok mais est-ce que tu peux vérifier ta conso de RAM à ce moment là stp
Romain-Gobard
@Romain-Gobard
May 31 2015 16:41
j'ai 1.5 GB d'utiliser sur 4BG c'est normal
en tout sur le pc
Clément T.
@TheMrMelc
May 31 2015 16:42
mais je m'en fous de "en tout". Je veux que tu regardes si t'as un pic, voire mieux directement sur la console si c'est facilement identifiable
Clément T.
@TheMrMelc
May 31 2015 16:52
/leave
Romain-Gobard
@Romain-Gobard
May 31 2015 16:58
je n'ai aucun pic de RAM
Mamaco
@Mamaco
May 31 2015 17:49
hey zetes là ?
Clément T.
@TheMrMelc
May 31 2015 17:49
moi oui. @Romain-Gobard a l'air absent pour l'instant
Mamaco
@Mamaco
May 31 2015 17:49
oki
Romain-Gobard
@Romain-Gobard
May 31 2015 17:50
non je suis la
Mamaco
@Mamaco
May 31 2015 17:50
donc puis je poser une question con ?
Romain-Gobard
@Romain-Gobard
May 31 2015 17:51
vas-y lance toi
TheMrMelc @TheMrMelc hésite
Mamaco
@Mamaco
May 31 2015 17:51
est il possible de télécharger d'un coup le dossier ?
avec un GROS bouton "télécharger"
Truc simple quoi
Clément T.
@TheMrMelc
May 31 2015 17:51
oui. Ya un download .zip :P
Mamaco
@Mamaco
May 31 2015 17:52
effectivement.
c'est la faute des oignons
Romain-Gobard
@Romain-Gobard
May 31 2015 17:55
alors vous arrivez à faire marcher le code ?
Clément T.
@TheMrMelc
May 31 2015 17:56
j'ai pas encore récupéré. J'ai changé de maison et là je le récupère sur mon autre ordi du coup
Mamaco
@Mamaco
May 31 2015 17:56
pour l'instant je n'arrive pas à voir le projet dans éclipse
Clément T.
@TheMrMelc
May 31 2015 18:09
j'ai les mêmes erreurs de segmentation que tt à l'heure
Romain-Gobard
@Romain-Gobard
May 31 2015 18:11
tu décommentes bien les instructions dans le main ?
Clément T.
@TheMrMelc
May 31 2015 18:12
Non. Pour l'instant j'ai juste chercher à les tester chacune. Chaque brique de commentaire dans le main correspond à une seule instruction ?
Romain-Gobard
@Romain-Gobard
May 31 2015 18:13
oui
Mamaco
@Mamaco
May 31 2015 18:15
euh. je sais pour vous mais moi j'ai RIEN d'autre que ADD et LDR qui fonctionne
Clément T.
@TheMrMelc
May 31 2015 18:16
Moi j'ai LDA, STO et STP
Romain-Gobard
@Romain-Gobard
May 31 2015 18:16
c'est bien à vous deux on en a déjà 5 :)
Clément T.
@TheMrMelc
May 31 2015 18:18
@Mamaco : pour Eclipse, la structure de GitHub ne lui va pas sûrement. Il vaut mieux simplement faire une copie de projet, puis écraser les dossiers include et src directement.
Clément T.
@TheMrMelc
May 31 2015 18:27
@Romain-Gobard : tu fais la compilation avec GCC/G++ ou MinGW ?
Mamaco
@Mamaco
May 31 2015 18:28
bon. Est il possible d'avoir le workspace en entier SANS m'enlever les fichers de config ? --"
ah nan pardon plantage ADD ne fonctionne pas.
Romain-Gobard
@Romain-Gobard
May 31 2015 18:29
attends je te dis ça ?
Mamaco
@Mamaco
May 31 2015 18:30
on va dire que ma vresion fonction
Clément T.
@TheMrMelc
May 31 2015 18:30
@Mamaco : mais j'ai laissé les fichiers de config qu'il faut. Ceux que j'ai enlevés sont générés tout le temps par le compilateur.
Mamaco
@Mamaco
May 31 2015 18:30
ok
bon.
Romain-Gobard
@Romain-Gobard
May 31 2015 18:31
je compile avec linux GCC
Mamaco
@Mamaco
May 31 2015 18:31
Coucou, c'est quiwy qui prend le pc ^^vous avez un makefile pour compiler ou vous le faite a l'arrache en terminal a chaque fois?
Clément T.
@TheMrMelc
May 31 2015 18:32
ya un makefile dans Debug/
enfin src/mu0/Debug/ pour être précis
c'est ou c'était quoi ton idée quiwy ? :)
Mamaco
@Mamaco
May 31 2015 18:45
Quiwy il a décompresser et a faire make dans le bon dossier
Clément T.
@TheMrMelc
May 31 2015 18:45
:clap:
Mamaco
@Mamaco
May 31 2015 18:45
et ben c'est bien ce que j'ai fait.
et c'est bien ce que j'ai lancé.
et c'est bien ce qui ne fonctionne pas.
les erreurs de ce matin.
Clément T.
@TheMrMelc
May 31 2015 18:46
moi je décommente les blocs individuellement là et ça change pas vraiment à part pour XPC qui n'arrive même pas à compiler
et j'ai un tout petit doute : faut bien seulement envoyer 3 lettres d'instruction en majuscule et c'est tout ?
Mamaco
@Mamaco
May 31 2015 18:48
Que Gobard m'a dit qu'il a corrigé.
oui
Clément T.
@TheMrMelc
May 31 2015 18:48
ok :+1:
Mamaco
@Mamaco
May 31 2015 18:49
du coup vous avez bien le sequement fault à cause du bus ?
Clément T.
@TheMrMelc
May 31 2015 18:50
je sais pas. J'ai pas encore mis gdb sur ma VM
Mamaco
@Mamaco
May 31 2015 18:51
ok
Et gobar il dit quoi ?
Parce que visiblement il a corrigé ça hier
Romain-Gobard
@Romain-Gobard
May 31 2015 18:52
Les instructions fonctionnent lorsque vous les lancez depuis le main
en tout cas sur ma machine
par contre pas directement depuis la console
Mamaco
@Mamaco
May 31 2015 18:52
...
Romain-Gobard
@Romain-Gobard
May 31 2015 18:52
mais ça c'est pas lié aux instructions
Clément T.
@TheMrMelc
May 31 2015 18:52
ça veut dire quoi ça ?
Romain-Gobard
@Romain-Gobard
May 31 2015 18:53
c'est lié au code de mailis
Mamaco
@Mamaco
May 31 2015 18:54
Le code de Maïlis ?
tu m'explique ?
Romain-Gobard
@Romain-Gobard
May 31 2015 18:54
qui permet de reconnaître les instructions juste en les écrivant
dans la console
Mamaco
@Mamaco
May 31 2015 18:55
tu parle des fonctions pour harmoniser tes instructions ?
parce que j'ai une putain de solution pour régler ce problème.
On change tous les prototypes de tes instructions.
Clément T.
@TheMrMelc
May 31 2015 18:56
c'est bien un soucis de Bus que j'ai avec gdb
Mamaco
@Mamaco
May 31 2015 18:56
Ah.
ok
Bon. Clément tu peux vérifier si depuis le main ça marche ?
Clément T.
@TheMrMelc
May 31 2015 18:57
ok. Je teste chacune et ensuite je vais manger
Mamaco
@Mamaco
May 31 2015 18:58
je fais la même de mon coté.
donc si je décomente tout ça fonctionne
c'est le principe ?
Romain-Gobard
@Romain-Gobard
May 31 2015 19:02
oui si tu décommentes les instructions ça marche suaf pour le ROL où j'ai aps encore réussi à faire la rotation à gauche
Clément T.
@TheMrMelc
May 31 2015 19:02
toute en même temps ?
Romain-Gobard
@Romain-Gobard
May 31 2015 19:02
peut -être pas toute en meme essaye déjà de voir si une par une ça marche
meme temps
Clément T.
@TheMrMelc
May 31 2015 19:03
@Romain-Gobard : même avec les commandes vues en MIP ?
Romain-Gobard
@Romain-Gobard
May 31 2015 19:03
les commandes vues en MIP ?
Clément T.
@TheMrMelc
May 31 2015 19:03
value << 1. ça fait une décalage binaire à gauche
et ensuite remettre le MSB en LSB
Romain-Gobard
@Romain-Gobard
May 31 2015 19:04
oui mais du coup après faut récupérer les MSB et les renvoyer au début du 1er octet. En théorir mon code fonctionne mais dans la pratique, c'est une autre histoire
Clément T.
@TheMrMelc
May 31 2015 19:04
ou l'inverse. Je sais jamais trop le sens des rotations
Romain-Gobard
@Romain-Gobard
May 31 2015 19:05
du coup les instructions fonctionnent ?
Clément T.
@TheMrMelc
May 31 2015 19:06

Nom Composant : muxC
Nb comp : 9
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant trouvé : muxC

Nom Composant : muxA
Nb comp : 9
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant trouvé : muxA

Nom Composant : IR
Nb comp : 9
composant gagnant : 0
composant trouvé : IR

Nom Composant : ACC
Nb comp : 9
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant trouvé : ACC

LDA : fin
Nom Composant : ACC
Nb comp : 9
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant trouvé : ACC

Nom Composant : IR
Nb comp : 9
composant gagnant : 0
composant trouvé : IR

j'ai ça pour LDA
Romain-Gobard
@Romain-Gobard
May 31 2015 19:07
et tu as le tableau à la fin ou pas ? Si tu ne l'as pas, décommente "InterfaceGraphique * inter = ...." et "inter->execute"
Clément T.
@TheMrMelc
May 31 2015 19:08
je l'avais retiré. Je remets ça
Mamaco
@Mamaco
May 31 2015 19:08
ben oui
lda fonctionne
Romain-Gobard
@Romain-Gobard
May 31 2015 19:09
ce que tu vois c'est la fonction "findComposant" qui l'affiche c'est pas tres important
l'important c'est le tableau
Clément T.
@TheMrMelc
May 31 2015 19:09
j'ai pas réfléchi sur le coup. Sorry guys
toujours probleme pour ADD.
Mamaco
@Mamaco
May 31 2015 19:10
le bus
Romain-Gobard
@Romain-Gobard
May 31 2015 19:10
par contre du coup il se peut qu'il y ait des signaux qui proviennent d'autres instructions exécutées avant et qui sont restées
qu'est ce que tu as comme erreur ?
Clément T.
@TheMrMelc
May 31 2015 19:11
et j'avais commencé ça depuis la fin tout àl'heure. Pareil pour LDI et STI
La valeur dans le bus de sortie de la memoire vaut5
Erreur de segmentation
dans GDB j'ai
Program received signal SIGSEGV, Segmentation fault.
0x0000000000401d0c in std::vector<Bus*, std::allocator<Bus*> >::size (this=0x28) at /usr/include/c++/4.7/bits/stl_vector.h:626
626 { return size_type(this->_M_impl._M_finish - this->_M_impl._M_start); }
et je vais manger. I come back ASAP ;)
Romain-Gobard
@Romain-Gobard
May 31 2015 19:13
ça normalement c'est lorsque tu lances l'instruction et qu'il va dans le code de ADD
là je comprends pas sur mon pc, tout fonctionne bien
Mamaco
@Mamaco
May 31 2015 19:15
dites.
je peux faire les images ?
Clément T.
@TheMrMelc
May 31 2015 19:17
J'ai pas regardé au bon endroit de la console en fait
Mamaco @Mamaco pleure
Clément T.
@TheMrMelc
May 31 2015 19:18
@Mamaco : oui tu peux faire les images. Ce serait bien qu'on en ait une ou deux de plus pour demo de Jeudi
Mamaco
@Mamaco
May 31 2015 19:18
merci
c'est les images de quand on coloriait les chemins hein ?
je change d'appart' et je fais ça
TheMrMelc @TheMrMelc est revenu
Clément T.
@TheMrMelc
May 31 2015 19:37

'''
Nom Composant : ACC
Nb comp : 9
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant trouvé : ACC

Nom Composant : IR
Nb comp : 9
composant gagnant : 0
composant trouvé : IR

Nom Composant : UAL
Nb comp : 9
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant trouvé : UAL

Nom Composant : muxC
Nb comp : 9
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant trouvé : muxC

Nom Composant : muxB
Nb comp : 9
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant trouvé : muxB

Nom Composant : muxA
Nb comp : 9
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant trouvé : muxA

Nom Composant : IR
Nb comp : 9
composant gagnant : 0
composant trouvé : IR

Nom Composant : ACC
Nb comp : 9
composant gagnant : 0
composant gagnant : 0
composant gagnant : 0
composant trouvé : ACC

La valeur dans le bus de sortie de la memoire vaut5
La valeur dans le bus d'entree 0 de l'ual vaut5
La valeur dans le bus de sortie de ACC1
La valeur dans le bus d'entree 1 de l'ual vaut1
La valeur dans le bus de sortie de l'ual vaut6
La valeur dans le bus d'entree vaut6
BIENVENUE
Blablablabla
'''

Romain-Gobard
@Romain-Gobard
May 31 2015 19:39
les composants qui s'affichent avec toutes leurs données proviennent de la fonction "FindComposant" à chaque fois qu'elle est appelée
Clément T.
@TheMrMelc
May 31 2015 19:39
@Romain-Gobard : c'est ce qui est attendu ou non ? (et ya le tableau en dessous que j'ai pas copié).
Romain-Gobard
@Romain-Gobard
May 31 2015 19:40
nono ce qui est attendu c'est la tableau
le tableau
Clément T.
@TheMrMelc
May 31 2015 19:43
retour console ADD
Romain-Gobard
@Romain-Gobard
May 31 2015 19:45
oui c'est pour l'instruction add ?
tu as encore des erreurs ?
sur les autres instructions ?
Clément T.
@TheMrMelc
May 31 2015 19:47
j'ai pas testé les autres. Je regardais si celle là avait les bonnes valeurs ou si c'était juste le remplissage par défaut
j'ai une petite question d'ailleurs : pour muxA, il prend comme signal [0,1,2,3] ou [1,2,3,4] ?
Romain-Gobard
@Romain-Gobard
May 31 2015 19:48
0,1,2,3
ne t'inquiete pas pour ça j'ai vérifié tout estbon
Clément T.
@TheMrMelc
May 31 2015 19:50
jusqu'au moment où tu te rends compte que non parfois
Romain-Gobard
@Romain-Gobard
May 31 2015 19:50
si jamais il y a des signaux qui ne devraient être actif et qui le sont quand meme c'est qu'il n'y a pas encore le reset
normalement toi et ange devez faire l'intégration avec la partie graphique
d'ailleurs ange est toujours pas là ?
Clément T.
@TheMrMelc
May 31 2015 19:51
non pas exactement. Je me charge de l'intégration et @angeparfait devait avancer au mieux sur le tutoriel
du coup, je vérifie juste que ça segfault pas ou je copie tous les tableaux affichés ?
Romain-Gobard
@Romain-Gobard
May 31 2015 19:54
pourquoi copier les tableaux affichés ? Pour Querrec ?
Clément T.
@TheMrMelc
May 31 2015 19:54
non. Pour vérifier le fonctionnement du programme
quand tu dis de vérifier les instructions une à une
Romain-Gobard
@Romain-Gobard
May 31 2015 19:57
à la limite je refais un commit avec les améliorations que j'ai effectuées comme ça vous aurez la meme version du code que moi
Clément T.
@TheMrMelc
May 31 2015 19:58
non pas besoin des améliorations. Soit y a des correctifs et on les prend, soit on laisse tel quel
Romain-Gobard
@Romain-Gobard
May 31 2015 19:58
pourquoi ?
Clément T.
@TheMrMelc
May 31 2015 19:59
parce que des améliorations sont des potentielles sources d'erreurs. Et de sécurité aussi mais c'est un autre sujet
Mamaco
@Mamaco
May 31 2015 20:00
Question : je fais des gif ?
Romain-Gobard
@Romain-Gobard
May 31 2015 20:00
mais non c'est juste l'ajout d'une fonction qui reset les signaux il y pas de source d'erreur potentielle
et j'ai enlevé plein de cout qui pollue la console
Clément T.
@TheMrMelc
May 31 2015 20:01
c'est justement parce que c'est potentiel qu'on ne sait pas s'il y en a une :P
Romain-Gobard
@Romain-Gobard
May 31 2015 20:02
c'est une fonction extremement simple
Clément T.
@TheMrMelc
May 31 2015 20:03
@Mamaco : je ne sais pas si c'est les gif sont supportés. Les png le sont, c'est sûr. Et je n'ai pas vérifié le reste
et les cout que j'ai vu ne sont pas une pollution. Ils permettent de savoir très précisément les différents états de chaque composant, même s'il ya beaucoup d'infos
Mamaco
@Mamaco
May 31 2015 20:06
les cout deviennent des polueurs quand tu sais si ta partie de code fonctionne. pour find composant par exemple : dites lui juste de retourner une erreur s'il ne trouve pas le composant et un message de réussite sinon
Clément T.
@TheMrMelc
May 31 2015 20:10
et du coup j'ai pas eu la réponse à ma question au final : je vérifie juste que ya pas de segfault en décommentant un par un ou je fais une copie écran du tableau ?
Romain-Gobard
@Romain-Gobard
May 31 2015 20:11
vérifie s'il y a pas de seg fautlt
Mamaco
@Mamaco
May 31 2015 20:12
je vous fais les deux vesions
Clément T.
@TheMrMelc
May 31 2015 20:12
@Mamaco : png + gif ?
Mamaco
@Mamaco
May 31 2015 20:12
oui
dernière question : je vous fais un chemin sur fond transparent ou avec le schéma derrière ?
Clément T.
@TheMrMelc
May 31 2015 20:13
avec le schéma derrière
Romain-Gobard
@Romain-Gobard
May 31 2015 20:18
je viens de me rendre compte que j'ai oublié la classe "interface graphique" dans le diag de classe
Clément T.
@TheMrMelc
May 31 2015 20:19
normal : on nous a dit qu'il ne fallait pas la mettre dès le début de la conception
Mamaco
@Mamaco
May 31 2015 20:19
non il ne la faut pas
Clément T.
@TheMrMelc
May 31 2015 20:19
:P
Romain-Gobard
@Romain-Gobard
May 31 2015 20:19
ouf :)
Mamaco
@Mamaco
May 31 2015 20:19
=)
c'est quoi les couleurs de l'interface graphique ?
Romain-Gobard
@Romain-Gobard
May 31 2015 20:22
pas d'autres seg fault ?
Clément T.
@TheMrMelc
May 31 2015 20:25
@Mamaco : c'est juste gris pour le moment (couleur par défaut). J'ai fait des screenshots en commentaire ici : TheMrMelc/mu0_simulator@a05b216
ils sont tout en bas
@Romain-Gobard : pas de segfault non, sauf ptet pour ROL que je n'ai pas essayé
Romain-Gobard
@Romain-Gobard
May 31 2015 20:28
il n'y aura normalement pas de seg fault mais juste une mauvaise valeur dans ACC
Clément T.
@TheMrMelc
May 31 2015 20:30
non pas de segfault en effet. Et j'ai vérifié pour STO au cas-où et pas de segfault non plus.
Romain-Gobard
@Romain-Gobard
May 31 2015 20:35
ok cool
par contre j'ai bien nettoyé mon code, donc pour la partie" coeur du mu0" je pense qu'il vaut mieux envoyé mon code
Clément T.
@TheMrMelc
May 31 2015 20:37
:warning: la version que tu as actuellement, nuance
et fais une pull request plutôt parce qu'il est possible que @angeparfait ait terminé le tuto d'ici minuit
Clément T.
@TheMrMelc
May 31 2015 20:47
Image moodle
Oh mince :shit: On est à la bourre pour rendre le projet ^^'
Romain-Gobard
@Romain-Gobard
May 31 2015 20:49
oh merde alors
Clément T.
@TheMrMelc
May 31 2015 20:52
sinon sérieusement, comme c'est marqué jusqu'à midi, on peut dire que c'est le cas pour nous aussi ou pas ?
Romain-Gobard
@Romain-Gobard
May 31 2015 20:55
non vaut mieux envoyer ça ce soir
Clément T.
@TheMrMelc
May 31 2015 20:55
oui je pense bien. Mais minuit max ou pas ? That is the question :question:
Romain-Gobard
@Romain-Gobard
May 31 2015 20:56
oui je pense qu'il faut se fixer minuit comme deadline
Mamaco
@Mamaco
May 31 2015 21:00
vous voulez quoi comme deuxième image après LDA ?
Clément T.
@TheMrMelc
May 31 2015 21:00
STO comme elle ne segfaultait pas dans l'interface graphique que t'as conçue
Mamaco
@Mamaco
May 31 2015 21:04
ok
mail pour lda partis
Romain-Gobard
@Romain-Gobard
May 31 2015 21:06
par contre pour github je n'arrive pas à commit la mise à jour du code
quand je fais git log, le commit n'est pas en haut de la liste
Clément T.
@TheMrMelc
May 31 2015 21:08
@Romain-Gobard : parles moi en privé pour GitHub sinon ça va polluer la discussion de groupe pour rien
Romain-Gobard
@Romain-Gobard
May 31 2015 21:10
ok
Mamaco @Mamaco est fière de son premier gif aux couleurs pas belles <3
TheMrMelc @TheMrMelc a vu le gif à Mama
Clément T.
@TheMrMelc
May 31 2015 21:20
Pourquoi y a une trace rose au milieu de muxA ? :worried:
Romain-Gobard
@Romain-Gobard
May 31 2015 21:20
pas mal :)
Mamaco
@Mamaco
May 31 2015 21:25
tu veux dire le triangle rose plus foncé ?
:/
je viens de le voir
j'en ai aucune idée
Clément T.
@TheMrMelc
May 31 2015 21:25
yes
Mamaco
@Mamaco
May 31 2015 21:26
c'est très étrange vu les manip' que j'ai fait
y'a aucune raison
par contre j'ai une question pour sto
je comprend pas le code.
pourquoi mux A set signal à 3 ?
need this information for the drawing
Romain-Gobard
@Romain-Gobard
May 31 2015 21:31
pour envoyer le contenu de IR dans la memoire
Clément T.
@TheMrMelc
May 31 2015 21:32
comme dans LDA, pour pointer la bonne case
désignée par addr
Mamaco
@Mamaco
May 31 2015 21:33
donc la seule dif avec LDA est l'ordre des img ?
je pointe et je met ACC dans la mem et non la meme dans acc
Clément T.
@TheMrMelc
May 31 2015 21:34
pas que : le flux sur le bus de données va dans l'autre sens aussi
y a écriture mémoire là
Romain-Gobard
@Romain-Gobard
May 31 2015 21:34
exact
Mamaco
@Mamaco
May 31 2015 21:35
ouai fin bon on va pas trop voir la dif quoi
je suis limite en langage sms dsl ^^
Romain-Gobard
@Romain-Gobard
May 31 2015 21:36
j'ai fait une pull request si vous voulez
Clément T.
@TheMrMelc
May 31 2015 21:42
gif supporté et implémenté :+1:
et à l'echelle
@Romain-Gobard : t'as vraiment pas trouvé autre chose que ça comme nom de Pull Request sérieux ? --'
Romain-Gobard
@Romain-Gobard
May 31 2015 21:44
on s'en fout
Clément T.
@TheMrMelc
May 31 2015 21:45
et elle est pas bonne parce que tu ne t'es pas aligné sur le projet principal.
Mamaco @Mamaco contente :3
Mamaco
@Mamaco
May 31 2015 21:50
le deuxième arrive
enfin... presque. je re-viens de faire planter le logiciel.
une préférence pour le troisième ?
Clément T.
@TheMrMelc
May 31 2015 21:52
ah zut :shit: Sinon @Romain-Gobard , je suis sérieux quand je dis que ta requête n'est pas acceptable en l'état. Mais tu peux changer les commits tant que la requête reste ouverte.
@Mamaco : STP était la seule avec LDA et STO à ne pas segfaulter donc plutôt STP au cas-où ^^
Romain-Gobard
@Romain-Gobard
May 31 2015 21:53
tant pis on verra ça une autre fois
Clément T.
@TheMrMelc
May 31 2015 21:56
de toute façon, à part l'initialisation sur le main, je n'ai vu que des modifs de nettoyage donc c'est pas ça qui va améliorer quelque chose
Romain-Gobard
@Romain-Gobard
May 31 2015 21:57
j'ai ajouté le reset et commenté du code dans le main pour que Querrec comprenne bien le cheminement
Mamaco
@Mamaco
May 31 2015 21:57
faut déposer le ficgier
Romain-Gobard
@Romain-Gobard
May 31 2015 21:57
oui
Clément T.
@TheMrMelc
May 31 2015 21:58
du coup, je pense qu'il vaut mieux rendre la version qui est dans mon fork, comme il y a les images qui s'adaptent dans Qt
Romain-Gobard
@Romain-Gobard
May 31 2015 21:58
ziu vous voulez
Mamaco
@Mamaco
May 31 2015 21:58
vous pouvez pas faire de merge
?
Clément T.
@TheMrMelc
May 31 2015 21:59
non ça va foutre la zone comme c'est un commit ancien qui est reproposé
on rend tout de suite du coup ou je rajoute STO et hop ? :)
Mamaco
@Mamaco
May 31 2015 22:05
sto emailer
emailé
avec sto ?
Romain-Gobard
@Romain-Gobard
May 31 2015 22:05
vous avez envoyer le projet ?
Mamaco
@Mamaco
May 31 2015 22:05
j'en sais rien
Clément T.
@TheMrMelc
May 31 2015 22:06
non. C'est pour ça que je pose la question de si je mets STO ou pas
Romain-Gobard
@Romain-Gobard
May 31 2015 22:07
tu as cas mettre le STO et après tu envoies
*qu'à
Clément T.
@TheMrMelc
May 31 2015 22:07
@Mamaco : tu proposes de déposer maintenant et d'envoyer par :mailbox_with_mail: avec STO ?
Romain-Gobard
@Romain-Gobard
May 31 2015 22:07

fatigué

Mamaco
@Mamaco
May 31 2015 22:09
'en sais rine mi
TheMrMelc @TheMrMelc a pas compris
Mamaco
@Mamaco
May 31 2015 22:10
je sais juste que c'est l'heure de dodoter du coup tu dépose ce que tu as et on termine pour jeudi
Clément T.
@TheMrMelc
May 31 2015 22:11
okay. Je dépose vite fait ça alors, sans oublier le diag. Bonne :moon: ;)
Mamaco
@Mamaco
May 31 2015 22:11
cool =)
tks
Romain-Gobard
@Romain-Gobard
May 31 2015 22:11
ok bonne nuit tout le monde