These are chat archives for TypeStrong/atom-typescript

10th
May 2015
fops
@fopsdev
May 10 2015 11:59
hi there, i have a nodejs and atom related beginners question. after installing atom-typescript i would really like to see some action and get my feet wet :)
so i would like to create a nodejs testapp with typescript and test my results with console.log(...) from withing atom if possible.
i see that i can build using atom-typescript but i'm really stuck with the workflow from there to easely run my app. is there a package for that as well?
Micah Zoltu
@MicahZoltu
May 10 2015 16:34
Is there a way to clear things out of the auto-complete list? In particular, it appears that atom's underlying autocomplete is being used which just lists every word in the current document as auto-complete options.
Nelo Mitranim
@Mitranim
May 10 2015 16:59
Hmm I take it back what I said about filesGlob. What I'm seeing right now is that atom-typescript creates a filesGlob array and a files array regardless of the previous filesGlob value (such as null)
This is pretty messy =/ Can we fix this?
Basarat Ali Syed
@basarat
May 10 2015 21:36
In particular, it appears that atom's underlying autocomplete is being used which just lists every word in the current document as auto-complete options.
You can disable the fuzzy provider. I think it's in the autocomplete plus options.
can we fix the filesGlob
Basarat Ali Syed
@basarat
May 10 2015 21:41
I'll make it so that it doesn't get inserted automatically. It was that way as I felt like sharing my convenience. Will move it into a snippet instead 🌹
Micah Zoltu
@MicahZoltu
May 10 2015 22:18
Thanks.
Basarat Ali Syed
@basarat
May 10 2015 23:39
@Mitranim 4.2.0 will not create a filesGlob if you don't have files / filesGlob and silently assume **/*.ts You can add a filesGlob manually or just do (fg + press tab) to have one inserted :rose:
Basarat Ali Syed
@basarat
May 10 2015 23:54

i see that i can build using atom-typescript but i'm really stuck with the workflow from there to easely run my app. is there a package for that as well?

@fopsdev not yet. You need to run it externally however you would normally run your app.