These are chat archives for TypeStrong/atom-typescript

5th
Oct 2015
Valentin Robert
@Ptival
Oct 05 2015 00:45
has anyone tried using atom-typescript under NixOS? It seems it tries to access libgtk-x11-2.0.so which crashes the ts worker
Basarat Ali Syed
@basarat
Oct 05 2015 00:48
@Ptival I haven't
NOTE ALL (I don't like all mention so not using it) the grammar breaking in 1.0.15 was fixed with version 7.1 of this package :rose:
Valentin Robert
@Ptival
Oct 05 2015 00:50
@basarat would you happen to know which part of the atom-typescript code would require that shared library?
Basarat Ali Syed
@basarat
Oct 05 2015 00:50
@robyoder / @kitsonk ^
@Ptival you can open up debug.tsand edit it to make it run synchronously ... that might give you more help
Valentin Robert
@Ptival
Oct 05 2015 00:52
ah, thanks, I'll give this a try
phil
@uniphil
Oct 05 2015 02:13
@Ptival I've been having the same issue -- I thought it was because nix's Atom package was back at 1.0.4, but upgrading it to 1.0.19 has not helped
Valentin Robert
@Ptival
Oct 05 2015 02:35
@uniphil so did you just give up on it?
phil
@uniphil
Oct 05 2015 02:42
finding your nixos github issue and this chat has given me optimism :)
I actually just figured out how to override the atom package earlier this evening
phil
@uniphil
Oct 05 2015 03:02
When I open any typescript file, this is what happens in the console: https://i.imgur.com/xVBy9Jy.png
many times per second
and my fan spins up and my laptop gets hot :)
Valentin Robert
@Ptival
Oct 05 2015 03:12
@uniphil yes, same here
phil
@uniphil
Oct 05 2015 03:17
I'm not having much luck debugging so far. Setting everything in debug to true does not stop the worker from dying/restarting constantly nor change the message.
in workerLib I can stop the worker from restarting if the code is 127, but then I can't open typescript files
Basarat Ali Syed
@basarat
Oct 05 2015 03:28
@uniphil @Ptival Ive created this issue TypeStrong/atom-typescript#642
phil
@uniphil
Oct 05 2015 03:30
cool
Basarat Ali Syed
@basarat
Oct 05 2015 03:31
@uniphil @Ptival issue closed. Try now :rose:
Kitson Kelly
@kitsonk
Oct 05 2015 10:31
@basarat thank you much! It is working for me.
Valentin Robert
@Ptival
Oct 05 2015 22:10
@basarat neither apm install nor npm install seem to refresh the .js files in my dist/ directory, am I missing something?