Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Dec 05 17:51
    lierdakil synchronize #1527
  • Dec 05 16:20
    lierdakil edited #1527
  • Dec 05 16:15
    lierdakil opened #1527
  • Dec 05 06:59
    lierdakil closed #1503
  • Dec 05 06:59
    lierdakil closed #1509
  • Dec 05 05:43
    lierdakil labeled #1502
  • Dec 05 05:43
    lierdakil closed #1502
  • Dec 05 05:24
    lierdakil labeled #1513
  • Dec 05 05:24
    lierdakil labeled #1513
  • Dec 05 05:24
    lierdakil labeled #1510
  • Dec 05 01:28
    lierdakil closed #1523
  • Dec 02 10:12
    jeremy-flusin synchronize #1523
  • Nov 27 12:59
    jeremy-flusin synchronize #1523
  • Nov 27 09:57
    jeremy-flusin synchronize #1523
  • Nov 27 09:51
    jeremy-flusin synchronize #1523
  • Nov 26 20:46
    jeremy-flusin synchronize #1523
  • Nov 26 20:41
    jeremy-flusin synchronize #1523
  • Nov 25 20:43
    jeremy-flusin edited #1523
  • Nov 25 20:41
    jeremy-flusin synchronize #1523
  • Nov 25 18:58
    lierdakil synchronize #1523
Micah Zoltu
@MicahZoltu
In particular, the workflow for external type definitions blows at the moment and I don't feel like putting in the time to deal with it until there is some sanity (standardization) around what the long term goals for TS are.
Mike Graham
@cmichaelgraham
makes perfect sense.
Dima Kuzmich
@forforeach
Hi, I try to use atom-typescript with angular and get next error Experimental support for decorators is a feature that is subject to change in a future release. Specify '--experimentalDecorators' to remove this warning.
Anyone know how to handle it?
Nelo Mitranim
@Mitranim
"experimentalDecorators": true in your tsconfig
Dima Kuzmich
@forforeach
@Mitranim thanks
Miguel Couto
@Mig1st4ck
i upgraded to latest version 4.8.1
now when i press F6 to do a full build
it generate 4 Builds
what is happening???
Basarat Ali Syed
@basarat
build.gif
@Mig1st4ck I am getting a single build as seen ^
Miguel Couto
@Mig1st4ck
i think the problem is with the upgrade.
something like a server is running listening for F6, then when i upgrade a new server is started, but the old is still runing,
since i had my Atom open for several days and did some upgrades i should have had 3 instances of the server running so 3 builds
after i restart Atom i got a single build.
Jonathan Park
@park9140
@basarat, do you use Timecop?
I’m curious why the package load time is 600ms while the activation time is only ~30-40ms
I’m curious why the package load time is 600ms while the activation time is only 34ms
Basarat Ali Syed
@basarat
@park9140 Haven't profiled it yet. Still feature churning
@park9140 think its the worker starting ... but not sure (i.e. doesn't sound right)
Basarat Ali Syed
@basarat
Thanks @park9140 ! atom/atom#7638 created : TypeStrong/atom-typescript#428
Jonathan Park
@park9140
@basarat, I might take a couple swings at optimizing load time this weekend.
Cu3PO42
@Cu3PO42
@basarat Just saw you comment on #418. I can’t seem to reproduce that, though EDIT: nvm, was my theme being wonky. working on it!
Cu3PO42
@Cu3PO42
Got if fixed and PR sent (#430). That was a quick one :)
Basarat Ali Syed
@basarat
@Cu3PO42 if you get the
Chance run "apm publish patch"
Cu3PO42
@Cu3PO42
@basarat I’d love to, but I don’t think I can do that without having the 5.0.1 tag on upstream and I can’t push that there obviously… am I supposed to create a PR for that?
@Cu3PO42 I added you as a collaborator ... accept that and then you can push ;)
Cu3PO42
@Cu3PO42
@basarat I’m afraid I didn’t receive an invite
Basarat Ali Syed
@basarat
blob
blob
@Cu3PO42 I just cancelled and invited again ... check email again :rose:
Cu3PO42
@Cu3PO42
@basarat Got one and joined!
Thanks :)
kpgarrod
@kpgarrod
I am noticing (for the last few releases) that some errors are not cleared when I fix them. The only way I can get the errors cleared is to close down Atom (or the project at least) and re-open. Is anybody else getting this?
Basarat Ali Syed
@basarat
I am getting something like this. Note that the atom-ts error panel does clear errors, just the linter errors keep hanging @kpgarrod is that correct?
Cu3PO42
@Cu3PO42
I have sometimes noticed that, too, although deleting the line and pasting it again usually does it for me. Using vim-mode that’s just a quick ddP
kpgarrod
@kpgarrod
@basarat. not sure. I will check. Linter errors are shown in the bottom of the screen, right?
Cu3PO42
@Cu3PO42
The linter error list should be below the TS bar.
Basarat Ali Syed
@basarat
blob
the lower one is linter ... it is out of date even right now
kpgarrod
@kpgarrod
How do I attach a file here?
Basarat Ali Syed
@basarat
@kpgarrod drop it ... or paste it from clipboard
kpgarrod
@kpgarrod
Screen Shot 2015-07-03 at 10.58.45 AM
Basarat Ali Syed
@basarat
@kpgarrod was that a drop?
Cu3PO42
@Cu3PO42
This message was deleted
Dropping from OS X definitely works...
kpgarrod
@kpgarrod
Screen Shot 2015-07-03 at 10.58.45 AM.png
sorry, tried pasting