Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Oct 15 09:28
    pasinduperera synchronize #1514
  • Oct 15 09:20
    pasinduperera synchronize #1514
  • Oct 15 09:11
    pasinduperera opened #1514
  • Oct 02 22:01
    kaiyoma opened #1513
  • Sep 30 20:20
    jfellus edited #1512
  • Sep 30 20:20
    jfellus edited #1512
  • Sep 30 20:19
    jfellus edited #1512
  • Sep 30 20:18
    jfellus edited #1512
  • Sep 30 20:18
    jfellus edited #1512
  • Sep 30 20:17
    jfellus opened #1512
  • Sep 21 09:57
    arcanis opened #1511
  • Sep 20 16:18
    reduxdj edited #1510
  • Sep 20 16:18
    reduxdj opened #1510
  • Sep 20 08:28
    mininek opened #1509
  • Aug 15 17:06
    chaffeqa opened #1508
  • Aug 08 16:07
    lierdakil closed #1507
  • Aug 08 16:07
    lierdakil labeled #1507
  • Aug 08 11:43
    rahamin1 opened #1507
  • Aug 07 12:07
    lierdakil labeled #1505
  • Aug 07 12:07
    lierdakil closed #1505
Jonathan Park
@park9140
@basarat, do you use Timecop?
I’m curious why the package load time is 600ms while the activation time is only ~30-40ms
I’m curious why the package load time is 600ms while the activation time is only 34ms
Basarat Ali Syed
@basarat
@park9140 Haven't profiled it yet. Still feature churning
@park9140 think its the worker starting ... but not sure (i.e. doesn't sound right)
Basarat Ali Syed
@basarat
Thanks @park9140 ! atom/atom#7638 created : TypeStrong/atom-typescript#428
Jonathan Park
@park9140
@basarat, I might take a couple swings at optimizing load time this weekend.
Cu3PO42
@Cu3PO42
@basarat Just saw you comment on #418. I can’t seem to reproduce that, though EDIT: nvm, was my theme being wonky. working on it!
Cu3PO42
@Cu3PO42
Got if fixed and PR sent (#430). That was a quick one :)
Basarat Ali Syed
@basarat
@Cu3PO42 if you get the
Chance run "apm publish patch"
Cu3PO42
@Cu3PO42
@basarat I’d love to, but I don’t think I can do that without having the 5.0.1 tag on upstream and I can’t push that there obviously… am I supposed to create a PR for that?
@Cu3PO42 I added you as a collaborator ... accept that and then you can push ;)
Cu3PO42
@Cu3PO42
@basarat I’m afraid I didn’t receive an invite
Basarat Ali Syed
@basarat
blob
blob
@Cu3PO42 I just cancelled and invited again ... check email again :rose:
Cu3PO42
@Cu3PO42
@basarat Got one and joined!
Thanks :)
kpgarrod
@kpgarrod
I am noticing (for the last few releases) that some errors are not cleared when I fix them. The only way I can get the errors cleared is to close down Atom (or the project at least) and re-open. Is anybody else getting this?
Basarat Ali Syed
@basarat
I am getting something like this. Note that the atom-ts error panel does clear errors, just the linter errors keep hanging @kpgarrod is that correct?
Cu3PO42
@Cu3PO42
I have sometimes noticed that, too, although deleting the line and pasting it again usually does it for me. Using vim-mode that’s just a quick ddP
kpgarrod
@kpgarrod
@basarat. not sure. I will check. Linter errors are shown in the bottom of the screen, right?
Cu3PO42
@Cu3PO42
The linter error list should be below the TS bar.
Basarat Ali Syed
@basarat
blob
the lower one is linter ... it is out of date even right now
kpgarrod
@kpgarrod
How do I attach a file here?
Basarat Ali Syed
@basarat
@kpgarrod drop it ... or paste it from clipboard
kpgarrod
@kpgarrod
Screen Shot 2015-07-03 at 10.58.45 AM
Basarat Ali Syed
@basarat
@kpgarrod was that a drop?
Cu3PO42
@Cu3PO42
This message was deleted
Dropping from OS X definitely works...
kpgarrod
@kpgarrod
Screen Shot 2015-07-03 at 10.58.45 AM.png
sorry, tried pasting
Basarat Ali Syed
@basarat
@kpgarrod press cmd+s does that fix it?
kpgarrod
@kpgarrod
You see, I have fixed the error at line 104
there is no coachId there now
As you say, the error disappears from the ts errors
Basarat Ali Syed
@basarat
"disappears from ts errors" "but sticks in linter errors" right?
kpgarrod
@kpgarrod
no, cmd+s does not fix it
even closing and reopening the file doesn't
@basarat: yes, right
Basarat Ali Syed
@basarat
cool It's an issue with the new linter rewrite. I am hoping other lint clients (like us) will suffer the same fate and someone there will fix it :)
It's not particularly easy to reproduce
I've even tried execing "linter:lint" command and even that doesn't fix it
Cu3PO42
@Cu3PO42
:/
Basarat Ali Syed
@basarat
This is their gitter page btw : https://gitter.im/AtomLinter/Linter
Cu3PO42
@Cu3PO42
The joys of being dependant on someone else fixing errors
Basarat Ali Syed
@basarat
we could put in the effort (its oss) ... just because nearly everybody who uses atom uses linter => they will get a clear issue report soon