Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 01 19:20
    dependabot[bot] labeled #1521
  • Nov 01 19:20
    dependabot[bot] opened #1521
  • Oct 26 23:07
    lierdakil closed #1512
  • Oct 26 23:07
    lierdakil labeled #1512
  • Oct 26 23:07
    lierdakil labeled #1512
  • Oct 24 22:12
    micazoyolli opened #1520
  • Oct 23 23:07
    lierdakil closed #1514
  • Oct 23 23:06
    lierdakil labeled #1514
  • Oct 23 22:53
    lierdakil closed #1518
  • Oct 23 22:53
    lierdakil closed #1517
  • Oct 23 22:52
    lierdakil closed #1516
  • Oct 23 22:51
    lierdakil opened #1519
  • Oct 19 14:49
    betheymc opened #1518
  • Oct 19 14:43
    betheymc opened #1517
  • Oct 19 14:36
    betheymc opened #1516
  • Oct 19 14:30
    betheymc opened #1515
  • Oct 15 09:28
    pasinduperera synchronize #1514
  • Oct 15 09:20
    pasinduperera synchronize #1514
  • Oct 15 09:11
    pasinduperera opened #1514
  • Oct 02 22:01
    kaiyoma opened #1513
Basarat Ali Syed
@basarat
@kpgarrod drop it ... or paste it from clipboard
kpgarrod
@kpgarrod
Screen Shot 2015-07-03 at 10.58.45 AM
Basarat Ali Syed
@basarat
@kpgarrod was that a drop?
Cu3PO42
@Cu3PO42
This message was deleted
Dropping from OS X definitely works...
kpgarrod
@kpgarrod
Screen Shot 2015-07-03 at 10.58.45 AM.png
sorry, tried pasting
Basarat Ali Syed
@basarat
@kpgarrod press cmd+s does that fix it?
kpgarrod
@kpgarrod
You see, I have fixed the error at line 104
there is no coachId there now
As you say, the error disappears from the ts errors
Basarat Ali Syed
@basarat
"disappears from ts errors" "but sticks in linter errors" right?
kpgarrod
@kpgarrod
no, cmd+s does not fix it
even closing and reopening the file doesn't
@basarat: yes, right
Basarat Ali Syed
@basarat
cool It's an issue with the new linter rewrite. I am hoping other lint clients (like us) will suffer the same fate and someone there will fix it :)
It's not particularly easy to reproduce
I've even tried execing "linter:lint" command and even that doesn't fix it
Cu3PO42
@Cu3PO42
:/
Basarat Ali Syed
@basarat
This is their gitter page btw : https://gitter.im/AtomLinter/Linter
Cu3PO42
@Cu3PO42
The joys of being dependant on someone else fixing errors
Basarat Ali Syed
@basarat
we could put in the effort (its oss) ... just because nearly everybody who uses atom uses linter => they will get a clear issue report soon
and they are actively maintaing it :rose:
Cu3PO42
@Cu3PO42
Maybe I’ll look into it after I get sourcemaps working for the node debugger
Basarat Ali Syed
@basarat
blob
what I'm working on ^ typescript/register support
for node
Cu3PO42
@Cu3PO42
That’s awesome!
kpgarrod
@kpgarrod
@basarat: actually, the typescript error doesn't always get cleared
Basarat Ali Syed
@basarat
@kpgarrod ctrl+s should clear that : https://github.com/TypeStrong/atom-typescript#sync
does it?
If so I know I have a bug to find :) lately I haven't needed that
kpgarrod
@kpgarrod
no, it doesn't
Basarat Ali Syed
@basarat
:(
screenshot?
kpgarrod
@kpgarrod
Screen Shot 2015-07-03 at 11.15.18 AM.png
Cu3PO42
@Cu3PO42
Can you consistently reproduce that?
kpgarrod
@kpgarrod
not sure, but it seems to be happening regularly
Basarat Ali Syed
@basarat
in a not so loud voice (at least its not a bug in linter then) ashamed
Cu3PO42
@Cu3PO42
Welp, I can’t seem to be able to reproduce that
In my code
kpgarrod
@kpgarrod
I just updated to 5.0.9 and the errors have gone for now
Cu3PO42
@Cu3PO42
Awesome!
kpgarrod
@kpgarrod
I'll try to watch out for the exact conditions that cause it if it happens again
Cu3PO42
@Cu3PO42
That’ll be great :)
kpgarrod
@kpgarrod
mmm, back again
Basarat Ali Syed
@basarat
screenshot ... before it goes too bad
kpgarrod
@kpgarrod
it seems that linter was still linting when the errors had disappeared
after the linter errors appeared, the ts errors got stuck as well (maybe)
just looking at my packages, I see I have linter and linter-tslint disabled