Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 18 18:59
    danieltroger opened #1595
  • Nov 11 00:19
    github-actions[bot] closed #1589
  • Nov 09 20:22
    ChronomancerDev opened #1594
  • Oct 31 20:04
    lierdakil closed #1590
  • Oct 28 12:01
    ayame113 closed #1587
  • Oct 28 11:50
    lierdakil unlabeled #1590
  • Oct 28 11:49
    lierdakil assigned #1590
  • Oct 28 00:18
    github-actions[bot] labeled #1589
  • Oct 28 00:18
    github-actions[bot] labeled #1590
  • Oct 27 08:49
    droid001 closed #1593
  • Oct 27 08:34
    droid001 edited #1593
  • Oct 25 14:30
    droid001 opened #1593
  • Oct 11 00:18
    github-actions[bot] closed #1586
  • Oct 11 00:18
    github-actions[bot] closed #1588
  • Sep 26 00:19
    github-actions[bot] labeled #1586
  • Sep 26 00:19
    github-actions[bot] labeled #1588
  • Aug 31 00:16
    github-actions[bot] closed #1585
  • Aug 25 11:30
    Nilos opened #1591
  • Aug 16 00:17
    github-actions[bot] labeled #1585
  • Aug 14 00:15
    github-actions[bot] closed #1584
Basarat Ali Syed
@basarat
we'll see if that fixes it
@Mig1st4ck alright I've pushed an update v5.2.5 let me know if that fixes it :rose:
Miguel Couto
@Mig1st4ck
@basarat i am updating to 5.2.6 missed the 5 :D
its working with 5.2.6
thx
stijnvn
@stijnvn
I'm trying to set up TypeScript with Atom and Gulp. Gulp compiles the TypeScript files when they are changed. Therefore I have set compileOnSave to false in tsconfig.json. In Atom I get the error message "Js emit is outdated". When I change something in the file and undo the change, the warning disappears. It seems that atom-typescript does not pick up automatically the files compiled by Gulp. Is there something to do about this? Or what workflow do you suggest?
Patrick Toy
@patrickjtoy
It sounds like a matter of preference. atom-typescript and gulp can both compile your TS files on save, but only atom-typescript is going to give you additional functionality (such as the outdated emit message). If you prefer to continue using gulp, I wouldn't worry about the outdate emit message, as it likely isn't harmful.
kpgarrod
@kpgarrod
This message was deleted
stijnvn
@stijnvn
@patrickjtoy Would it make sense then to disable that error message when compileOnSave is false or maybe even better let atom-typescript detect that some other tool has compiled the file?
Patrick Toy
@patrickjtoy
@stijnvn possibly. have you tried reporting it as an issue on github?
Basarat Ali Syed
@basarat
Would it make sense then to disable that error message when compileOnSave is false
:+1:
Vaughn Royko
@vaughnroyko
hey all, is there a way to not have tsconfig not automatically build itself? i want to change the order of some of the files for some definition overrides, and manually changing order in tsconfig and saving just reverts it
Micah Zoltu
@MicahZoltu
@vaughnroyko I think atom won't modify the file if you don't have a filesGlob section.
Vaughn Royko
@vaughnroyko
was just looking at that!
yep, looks like it works, thanks!
i can also edit the glob a bit so the order is changed
Basarat Ali Syed
@basarat

i can also edit the glob a bit so the order is changed

Yes. The ordering from filesGlob is preserved

Amine BIZID
@zigzag95
Hi guys
how in tsconfig make js generation in an output folder
Basarat Ali Syed
@basarat
@zigzag95 use compilerOptions / outDir
Amine BIZID
@zigzag95
@basarat thanks. Another question: how to tell tsconfig to generate map files?
Basarat Ali Syed
@basarat
@zigzag95 compilerOptions / sourceMap to true
Simon Hampton
@simonh1000
@ewinslow Yes, me too
gastrodia
@gastrodia
does atom-typescript have any options to rewrite typescript require path ?
Basarat Ali Syed
@basarat

have any options to rewrite typescript require path

Nope. Waiting for Microsoft/TypeScript#2338

@gastrodia :rose: ^
gastrodia
@gastrodia
@basarat nice to know about it ,thank you
Valentin Robert
@Ptival
suddenly, atom-typescript does not complain about any error, is this a known issue?
Basarat Ali Syed
@basarat

is this a known issue

Not at the moment. Would be great if we can get a repo. Meanwhile try running sync to prevent work stops : https://github.com/TypeStrong/atom-typescript#sync

@Ptival ^ :rose:
Valentin Robert
@Ptival
@basarat ah yeah, I fixed it by downgrading my atom-typescript version
is there a way to pin the Typescript pane open?
it keeps moving and often hides the part where I'm typing...
gastrodia
@gastrodia
can i separate files in tsconfig to a file
Micah Zoltu
@MicahZoltu
@gastrodia I don't believe so. Out of curiosity, why do you want to?
Basarat Ali Syed
@basarat

is there a way to pin the Typescript pane open?

@Ptival done : TypeStrong/atom-typescript@86d8d69 v5.4.1 :rose:

gastrodia
@gastrodia
@Zoltu i want put tsconfig.json into git ,but the files will conflict when we add or delete ts files toghter
Basarat Ali Syed
@basarat

git ,but the files will conflict when we add or delete ts files toghter

@gastrodia yeah, thats a pain. Its been raised before. Basically if you have filesGlob then files shouldn't even be there but we have it for convinience for other IDE users and TSC conmmand line. Consider the pain of adding files manually

Valentin Robert
@Ptival
@basarat do you know why, when I do "apm install atom-typescript", then "apm list" shows @4.5.0, but "apm show atom-typescript" says 5.5.0?
Valentin Robert
@Ptival
Also, when I update to 5.5.0, the plugin stops working entirely. F2, F6, the pane, nothing seems to be working :\
Basarat Ali Syed
@basarat
@Ptival any errors?
Miguel Couto
@Mig1st4ck
emitDecoratorMetadata when set to true gives wrong javascript code
something like this.
__metadata('design:paramtypes', [, Object, Object, Object, .., Object, Object, ..., ., ., ., Object])
my Constructor for the class is this

    constructor($stateParams,
      private $state: ng.ui.IStateService,
      private $scope: ng.IScope,
      private common: Common.ICommonService,
      private  docsData: Lf.Docs.DocsService,
      private docsTransform: Lf.Docs.ITransfomDocHelper,
      private modal: Bootstrap.Modal,
      private  calcs: Lf.Docs.Editor.CalcFactory,
      private editorChanges: Editor.EditorChanges,
      private editorCanAct: Editor.EditorCanAct,
      private docTransfLines: Editor.ModalTransformLines,
      private  helperNewDoc: Docs.INewDocHelper) {
Aviel Fedida
@avielfedida
When installed 5.5.0, the plugin won't compile, when cheacked config.cson, I notice that: "atom-typescript": {}
Basarat Ali Syed
@basarat

when cheacked config.cson, I notice that: "atom-typescript": {}

@avielfedida That's just because you don't have any settings saved for atom-typescript. Should be a correlation with wont' compile. Can you provide more info :rose:

Philipp Knecht
@fopsdev
blob
hi all, i'm checking out aurelia together with typescript. i have typestrong 5.5.1 installed. but the build somehow does not finish
if somebody wants to check it out: https://github.com/fopsdev/aurelia-typescript.git