Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Aug 15 17:06
    chaffeqa opened #1508
  • Aug 08 16:07
    lierdakil closed #1507
  • Aug 08 16:07
    lierdakil labeled #1507
  • Aug 08 11:43
    rahamin1 opened #1507
  • Aug 07 12:07
    lierdakil labeled #1505
  • Aug 07 12:07
    lierdakil closed #1505
  • Aug 06 21:51
    TheEmrio closed #1506
  • Aug 05 14:22
    TheEmrio opened #1506
  • Jul 15 15:40
    Xapphire13 closed #1496
  • Jul 10 13:23
    akonwi opened #1505
  • Jul 10 04:44
    nelson6e65 edited #1504
  • Jul 10 04:40
    nelson6e65 opened #1504
  • Jul 08 06:40
    sshquack closed #846
  • Jun 17 16:02
    akonwi opened #1503
  • Jun 02 18:18
    tanfonto opened #1502
  • May 28 17:11
    jazzdragon opened #1501
  • Apr 29 01:12
    dyping closed #1500
  • Apr 28 06:56
    dyping edited #1500
  • Apr 28 06:54
    dyping edited #1500
  • Apr 26 11:38
    dyping opened #1500
Basarat Ali Syed
@basarat

@proff321

Tips : files and exclude (note not excludes ... and I did argue for it ... https://github.com/Microsoft/TypeScript/pull/3188#issuecomment-102720217 but they went with exclude ¯\_(ツ)_/¯) are both arrays ... so files:{} is bad files:[] is good (same for exclude). Also `exclude should just be directory name (
"exclude": [ "node_modules", "examples" ])

PS: feel free to file a :bug: :rose:
Rob Yoder
@robyoder

NOTE ALL (I don't like all mention so not using it) the grammar breaking in 1.0.15 was fixed with version 7.1 of this package :rose:

Awesome! :heart:

I need to check back here more often :)
Basarat Ali Syed
@basarat
You can click watch on an issue on github to get notified when that issue is resolved/closed ;)
Valentin Robert
@Ptival
@basarat thanks for the merge! as part of building on my system, I had an error in tsconfig.d.ts about not finding the module 'pinkie-promise', any pointer on that?
Basarat Ali Syed
@basarat
@Ptival That is a bug (a bit harmless though) in the tsconfig.d.ts file and an issue needs to be reported /cc @blakeembrey
I had the same error when building locally (which I just ignored) before pushing ;)
Blake Embrey
@blakeembrey
yeah, i have the same issue but there's no proper fix for the bug in tsconfig until i've finished with tsd :( if i define pinkie-promise, it might conflict with a different definition - the simplest fix is to copy it locally to your own project (which i did with ts-node)
Rob Yoder
@robyoder
ts-grammar.png
@basarat new grammar problem, known issue?
using parentheses seems to be the issue
Blake Embrey
@blakeembrey
TypeStrong/atom-typescript#670
recently logged the same issue
Rob Yoder
@robyoder
gracias!
matthew harwood
@matthewharwood
anyone know within a tsconfig.json the purposes of these flags
        "declaration": false,
        "noImplicitAny": false,
        "noLib": false,
matthew harwood
@matthewharwood
mmm Tyty
James Brantly
@jbrantly
if you have specific questions after reading that feel free to ask :D
matthew harwood
@matthewharwood
do you have any examples on how 'declaration': true would work?
declaration:true
James Brantly
@jbrantly
TS will emit .d.ts files next to your .js files is all
matthew harwood
@matthewharwood
and it hooks in to your ts when you put the word declare right?
James Brantly
@jbrantly
declare is something else
matthew harwood
@matthewharwood
yeah I should go read more lol.
James Brantly
@jbrantly
more than likely you don't need to care about declaration: true
it's mostly for library authors
matthew harwood
@matthewharwood
I know I know. theres just so much boilerplate to a project and I hate seeing the same things and having zero idea what they really do or mean. I feel like sometimes I missing out on a deeper understanding. I'm just trying to read the source and pausing on words that I don't know. That sound insane?
James Brantly
@jbrantly
nope, sounds like learning
matthew harwood
@matthewharwood
I got to catch the bus but thanks for the help
cubuspl42
@cubuspl42
Hello!
Anybody here? :)
Blake Embrey
@blakeembrey
what's up? you're welcome to ask questions anytime - not everyone can online at all times :)
George Song
@gsong
@basarat So far atom-typescript has been the most pleasant thing of my investigation into TS.
Basarat Ali Syed
@basarat
@gsong cheers :rose:
Gordon Lawrenz
@DeusProx
Hello! I just updated to atom-typescript 7.6.3 and atom won't transpile to es6 anymore. all the lines which should be "import" are now "require" lines
http://pastebin.com/CAVx1tC3 this is my tsconfig
Basarat Ali Syed
@basarat

which should be "import" are now "require" lines

@Chocoloper is this the issue you are facing? Microsoft/TypeScript#5110

Gordon Lawrenz
@DeusProx
yeah
before the update it worked correctly and i could pull everything with systemjs into the browser
it also still works from terminal with tsc
Basarat Ali Syed
@basarat
@Chocoloper can you provide a repro for the TypeScript team. Till then you can lock your atom-typescript apm install atom-typescript@versionthatworks

it also still works from terminal with tsc

@Chocoloper try typescript nightly

or ntypescript if you don't want to mess up the meaning of tsc in your OS
Gordon Lawrenz
@DeusProx
no tsc 1.6.2 works correctly so i'm fine with it... it's only the builtin typescript in atom-typescript. i just commented Microsoft/TypeScript#5110
Basarat Ali Syed
@basarat
@Chocoloper please try npm install ntypescript -g and then run ntsc instead of tsc
Gordon Lawrenz
@DeusProx
okay i'll try
ntsc (1.8.0) works fine
I'm working with node(v4.2.1)/npm(2.14.7) from nvm