Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Aug 15 17:06
    chaffeqa opened #1508
  • Aug 08 16:07
    lierdakil closed #1507
  • Aug 08 16:07
    lierdakil labeled #1507
  • Aug 08 11:43
    rahamin1 opened #1507
  • Aug 07 12:07
    lierdakil labeled #1505
  • Aug 07 12:07
    lierdakil closed #1505
  • Aug 06 21:51
    TheEmrio closed #1506
  • Aug 05 14:22
    TheEmrio opened #1506
  • Jul 15 15:40
    Xapphire13 closed #1496
  • Jul 10 13:23
    akonwi opened #1505
  • Jul 10 04:44
    nelson6e65 edited #1504
  • Jul 10 04:40
    nelson6e65 opened #1504
  • Jul 08 06:40
    sshquack closed #846
  • Jun 17 16:02
    akonwi opened #1503
  • Jun 02 18:18
    tanfonto opened #1502
  • May 28 17:11
    jazzdragon opened #1501
  • Apr 29 01:12
    dyping closed #1500
  • Apr 28 06:56
    dyping edited #1500
  • Apr 28 06:54
    dyping edited #1500
  • Apr 26 11:38
    dyping opened #1500
llgcode
@llgcode
Hi is someone can tell me about new use-strict statement added automatically by atom-typescript?
@basarat Does atom-typescript interfere with the newline characters used by typescript? I have "newLine": "LF" in my tsconfig file, but it's writing the files with CRLF. It seems to work fine when using tsc directly.
llgcode
@llgcode
@glen-84 thanks. So I've changed the default typescript used (last github version) with the one I have installed with npm to keep compatibility for now waiting the 1.8 to be released
Glen
@glen-84
You're welcome.
Dominic Böttger
@DominicBoettger
Hello
Can i limit the line length of the compiled javascript?
Gerasimos (Makis) Maropoulos
@removed~kataras
This message was deleted
http://postimg.org/image/s15zgxzf3/ Does someone else has this problem at .tsx files ? ( look at the right side of the image)
Gerasimos (Makis) Maropoulos
@removed~kataras
@/all
Basarat Ali Syed
@basarat
@DominicBoettger No. Just limit the length of the ts ? 🌹
@kataras I've seen the minimal look that way. I uninstalled it for myself :). I haven't seen '/div' artifacts.
Gerasimos (Makis) Maropoulos
@removed~kataras
@basarat it's happening for </span also, If I change the language editor to 'Typescript' ( from Typescript (TSX)) it does disappear but no code hint for html inside render()
I'm using Windows 7, I had the same problem with Windows 10 and Ubuntu 15.10 too
I though it will be fixed but no..
Why I have this problem ?
It's the only reason I had to use sublime but I like Atom most..
Marcus
@mjohnsonengr
blob
Aware of this syntax highlighting issue?
Couldn't find an issue, but I'll be surprised if I'm the first one that's noticed it
@basarat
Roderick Gibson
@kniteli
I use jspm for my run time dependencies, but I'm currently having to npm install angular2 just so atom-typescript can resolve the imports and typings. Does anyone have any thoughts on hooking into the jspm packages instead of having to install the npm versions as well?
Basarat Ali Syed
@basarat

Aware of this syntax highlighting issue?

@mjohnsonengr seems like a specialization of TypeStrong/atom-typescript#645

I use jspm for my run time dependencies, but I'm currently having to npm install angular2 just so atom-typescript can resolve the imports and typings. Does anyone have any thoughts on hooking into the jspm packages instead of having to install the npm versions as well?

@kniteli Nope. TypeScript only resolves on node_modules at the moment and hence that is what we support. As far as I know jspm module resolution is being tracked here : Microsoft/TypeScript#5039 but don't think it covers auto impor. Correct me if I am wrong :rose:

Marcus
@mjohnsonengr
Awesome thanks!
Roderick Gibson
@kniteli
@basarat thanks
John Fly
@boxofnotgoodery
Can anyone help me figure out using babel as an externaltranspiler?
I'm not a babel user..
Basarat Ali Syed
@basarat
@boxofnotgoodery sorry for the late reply. Unfortunately neither am I (at least not in any significant way). The features were authored by the community and should be obvious to a babel user, which again I am not :rose: I might be able to help if you have a more concrete question though :rose:
Dominic Böttger
@DominicBoettger
@boxofnotgoodery I tried it and actually had success with it :-). https://github.com/TypeStrong/atom-typescript/blob/master/docs/faq.md
@boxofnotgoodery Actually it was not very fast and sometimes did not work well. I created a Boileplate for a angular project where i solved it differently including all the html templates into typescript: https://github.com/INSPIRATIONlabs/angular-systemjs-typescript-boilerplate
Ophir Oren
@developer82
I keep getting JS Outdated 1, c:/node/...../myfile.ts No project file found. Please user the 'Create tsconfig.json project file' command. I've created a tsconfig.json and even put "buildOnSave": true which seems to be working. why the error message?
Tatamethues
@colinshen
hello
how to compile ts fils to another folder but keep their own folder? like this src/a/a.ts app/a/a.js?
Micah Zoltu
@MicahZoltu
Ophir Oren
@developer82
Auto .ts file transpilation no longer works on save
Nick
@streusselhirni
Hello there
It seems like the "preferred quotes" setting does not change anything for me. It doesn't matter if I enter ' or single in this setting, the linter always complains, that I should use double quotes.
Does someone have an idea what I'm doing wrong?
Basarat Ali Syed
@basarat
@streusselhirni the linter is not from atom-typescript. You need to set tslint settings :rose:
Nick
@streusselhirni
@basarat thank you, I found the problem! Using a tslint.json file I could finally set quotemarks to singles :smile:
Gordon Lawrenz
@DeusProx

@basarat I want to use rxjs observables with the fromEvent function. To get it working I need to import them like this:

import ...........
import {Observable} from 'rxjs/Observable';
import 'rxjs/add/observable/fromEvent';

But it keeps underlining it as error:
'/home/chocoloper/Downloads/ng/node_modules/rxjs/add/observable/fromEvent.d.ts' is not a module. Please contact the package author to update the package definition.at line 3 col 8

Basarat Ali Syed
@basarat
@Chocoloper If that's valid code then the issue needs to be reported to angular (create an issue there first) and then rxjs team :rose:
Navin Saini
@sumedha-navin
How to load "ng2-datepicker" package on save package.json in atom
it works on Visual Studio 15
but not in atom-typescript
Tatamethues
@colinshen
hello, how can i make a sticky top bar in foundation6?
Basarat Ali Syed
@basarat
@colinshen wrong channel?
loginator
@loginator
is there any way to install this extension without an internet connection?
im trying to install it by copying the files to the atom packages folder but this is causing an error because it has too long filenames
atsu85
@atsu85
@loginator, use apm - AtomPackageManager
it is installed with atom
rajivbala
@rajivbala
Hi when i create a file with uppercase character in it's name(for ex: testFile.ts), the atom editor throws an error , The file 'path/to.file.ts' is not included in the Typescript compilation context. If this is not intended please check the 'files' or 'filesGlob' section of your tsconfig.json file. Any thoughts ?