These are chat archives for USGS-WiM/BLTAdmin_angular

26th
Sep 2016
Hans Vraga
@HansVraga
Sep 26 2016 14:28
@troddick I was updating @venikunche that you are taking a stab at updating the BLT Internal application to work with the new Services.
We do want to give them the password reset ability so we don't have to babysit them in the upcoming year
Hans Vraga
@HansVraga
Sep 26 2016 14:34
What's the latest on this @troddick ?
Tonia Roddick
@troddick
Sep 26 2016 14:35
i'm almost done adding that functionality
i have create new user working with the password
and almost done editing existing user and allowing change password
i'm wondering how you testing clicking on a pula shape in the testing environment @venikunche ?
Veni
@venikunche
Sep 26 2016 14:37
@troddick: I wasn't doing anything different. What's happening when you click on a pula shape now?
Tonia Roddick
@troddick
Sep 26 2016 14:37
i'm not getting the pula shapes. take a look: bltdev.wim.usgs.gov/BLTWeb2
or.. rather, i'm getting shapes, but the loading doesn't go away to let me click
well..that's a different error than I was getting before..hmm
Veni
@venikunche
Sep 26 2016 14:39
yeah, i see that the loading icon is not going away and i don't see any pula shapes on the map.
Tonia Roddick
@troddick
Sep 26 2016 14:39
they are there.. just all yellow
Veni
@venikunche
Sep 26 2016 14:40
ah ok
i'll dig through the code a little, and see what's going on.
Tonia Roddick
@troddick
Sep 26 2016 14:40
cool. i'll keep working on the password part of the user. I haven't updated github with the code yet
Veni
@venikunche
Sep 26 2016 14:40
sounds good
Tonia Roddick
@troddick
Sep 26 2016 15:20
One feature that I think we should not worry about adding.. because it will take some reconfiguring of the app.. is allowing anyone that is not admin to update their user info. That does not currently exist in the app. (If notAdmin, can't see Users tab to get to users)
to add this functionality, I'd need to add the click event on their name in the upper right corner (which is a function in the userController for when within the user settings area.. and not header area) to bring them to their info..
right now, admin can edit and create other users. I suggest we leave this as-is
Hans Vraga
@HansVraga
Sep 26 2016 15:22
Agreed.
Tonia Roddick
@troddick
Sep 26 2016 15:32
yes, that's why I commented it out. I was hoping I could narrow down the issue.. I think this may have something to do with a setting we told Aaron not to worry about adding to the bltdev server.. since it's just a testing server.. related to arcgis. But I'm not sure.
I'm tempted to get everything else working, move it to the production server under a different name.. just to check all the pula click stuff.. but then I'd have to overwrite the bltservices on production at the same time.. I could bring it over as a new (different name services to prod..)
I don't know much about map-services.. looking on the bltdev server now to see if there's something I can do..
Veni
@venikunche
Sep 26 2016 15:38
yeah, i'm not sure if it's easy to comment out that part and get it to work. In the services.js, I call that service to get PULASHAPEI which is then added to the pula's before they are displayed.
Should I follow up with Aaron to get the map services to work?
Tonia Roddick
@troddick
Sep 26 2016 15:39
let me take a look first.
Veni
@venikunche
Sep 26 2016 15:39
sounds good
Tonia Roddick
@troddick
Sep 26 2016 15:40
it's been awhile.. Looking at arcMap right now. There's a problem with the connection there.
Veni
@venikunche
Sep 26 2016 15:44
ok
Veni
@venikunche
Sep 26 2016 16:46
let me know if i can help with anything @troddick
Tonia Roddick
@troddick
Sep 26 2016 17:32
trying to register the database for arcGIS Server and it's failing. going to ask Aaron about it
Veni
@venikunche
Sep 26 2016 17:55
sounds good
Tonia Roddick
@troddick
Sep 26 2016 18:09
got the arc service working now. just need to go through that code and update because it's all lowercase now. going to take a lunch now..