Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Tom Dyas
    @tdyas
    make cleaner && make build fails due to no access to adapt-web repo:
    git clone git@gitlab.com:unboundedsystems/adapt-web.git web
    Cloning into 'web'...
    Warning: Permanently added the ECDSA host key for IP address '172.65.251.78' to the list of known hosts.
    Permission denied (publickey).
    fatal: Could not read from remote repository.
    
    Please make sure you have the correct access rights
    and the repository exists.
    /src/config/build_support/web.mk:30: recipe for target 'web/.git' failed
    make: *** [web/.git] Error 128
    make: *** [/home/tdyas/Projects/Adapt/adapt/config/build_support/dockerize.mk:36: .DOCKER_MAKE_DONE] Error 2
    Mark Terrel
    @mterrel
    Ok, I'll file a bug for that. I think it's not actually a permissions error in this case, despite the message. Try cloning it manually. So from the adapt repo directory: git clone git@gitlab.com:unboundedsystems/adapt-web.git web
    Oh, I may have spoken too soon. It may be a permissions problem. Investigating and fixing...
    Mark Terrel
    @mterrel
    Ok, adapt-web should be public now. Try make build again. It is somewhat possible that it still gives a permissions error in that context though. If you still see the permissions error, try the manual clone as suggested above. And either way, let me know how that goes and I'll file a bug if needed.
    Tom Dyas
    @tdyas
    I had to manually clone. Maybe the ssh key to authenticate with is not being passed into whatever Docker container things are running in?
    Mark Terrel
    @mterrel
    Yes, that's probably the case.
    Rahul Saxena
    @rksio_twitter
    Mark Terrel
    @mterrel
    Looks interesting. Sounds like a lot of custom work to pull all that together.
    Kirk Ross
    @kirkbross_gitlab

    kirkb@DESKTOP-5BF58I3 MINGW64 /e/Sites/wud/deploy

    $ adapt run k8s-test --deployID app-test
    [13:23:59] Installing node modules [started]
    [13:24:02] Installing node modules [failed]
    [13:24:02] → EBUSY: resource busy or locked, rmdir 'E:\Sites\wud\deploy'
    Error: EBUSY: resource busy or locked, rmdir 'E:\Sites\wud\deploy'
    Code: EBUSY

    Adapt version: 0.3.1
    Mark Terrel
    @mterrel
    Hi Kirk! Thanks for getting this info. Sorry again you're seeing this problem.
    Kirk Ross
    @kirkbross_gitlab
    Node version 12.18 .3
    Windows 10
    GNU bash, version 4.4.23(1)-release (x86_64-pc-msys)
    Mark Terrel
    @mterrel
    Hmm... We haven't done a lot of testing under Windows, so I suspect it's some issue in that general area.
    Do you have any yarn-related configuration anywhere, like maybe a yarnrc file?
    Kirk Ross
    @kirkbross_gitlab
    globally you mean?
    Mark Terrel
    @mterrel
    Yep, globally or in your home directory
    Kirk Ross
    @kirkbross_gitlab
    .yarnrc

    THIS IS AN AUTOGENERATED FILE. DO NOT EDIT THIS FILE DIRECTLY.
    yarn lockfile v1

    lastUpdateCheck 1599800732820

    not much in there
    Mark Terrel
    @mterrel
    Ok, great. I'd like to try to reproduce this on my system. Can I get back to you in maybe an hour or so?
    Kirk Ross
    @kirkbross_gitlab
    Sure... do you have a Windows machine or VM?
    Mark Terrel
    @mterrel
    Yep, I do
    Kirk Ross
    @kirkbross_gitlab
    sweet. thx
    Mark Terrel
    @mterrel
    Oh, wait..one more question for you: You're using MinGW, right?
    I suspect the issue is with Windows generally, not MinGW. But just to check, if you could open either a regular Windows CMD shell or a PowerShell and run that Adapt command again, that would confirm.
    Kirk Ross
    @kirkbross_gitlab
    yes
    MINGW64
    I tried on Windows PowerShell too, run as Admin.
    same result
    Mark Terrel
    @mterrel
    Ok, perfect. That's super helpful.
    Kirk Ross
    @kirkbross_gitlab
    didn't try with the standard windows shell though
    Mark Terrel
    @mterrel
    PowerShell should be fine. No need to.
    Kirk Ross
    @kirkbross_gitlab
    did anyway, and same result :)
    Mark Terrel
    @mterrel
    haha Thanks for checking. :)
    Kirk Ross
    @kirkbross_gitlab
    I'm not supposed to yarn install it locally correct?
    Mark Terrel
    @mterrel
    That's right, there's a version included with Adapt itself.
    So no need to install it. And Adapt wouldn't use your system-installed version anyway.
    Kirk Ross
    @kirkbross_gitlab
    I have a Linux machine and a Mac too, but I develop on my PC.
    Mark Terrel
    @mterrel
    My laptop is Win10, but I don't really do any local dev on it. We mostly use Linux on AWS Workstations for dev. And Adapt's testing is primarily on Linux with some on Mac.
    We just haven't had much interest from Windows users yet, so haven't put the effort into creating testing on Win
    But here you are :)
    Kirk Ross
    @kirkbross_gitlab
    ha
    Did you happen to watch Silicon Valley?
    Mark Terrel
    @mterrel
    Oh, yeah..love that show.
    Kirk Ross
    @kirkbross_gitlab
    Random trivia... my brother played Gavin Belson, Hooli CEO.
    Mark Terrel
    @mterrel
    No kidding?!?
    That basically makes you a celebrity :D